How Does Fing Box generate "Offline" and "In Range" messages?

SystopsSystops Member Posts: 6
First Comment
edited September 2019 in Fingbox
So I had been getting a lot of alerts about my Synology NAS being "Offline" and "In Range" since this device will go to sleep after a specific period of in active use, I decided I would just turn off Alert me on Status Changes Off. However, this morning I am still getting this message, whats even more curious is that it is saying that it is "In Range" which is baffling because this device is a NAS Server with NO WIFI at all. So how can it be showing up as "In Range"? I would expect that designation to be limited to WIFI devices? This NAS does not have any on board or external WIFI adapter, and is hardwired to my network via a managed switch. "Device Alert: 'Synology DS-718+ NAS' in 'Home' is in range" I would love for some help in understanding why or where this message could be coming from? Thanks

UPDATE: I did figure out why I was still getting alerts, however, what I don't understand is the "In Range" alert. The reason I was still getting any alerts was because this device has 2 network adapters as it is configured in Link Aggregation, so only when the LAG IEEE802.3ad  protocol is invoked would this NIC have any data going across it, or a Keep Alive. 
Tagged:

Answers

  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭

    Community Manager at Fing

  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Do you have switches on your network too? 
    The reason you are getting In range alerts could be due to your network set up. 
    Let us know any more details about your set-up.

    Community Manager at Fing

  • SystopsSystops Member Posts: 6
    First Comment
    I will check out that post, however, my network topology while not too extensive, is not that simple either  :) 
    I have Verizon 1 Gig  ISP the Verizon Router is hardwired to my ASUS GT-AX11000, the AX11000 is then hardwired to my Netgear Smart Switch, the Netgear Smart Switch is interconnected via two LAG Ports to a Ubiquiti Managed Switfch. All my LAS devices are connected to my NetGeaer Switch, all my PC's, Printers, Stand alone devices are connected to the Ubiquiti Switch. 
    The NAS device is connected via LAG to my Netgear Switch. 

    Everything works perfectly fine. there should not be anything in my Network Topology that should be causing anything odd. It's a very basic setup. Some people get confused because right now I have 2 Routers in he mix, however, the Verizon Router is in Bridge Mode, so it is not handing out any IP's.  That is all done by my ASUS Router. Eventually the Verizon Router will be pulled from the configuration all together, for right now, I need to leave it as it provides the TV Set Top Boxes with the Internet connection they need and nothing else. 
  • SystopsSystops Member Posts: 6
    First Comment
    edited September 2019
    Unfortunately the post you pointed me to has to do with Multiple Access Points. I do not have multiple Access Points as I am using a Mesh Configuration.  Plus, ALL of my devices, use a Wired setup. They are not using WIFI. So the device showing In Range, is hardwired back to the GT-AX11000. The Wireless Devices are the only devices that could be caught up in any confusion with a Mesh Config, but that would not be affecting my NAS since they are wired right back to the ASUS Router (GT-AX11000) which is where the Fing Box enters my network. It is plugged into my ASUS Router, which is what all of my switches and other devices are connected ultimately back to. So that does not apply in my case.

    I would definitely be curious how my network configuration could be causing this.
  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Ok let me inquire with our support team a bit more. I think it is related to the switch instead of multiple AP's.

    Community Manager at Fing

  • SystopsSystops Member Posts: 6
    First Comment
    I would hope not, because switches are quite common. After having have worked in Development Engineering for over a decade, I might guess a bug in the Fingbox :)   But that is just my humble opinion lol :dizzy:
  • RobinRobin Administrator Posts: 1,147
    1000 Comments 50 Answers 100 Likes 25 Agrees
    admin
    Hi @Systops
    I believe the reason you were able to see those alerts is due to the connection of your NAS with switch. And you use a Mesh network set up as well. 
    Fingbox shows not only roaming Wi-Fi devices but also neighbors wired devices that are transmitting to Wi-Fi devices.

    In other words: if your wired device (A) needs to talk to a wireless device (C) through wireless device (B), the Fingbox passive monitoring can see that interaction taking place as (A)->(C) in the wireless packet headers and enlist (A) as seen the device of the Digital Fence. 

    Fingbox monitors all channels, and if some special wireless activity (A)->(C) is observed, it can also know for sure that (A) is wireless. Until those special activities are observed, though, Fingbox cannot tell for sure whether (A) it’s wireless or not, and in order to provide a comprehensive list, it must show (A) in the list.

    This is why, on some network setups, a wired device appears in the list among wireless ones and get alerts.

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • Systops5Systops5 Member Posts: 33
    10 Comments First Answer 5 Agrees 5 Likes
    ✭✭
    I have tried to reply to this a number of times, and it appears that I now have to have my posts approved. I don't know why. :(  Ok, odd. now it's not complaining. Let me try to post my previous reply.
    I may have to disagree, because my NAS servers don't need to talk to any devices via a wireless connection.  On top of that, that would be extremely confusing if you are looking at wired devices through a wireless Mesh Configuration. That just makes no logical sense to me. I actually came across, a completely different post which I believe may be most similar to my issue
    https://community.fing.com/discussion/775/problem-with-bonded-ethernet-nics-and-wireless-access-points#latest
    This issue talks about a Bonded Connection on the NAS device, which to me seem more likely to be the case since my Synology NAS does have 2 separate NIC's  with 2 separate IP's and MAC addresses.  My believe if that the FingBox is detecting BOTH NIC's, and even though the second interface should only be active when the LAG protocol is activated, it is likely that the second NIC is sending a Keep Alive Event, this KAE is triggering the Fingbox to send a notice, even though the NAS is NOT at all using a wireless setup. I will put money that this is a bug in the way that Fingbox is interpreting the Keep Aline Event :)

    I would really have a very hard time believing that the Fingbox would be basing it's alerts on regular communications on a LAN between an AP (or in my case a Mesh Node) and another wireless device on the same LAN. That would just not make much sense to me.

  • Systops5Systops5 Member Posts: 33
    10 Comments First Answer 5 Agrees 5 Likes
    ✭✭
    I may have to disagree, because my NAS servers don't need to talk to any devices via a wireless connection.  On top of that, that would be extremely confusing if you are looking at wired devices through a wireless Mesh Configuration. That just makes no logical sense to me. I actually came across, a completely different post which I believe may be most similar to my issue (it would appear linking another thread doesnt work)
    This issue talks about a Bonded Connection on the NAS device, which to me seem more likely to be the case since my Synology NAS does have 2 separate NIC's  with 2 separate IP's and MAC addresses.  My believe if that the FingBox is detecting BOTH NIC's, and even though the second interface should only be active when the LAG protocol is activated, it is likely that the second NIC is sending a Keep Alive Event, this KAE is triggering the Fingbox to send a notice, even though the NAS is NOT at all using a wireless setup. I will put money that this is a bug in the way that Fingbox is interpreting the Keep Aline Event :)

    I would really have a very hard time believing that the Fingbox would be basing it's alerts on regular communications on a LAN between an AP (or in my case a Mesh Node) and another wireless device on the same LAN. That would just not make much sense to me.

  • Systops5Systops5 Member Posts: 33
    10 Comments First Answer 5 Agrees 5 Likes
    ✭✭
    OK, I have checked this further, and this is in fact an issue with a Bonded Adapter.  I just checked the two instances of the Synology NAS which show up in the Fing App.  The Adapter that is considered the Primary NIC which is provided it's IP Address from my ASUS Routers DHCP Server and it is listed in the App with both the IP address and MAC address as configured on the NAS, however, the Second NIC which is configured as Bonded since I created a LAG connection, that NIC while it still has it's MAC address, the Fing App is seeing it with out the IP address, it is this second NIC on the Synology NAS which keeps showing up as "Offline" and "In Range". My guess is that this is NOT an Access Point or Router issue, but rather the fact that the Second Adapter still shows up on the Network, however, no IP address is assigned to it, because it is Bonded in the LAG.  This would make far more sense then the whole going through Wireless to Wired through the AP issue.  The fact that the device is sending traffic from both  Network Cards and there are 2 MAC addresses, even though the second NIC is not given an IP, it's still being identified by the Fing App (or Box) as another unique device.

    I would suggest an easy fix for this issue would be to NOT add a device to the Active Devices, or don't send alerts on devices which do not have an IP address or give us the option to device if we want to include devices which are only identified with a MAC address.  Or another way to handle it would be to give us the option to add such a device, or "Hide" such a device from future alerts, this way we can still detect any intrusions based on any device with a unique MAC but No IP, however, if we deem them "Safe" we can ignore them.
  • SystopsSystops Member Posts: 6
    First Comment
    edited September 2019
    Comment Removed By Systops - Duplicate!
Sign In or Register to comment.