Not blocking / pausing traffic

banditti
banditti Member Posts: 10
First Comment
I have a findbox. One of the main things we need it the ability to pause or stop internet traffic to a device.  That has been working.  As of yesterday, if I pause a device, it still routes traffic.

Thoughts?
 1.15.2

Answers

  • Marc
    Marc Moderator, Beta Tester Posts: 2,795
    250 Answers 1,000 Likes 2500 Comments 250 Awesomes
    ✭✭✭✭✭✭✭
    Hi @banditti ...  Has anything changed either on the client or your network since the last time it worked?  Can you confirm that the information you see when you look at the device on your Fingbox matches what is actually associated with the device?  

    Also, make sure the device is using an IPV4 address and has not, for some reason, grabbed an IPV6.  Fing cannot pause or block an IPV6 addressed device.

    Thats Daphnee, she's a good dog...
  • banditti
    banditti Member Posts: 10
    First Comment
    There was a IOS app update.  No IPV6.  The only thing I can possibly see is that in the diffence in how devices are displayed between devices/users.    
  • Marc
    Marc Moderator, Beta Tester Posts: 2,795
    250 Answers 1,000 Likes 2500 Comments 250 Awesomes
    ✭✭✭✭✭✭✭
    One thing to check.  On the iOS device your trying to block, check its Wifi connection to PIZZA WiFi and make sure private addressing is turned off.  Once that's done, then refresh and see if you can see and that its assigned properly and on line.
    Thats Daphnee, she's a good dog...
  • banditti
    banditti Member Posts: 10
    First Comment
    For example "Fire Cube - Master" between the two.  Devices shows black.  Users shows grayed out.  Doesn't block traffic when paused.
  • Marc
    Marc Moderator, Beta Tester Posts: 2,795
    250 Answers 1,000 Likes 2500 Comments 250 Awesomes
    ✭✭✭✭✭✭✭
    This is interesting.  As a test I tried to pause my iPhone and one of my Alexa devices.  The Fingbox display pulsed to show it read the command but neither device paused.  @Robin, can you see if there is something going on with this last release or the service in general?
    Thats Daphnee, she's a good dog...
  • Marc
    Marc Moderator, Beta Tester Posts: 2,795
    250 Answers 1,000 Likes 2500 Comments 250 Awesomes
    ✭✭✭✭✭✭✭
    @Pixel, if your still on line, could you sanity check this for us?  Does pause work for you??
    Thats Daphnee, she's a good dog...
  • banditti
    banditti Member Posts: 10
    First Comment
    Yeah!  I'm not crazy.  At least in this way.....  :)
    Marc
  • Pixel
    Pixel Devon, U.K.Member, Moderator, Beta Tester Posts: 244
    25 Answers 100 Comments 25 Likes First Anniversary
    ✭✭✭
    @Marc unfortunately I can’t access my fingbox, I’m stuck on on “Your device is being recognized, thank you!” 
    I’ll check pause once I get this sorted out.
  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 5,012
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    @banditti
    Is the pause not working for one device or all devices? Can you check?
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • banditti
    banditti Member Posts: 10
    First Comment
    It is all over.  Roku doesn't pause or Block or remove device.  One Fire Cube will blcok but not pause.  The second fire cube will pause.  

    I have a speacial needs child that I need to be able to have a solution that works or very unhappy things happen.  If this device isn't it that is cool, I just need to know.  
  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 5,012
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    @banditti
    Just to confirm, for some devices either the pause or block is working. Is it correct? Roku and Firecube are streaming devices which may have mac randomization enabled on their system by default. This can prevent Fing from blocking and pausing it. Are you able to pause any mobile or laptop device?

    If you still have access to the Internet at this point it could then be one of 3 things that are preventing the block/pause from working.

    • IPv6 – this is a method of communication that some devices use when IPv4 is blocked. Unfortunately, Fingbox cannot block IPv6 communications. If you feel comfortable, and if your router allows it, you can disable IPv6 within your router settings. All devices communicate on IPv4 so it should not impact the average user’s network performance.
    • Incompatible Router – Fingbox pauses Internet using a technique called ARP spoofing. Some routers contain software designed to block ARP spoofing, so prevent Fingbox performing this feature. 
    • Firewalls – Fingbox generally plays very well with firewalls, but like with the routers, there may be some software in the firewall that clashes with the Fingbox software.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • banditti
    banditti Member Posts: 10
    First Comment
    I am running OPNSense as a FW.  No IPv6, it is turned off.  
  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 5,012
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    edited July 13, 2021 #14
    banditti said:
    I am running OPNSense as a FW.  No IPv6, it is turned off.  
    Can you disable it and reboot device and then try to pause/block them via Fingbox. There is a chance that Opensense Firewall is blocking Fingbox from performing its function.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • banditti
    banditti Member Posts: 10
    First Comment
    OPNSense also works as my router.  Cable Modem ==> OPNSense ==> Switch ==> Fingbox, APs and everything else.

    If you are not familiar, OPNSense is a fork of PFSense
  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 5,012
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    banditti said:
    OPNSense also works as my router.  Cable Modem ==> OPNSense ==> Switch ==> Fingbox, APs and everything else.

    If you are not familiar, OPNSense is a fork of PFSense
    I checked with OPNSense and it seems like OPNSense does block Firewall from working. If you want to use the blocking/pausing feature, the arp spoof messages from FingBox may interference how OPNSense works. Our recommendation will be to use OPNSense to block/pause devices. 
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • banditti
    banditti Member Posts: 10
    First Comment
    Thanks.  OPNSense is too complicated for my wife to use when I am not home.  Is there something I can turn off or a rule I can do on OPNSense?
  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 5,012
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    banditti said:
    Thanks.  OPNSense is too complicated for my wife to use when I am not home.  Is there something I can turn off or a rule I can do on OPNSense?
    I have limited experience with OPNSense. I would advice getting in touch with OPNSense and seek advice. I doubt OPNSense works in similar fashion as Fingbox. 

    The way the Fingbox works is through ARP poisoning and DNS Spoofing.  So what is happening is that when you block a single device, the computer DHCP address and DNS entries gets changed and pointed to the Fingbox.  So this device is blocked from getting to the internet or internal resources. 
     
    For more information on ARP poisoning and DNS Spoofing see the following links: 
    Blocking is done by DNS/Blocking Spoofing. 
    https://en.wikipedia.org/wiki/DNS_blocking 
     
    The Fingbox/App work to pause things by a process called ARP poisoning/Blocking. 
    https://en.wikipedia.org/wiki/IP_address_spoofing 
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!