Laptop can't see my Ethernet for devices

Princy557Princy557 North YorkshireMember Posts: 11
First Comment Photogenic
Hope this is the correct place to ask this question.
I have an Acer laptop, it had a major crash a few weeks ago. I have had to re-install W10 Pro.
My problem is that using explorer I can't see my other drives on the system.
I did a netsh and found that the Internet was OK, connected. But Ethernet was not.
I have no idea how to re-connect the Ethernet to the laptop.
Can anyone please advise of what to do next
Princy 557


  • AlbertAlbert Member Posts: 97
    25 Likes 10 Comments Photogenic Name Dropper
    Prrincy557  When you say:: I can't see my other drives on the system,.... do you mean drives external to your LAN connected drives... like a NAS unit ? Or do you have more than one INTERNAL drive ????
    There is a well documented procedure for  making WIN10 aware that there are other drives.
  • Princy557Princy557 North YorkshireMember Posts: 11
    First Comment Photogenic
    HI Albert, thanks for getting back to me.
    Yes, sorry for not being precise. I can't seen my house drives at all.
    I have a couple of NAS devices Now I can use them, but only using their own software. I can't access the actual drives like I could before.
    I can no longer map these NAS drives. I can no longer see the HDD on the other computer (desktop).
    Had a quick look with netsh and it shows my Internet as connected. But Ethernet is disconnected.
    I don't know how to reconnect the Ethernet. I've looked but obviously not asking correct question.
    I've tried everything suggested about connecting windows 10, but it all comes back to lack of Etheernet.
    Any suggestions please.
    Regards Princy557
  • ScoobyScooby Member Posts: 160
    100 Comments 25 Awesomes 25 Likes 5 Answers
    @Princy557 Does your Acer laptop connect to the network via wifi or ethernet? If your Acer laptop only connects via wifi, then netsh may show ethernet as being disconnected. That should be normal.

    What type of NAS devices are you using? Are they older devices that may only support SMB1? Since Windows 10 1709, SMB1 is not installed by default: You may have had it enabled before, but since you had to "re-install W10 Pro", it is not enabled. Microsoft recommends you do not enable SMB1: Here is another Microsoft link that has a list of devices (older), that use SMB1: It is an old list, and not sure if it is updated anymore. I have an older "Linksys" router, with a USB HDD attached. It is in the "list". As I understand the risks, I have enabled it. If you device(s) is/are listed, check to see if an update (software/firmware) is available.

    As for the HDD on the other desktop, you may not see it, if "network discovery" is turned off. To check, click "Start" > "Settings" > "Network & Internet" > "Sharing options". Click "Private", to expand it, if is isn't already, and see what it shows for "Turn on network discovery". I don't remember, but it may be turned off, by default. It should be turned off for "Guest or Public". (Do not recommend enabling it for "Guest or Public").

    Hope this helps.

  • Princy557Princy557 North YorkshireMember Posts: 11
    First Comment Photogenic
    edited December 2020
    Hi Scooby,
    First off , sorry for the long delay. I'm back , illness's early in the year then other problems which all in all has delayed me by a huge amount. Also a  number of things have started being strange on the system
    OK, I'm in my seventies and technology has run away from me in a big way. Excuse for being thick maybe, ha
    OK you say to look using netsh , hm never used it before and just looked and left me cold.
    On my system  I have a desktop, laptop, Buffalo LS420D, Synology DS216+II, and a WD PR4100. Router is a Vodafone. and the switch is a netgear giga something or other.
    Windows 10, fully update . Virus check is MS built in one.
    OK Problem is now. Desktop: I can see DS216 and use it fully, I can see PR4100 and use it fully.  Buffalo not seen on the network. Saying that FING finds it no problem. I can't access it from Windows Explorer.  I can also access it via a login on the browser which allows me to make changes.
    OK between all the NAS's SMB is 1,2,3
    Network discovery is on , guest and public are off.
    LAPTOP: ditto
    I'm totally flummoxed
    Oh Yes, all devices are firmware as far as they can get, the latest available.
    Totally spent hours of reading  on this and getting nowhere very slowly.
    Any advise or suggestions. Polite of course. I'm pretty sure it's going to be a simple to the experts (snivel Grin)
    PS the Acer is WiFi the desktop hardwired.
  • ScoobyScooby Member Posts: 160
    100 Comments 25 Awesomes 25 Likes 5 Answers
    edited December 2020
    Sorry to hear you were ill and had other problems going on. Hope all is better, now.

    I believe the issue may be with the Buffalo LS420D NAS. It might still be using SMB1. As I referenced above, Windows 10 versions 1709, and later, do not support SMB1, by default. Please see this link from Buffalo:

    However, before looking at the above link, check to see if your Buffalo LS420D has been updated to the latest firmware. Here is a link to the latest firmware:

    If your Buffalo LS420D was updated, see if SMB2 can be enabled, as the first link shows. If not, follow the procedures to enable SMB1, within Windows 10, for both your Acer laptop and your desktop. Make sure you understand the risks, before doing so, and do so, at your own risk.

    Hopefully, you can enable SMB2 on your Buffalo NAS. Good luck!

  • Princy557Princy557 North YorkshireMember Posts: 11
    First Comment Photogenic
    Thanks Scooby,
    I've been through both of the above links and my system is set up correctly.
    Desktop: is working fine, I can access, update, copy, move from both Explorer and web.
    Explorer, the LS420D is visible in the list.  Darn it I was going to drop little pics in..
    Right It's there fully visible in t he Network list. If I click on it.  I get Windows cannot access  \\LS420D6F2..... check spelling etc.
    Diagnose says it finds no problems.
    Software runs but no access to LS420D. 
    It shows I'm on the correct Workgroup, the correct IP address, correct subnet, correct gateway, MAC address, Firmware is up to date  1.86
    If I try to Map a drive I get the (X) could not map the share. I do have a folder 'share'  on the LS4240D
    I have two other NAS devices an DS216+II, totally  accessible and usable.
    The other is a WD PR4100 which gives the same errors as the LS420D.
    Windows 10 Pro: Fully updated.
    SMB 1 is set
    I am totally flummoxed over this . I've been through so many items on the web, tried all sorts of suggestions.
    I am of course assuming the Laptop is OK because I do have full use of the DS216+II
    Anyone out there with suggestions , there's not much hair left ha ha

  • ScoobyScooby Member Posts: 160
    100 Comments 25 Awesomes 25 Likes 5 Answers
    What IP Address does your Acer laptop have?

    What IP Addresses do your desktop and Buffalo LS420D have?
  • Princy557Princy557 North YorkshireMember Posts: 11
    First Comment Photogenic
    Thanks for reply
    • LS420
    • Acer
    • Desktop
    all on
    all on the same workgroup
    Thanks for looking at this problem

  • ScoobyScooby Member Posts: 160
    100 Comments 25 Awesomes 25 Likes 5 Answers
    All three are on the same network, which is good.
    The only other option I can think of is it being a permission(s) issue. Have you checked the permissions on the folder "share"? Was it possible to give permissions to the user name on the Acer laptop? If so, when you reinstalled Windows 10 on the laptop, even if you used the same user name, the Buffalo NAS might think it is not the same account.
Sign In or Register to comment.