Why is the fingbox performance monitoring giving bad results when connected to a switch

Dear all, when I connect my fingbox to a switch which is connected to the router and I do a performance measurement then, it gives me around 1/3 of the speed it should be. (30Mbps instead of the 90Mbps I have according to other measurements) When I directly connect it to the router, it does give me the proper results. Is the Fingbox not compatible with a switch? Please note: A PC that is connected to the switch does yield the expected results when using MLAB

Best Answer

  • BK303BK303 Member Posts: 7
    First Answer First Comment Photogenic
    Accepted Answer
    When everything is working properly, all Ethernet devices are compatible with each other and built to industry standards, and I have never seen compatibility issues with wired Ethernet unless the switch port was defective.  The Ethernet switch may be poor quality and cause low data throughput.  This may occur if you have turned on port mirroring or other L2 features on the switch (if the switch has web management features), or if the switch is having lots of ethernet layer transmission errors due to bad power or faulty cables.   I would first try to connect your computer or laptop directly to the switch with Ethernet cable and see if the Internet speed performance measurement from a browser is also worse for your computer when connected to the switch.  You can check the Fingbox's Ethernet connection speed mode (10Mbps, 100Mbps, or 1Gpbs) on the phone app for Fingbox by selecting your Fingbox network, click gear icon (upper-right), then you should see Fingbox software version and MAC displayed....scroll down to Info and find Link Speed.  If the connection is not the maximum speed your switch supports, try using a different Ethernet cable or different port on the switch.   

Answers

  • douwevtdouwevt Member Posts: 4
    First Comment Photogenic
    Hi BK303, thank you for your answer. Measuring the speed from the computer(s) connected to the switch yielded the expected results. The fingbox reports 1Gb connection speeds when connected to the switch as well as when connected to the router. Using a different port on the router does not make any difference for the Fingbox. Also changing the cable did not make any difference. The FingBox only reports the correct speeds when connected to the router directly.
    So I tried to switch off the "green" features, and there I found the problem, when I disabled the low power idle for the switch, the problem disappeared!! Unfortunately it is not a per port configurable item, so I have to disable it for the whole switch, but perhaps all devices benefit from having it switched off, so I will leave it like this.
    Thanks again! Problem solved.
    BK303
  • Lee_BoLee_Bo Member Posts: 273
    100 Comments 100 Likes 5 Answers 25 Agrees
    ✭✭✭
    Very similar to have the "default/extended" setting set to "extended" on a PoE switch:
    • Extend function extending max PoE transmission distance from 100 meters to 250 meters
    • Extend function sets bandwidth to 10 megs.

  • BK303BK303 Member Posts: 7
    First Answer First Comment Photogenic
    douwevt  Great job figuring out how to work around switch performance issue out by fiddling with the "green" power options, probably that refers to support for "Energy Efficient Ethernet (EEE) Low Power Idle (LPI) mode defined in IEEE 802.3az, which optionally allows power saving by switching off part of the integrated Local Area Network (LAN) controller." 

    Perhaps Lee_Bo's comment provides a hint as to why this feature could degrade performance, if the EEE feature was accidentally causing the link to down speed to 10Mpbs or just a some bad implementation on either the switch or Fingbox side causing long delays as the link went into and out of idle.   I sometimes do turn on that EEE feature on my own switches, so I'll have to watch out that it doesn't cause throughput issues when I enable it.....learn something new everyday!
    douwevt
Sign In or Register to comment.