Health check code: N802.

CarloCarlo Padova (Veneto/Italia)Member, Beta Tester Posts: 28
10 Comments First Anniversary 5 Likes 5 Awesomes
✭✭
Good morning.
After the transition to the last release (2.1.0) the error reported below often appears several times a day.
I am told that the internet connection is not working but the report is not correct because there are no interruptions to the internet service.
I am waiting for indications / resolutions.
Regards



You have connectivity problems

Your device is connected to the network, but network has limited connectivity. You cannot reach Internet, please check your router.Health check code: N802.






Answers

  • kltaylorkltaylor Moderator, Beta Tester Posts: 1,231
    1000 Comments 500 Likes 50 Answers 100 Awesomes
    ✭✭✭✭✭✭
    Hi @Carlo welcome to the community and thanks for asking your question.
    If you are receiving a notification that states that there is a problem with your connection, for Fing Desktop that typically means that there is an interruption based on an SNMP response to your router, not to your internet connection.
    Let's try resetting the entire network, powering off the modem, router and the computer that you're receiving the notification on.  Then, power on the modem, wait until it completely boots, then do the same thing with your router, again waiting until it finishes it's power on sequence, and lastly power on your computer.
    "There's a fine line between audacity and idiocy."
    -Warden Anastasia Luccio, Captain
    Robin
  • CarloCarlo Padova (Veneto/Italia)Member, Beta Tester Posts: 28
    10 Comments First Anniversary 5 Likes 5 Awesomes
    ✭✭
    Thanks for the reply
    With the previous sw version the problem rarely happened now happens continuously.
    I had already carried out the steps indicated but without any change.
    However modem and router (tp-link vr900) are inside the same device.
    In my opinion, the problem has become greater with the latest release.
    Regards

  • RobinRobin Administrator Posts: 3,079
    2500 Comments 100 Answers 250 Likes 100 Awesomes
    admin
    Hi @Carlo
    Can you share the screenshot of timeline of the alerts from Notifications area. The notification you are referring comes when your device was either in sleep mode or the Fing desktop was unable to connect to the internet. When you click on the notification, it takes you to home tab to either re-run the scan or check if there is any error. When you manually scan or refresh the network, then Fing desktop re-runs the network scan and is able to talk to its servers and run the checks identifying everything is working alright.  

    The Connectivity alert is only for that particular time when Fing desktop was unable to run checks due to the device was in sleep mode or the internet was disconnected. You can always refresh the scan to make sure if everything is working alright at the current time.  

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • CarloCarlo Padova (Veneto/Italia)Member, Beta Tester Posts: 28
    10 Comments First Anniversary 5 Likes 5 Awesomes
    ✭✭
    Thank you,
    I enclose the last report in chronological order, but at least a dozen have occurred since this morning.
    It could be that the thing is has some connection with the system that goes into suspension ...
    During the error phases, it was necessary to refresh several times because the situation indicated that the system was working correctly.
    I also tried to perform an internet speed test while the application indicated that there was no connection: test performed perfectly!
    Regards




  • RobinRobin Administrator Posts: 3,079
    2500 Comments 100 Answers 250 Likes 100 Awesomes
    admin
    Hi @Carlo
    I got in touch with our developers and to update you when the Fing desktop is doing its normal health check while running in background, there are chances of unreliable DNS resolution by router and once it goes unstable then Fing desktop catches that and thus warns you. Once you refresh the scan then it is able to actively work and thus everything is normal on Fing desktop.
    If you configure the router dns settings with 8.8.8.8 then you will find there will be no errors or alerts. DNS resolution going unreliable by router is common.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • CarloCarlo Padova (Veneto/Italia)Member, Beta Tester Posts: 28
    10 Comments First Anniversary 5 Likes 5 Awesomes
    ✭✭
    Thanks for the prompt answers.
    I have implemented the suggestion indicated in the configuration of the modem-router as DNS 2 because in DNS 1 the IP address of the Pi-hole filter is instantiated.
    It still seems to work.
    I will keep it under observation and in the next few days I will give updates.
    Good job.

    Robin
  • CarloCarlo Padova (Veneto/Italia)Member, Beta Tester Posts: 28
    10 Comments First Anniversary 5 Likes 5 Awesomes
    ✭✭
    Hello Robin,
    after two days of enslavement I inform you that the problem persists.
    Thanks for your attention, greetings.

  • RobinRobin Administrator Posts: 3,079
    2500 Comments 100 Answers 250 Likes 100 Awesomes
    admin
    Carlo said:
    Hello Robin,
    after two days of enslavement I inform you that the problem persists.
    Thanks for your attention, greetings.

    Can you share the health check report with us and the screenshot of the error? Thanks
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • CarloCarlo Padova (Veneto/Italia)Member, Beta Tester Posts: 28
    10 Comments First Anniversary 5 Likes 5 Awesomes
    ✭✭
    Hello
    I hope I have understood correctly.
    Thank you




  • RobinRobin Administrator Posts: 3,079
    2500 Comments 100 Answers 250 Likes 100 Awesomes
    admin
    Thanks @Carlo
    I will update you as soon I have some new information.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • CarloCarlo Padova (Veneto/Italia)Member, Beta Tester Posts: 28
    10 Comments First Anniversary 5 Likes 5 Awesomes
    ✭✭
    Hi Robin,
    I noticed that the error has turned into a warning.
    So no longer a red signal but a yellow one.
    Furthermore, in the last two days the reports have in any case decreased.
    Until now, there have not been any.
    Thank you

    Robin
  • br14nhbr14nh Member Posts: 4
    First Comment Photogenic
    edited September 13
    I have the same problem, unfortunately I am unable to mute the notification by any interaction with the question mark or any other way.  It's also showing up as a "Fail" for me, not a warning - I have the latest desktop ver 2.2.0
    I do not have any issue reaching the internet.
    Any thoughts welcome....!

  • RobinRobin Administrator Posts: 3,079
    2500 Comments 100 Answers 250 Likes 100 Awesomes
    admin
    edited September 15
    Hi @br14nh
    Are you using Windows or Mac device? There can be an issue where you clear the router cache and the computer(s) retain the previous settings. This is the procedure to clear the cache from the router: 
    For Windows:
    • Turn off both your router & modem. 

    • While they are off, clear your internet cache from all browsers, and close all browsers. 

    • Go to command prompt (cmd) run ipconfig /flushdns 

    • Then run ipconfig /release 

    • Run ipconfig /renew 

    Run the scan on Fing desktop again.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • br14nhbr14nh Member Posts: 4
    First Comment Photogenic
    Hi Robin,

    Thanks for your reply,
    I'm running a Windows 7 Pro 64 bit machine. Having read through the above, I've tried those steps before posting, it didn't seem to make any difference.   I was hoping there was some way to mute or have desktop "ignore" the notification, as it doesn't have any impact on what I do (other than needing to mark them all read and then ignore them myself).  Even when I get the notification while I'm sitting at the PC, I can refresh manually and it comes back clear straight away, so I don't see any benefit in the notification.
  • RobinRobin Administrator Posts: 3,079
    2500 Comments 100 Answers 250 Likes 100 Awesomes
    admin
    @br14nh
    If you click on the (?) icon next to warning then you can mute those notifications. On Windows 7, Fing desktop runs on best effort basis. Fing Desktop is compatible with Windows & macOs operating systems. The following versions are compatible:
    • Fing Desktop should support any version of Windows that is still within its extended support lifetime  to current version. Windows 10  is recommended. Windows Server versions are not included
    • Fing Desktop supports macOS 10.13 (High Sierra) and later to current version
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • br14nhbr14nh Member Posts: 4
    First Comment Photogenic
    Hi Robin,
    When I click on the (?) icon all that happens is it opens a dialogue box that asks "Could  not solve your problem?" beside a blued button labelled "Get Advice Now" , as shown on this page:
    There's no option that will mute or silence the notification.  Is that likely to be because I'm running Win 7 ?




  • RobinRobin Administrator Posts: 3,079
    2500 Comments 100 Answers 250 Likes 100 Awesomes
    admin
    Hi @br14nh
    Once the scan is finished and you get the warnings then you need to click on (?) to mute those. If this is not appearing then can you share the healthcheck report with me? Thanks
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • br14nhbr14nh Member Posts: 4
    First Comment Photogenic
    Hi Robin,
    Here's a link from when I last tried to share a query:
    - I hope that's what you mean; otherwise, I'm getting the (?) appearing but when I clickon it, there's no option to mute.  It just appears as the large dialogue box, exactly the same as shown on the page I linked to -
    Cheers,
    Brian




  • RobinRobin Administrator Posts: 3,079
    2500 Comments 100 Answers 250 Likes 100 Awesomes
    admin
    Thanks @br14nh
    I am seeking further advice on this one and I will update you once I have some new information. :smile:

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
    br14nh
Sign In or Register to comment.