IOS 14, Fing thinks I keep leaving

PaPaTheGManPaPaTheGMan Member, Beta Tester Posts: 6
First Comment Photogenic

just updated my iPhone to IOS 14 and now Fing thinks I keep leaving home. How do I fix this?

tebasham
«1

Answers

  • StevePSteveP Member Posts: 3
    First Anniversary 5 Likes First Comment Photogenic
    I have iOS 14 beta loaded on a test iPhone and started seeing my Fingbox detecting it as a new device more than once. It turns out there is a new anti tracking feature in iOS 14 called "Use Private Address". It is found under Settings/Wi-Fi/SSID and should probably be turned off for your Fingbox managed network. It will periodically change the MAC address of your device for that particular SSID.
    Bnelms
  • RobinRobin Administrator Posts: 2,828
    2500 Comments 100 Answers 250 Likes 100 Awesomes
    admin
    Thanks for the information @SteveP. Really helpful.

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
    Ferlauto
  • MegachipMegachip Member Posts: 1
    First Comment Photogenic

    There is a same feature within android. Ill guess since version 10

    Robin
  • andyorkneyandyorkney Member Posts: 6
    Photogenic First Comment
    This feature, along with other issues has made Fing unusable on my network. Looks like either I have to modify lots of devices or find other ways to manage in Fing. Doesn’t help that Fing is crashing 9 out of 10 attempts to launch. Has been a huge disruption, so thanks for the update, at least I might be able to manage a mission critical devices without dumping Fing box altogether 
  • andyorkneyandyorkney Member Posts: 6
    Photogenic First Comment
    Update to Fing app has fixed the crashing issue, thank you 😀. Gonna suggest to Apple that there is an additional setting for trusted networks so that we can keep the “use private address” but stop the activity on named trusted networks. 
  • FabianFabian Member, Beta Tester Posts: 41
    10 Comments 5 Likes Name Dropper Photogenic
    @andyorkney The Private Address feature can be disabled.



    Here's a link, https://support.apple.com/en-us/HT211227.
  • andyorkneyandyorkney Member Posts: 6
    Photogenic First Comment
    Sure, I’m aware it can be disabled, but the point is this protects privacy and reduces hack attempt success probability hugely on public networks. It would be great to retain the feature but show a recognised address on know private networks so that those of us who have features like Fing on our home networks can continue to protect our networks from intrusions etc, while gaining the new security features on public networks. I’d like to think all of us here testing iOS 14 might us want to make that feature request?

    Fabianidea2gorashj
  • SAUSAGESSAUSAGES Member Posts: 1
    First Comment Photogenic

    Agree - really annoying (but not critical for me as a single iOS 14 device at home).

    Shows it works though!

  • DavidFDavidF Member Posts: 27
    5 Answers 10 Comments 5 Likes Name Dropper
    ✭✭
    A couple of points/thoughts: 

    1. Given the screenshot above it looks like you can turn this off on a network by network bases, so there is no reason it should impact your home network if you do not want it to do so. The setting is under the SSID, so can be off or on per network. 

    2. The android implementation of this (randomized MAC address) is also per SSID. However, once it randomizes a MAC address it keeps it for that network and does not change it again until you leave or rejoin the network (i.e. forget network). So even when enabled once you track the MAC back to the phone/device you are stable until you make changes manually. I have never seen a phone re-randomize the MAC on an existing network. I assume Apple would do the same but would be interested to hear how it plays out in testing. 
  • SparksSparks Member, Beta Tester Posts: 81
    10 Comments First Anniversary 5 Likes Photogenic
    ✭✭
    edited July 17
    I still am unable to use FING with IOS 14 as it crashes. And I have turned off the private address option in IOS 14 as it effects my iPhone and my Apple Watch that has Watch OS7.

    UPDATE: I have removed FING and reinstalled, seems to be working. I will see later if it continues to crash.
  • MarchpMarchp Member, Beta Tester Posts: 1
    First Comment Photogenic

    Hello,


    I am also running IOS14, and “Private Address" was automatically disable for my home WiFi.


  • JonMartinJonMartin Member Posts: 3
    First Comment Photogenic
    Slightly off topic but I have also had trouble with the MAC address changing due to combinations of the lower two bits of the upper byte changing.  This is due to some devices using the multicast or local bits to give themselves an extra address or three.  So far Fing has not recognized these as the same mac address.  More on these bits here https://en.wikipedia.org/wiki/MAC_address 
  • wmhwmh Member Posts: 1
    First Comment Photogenic
    Is Fing Devs going to update the notification function to recognize apple products with same hostname as the same device to avoid the "New device-but-not-really" spam when friends visit the Wi-Fi? Can't tell them to please turn off the private mode so they can get hacked.
    Adampk17idea2goKensingtonrashj
  • KensingtonKensington Member Posts: 2
    First Comment
    Seems like all iOS and current Android devices use random MAC addresses now, and we can't tell friends to let them get tracked by us, not even at home. Device recognition should use the hostname for those MAC address ranges assigned to Apple (not sure how this would work with Android), else the entire Fing proposition becomes pointless. I see this as an essential threat to the company, so I'm a bit surprised they seem clueless. I mean, the iOS 14 beta was available for some time.
    Fing_a_me_Bob
  • DavidFDavidF Member Posts: 27
    5 Answers 10 Comments 5 Likes Name Dropper
    ✭✭
    MAC randomization has been around well before IOS14. Randomization only occurs when joining the network - it is not randomized on every visit. It can also be disabled, at least for Android. It may take a little more work when a new device joins, but overall I am not sure it is a big issue. 
  • KensingtonKensington Member Posts: 2
    First Comment
    David, that was true until yesterday. Now iOS 14 randomised MAC Adresse even on known networks with a new one every couple of hours. 
  • DavidFDavidF Member Posts: 27
    5 Answers 10 Comments 5 Likes Name Dropper
    ✭✭
    Kensington, Odd - the wifes phone is on IOS14 and has not changed at all from the randomized MAC it had when it joined the home network. I will keep an eye out for it. 
  • stormteech383stormteech383 Member Posts: 2
    First Comment Photogenic
    I have the same problem . . .Fing thinks I am leaving/returning several times a day.
    ChuckWhite
  • ibashibash Member Posts: 1
    First Comment

    iOS 14 has new privacy setting for location tracking so that location is approximate: https://9to5mac.com/2020/08/12/ios-14-precise-location/


    Check Settings -> Fing -> Location and make sure “Precise” is on

  • MarcMarc Moderator, Beta Tester Posts: 1,658
    100 Answers 1000 Comments 500 Likes 100 Awesomes
    ✭✭✭✭✭✭
    I don’t think that is what is causing this.  I have precise location on for Fing and I’m also having this issue.  @Robin, please add this to the list of iOS 14 idiosyncrasies....  Unless you have a fix for it?
    Thats Daphnee, she's a good dog...
    Fing_a_me_Bob
  • MarcMarc Moderator, Beta Tester Posts: 1,658
    100 Answers 1000 Comments 500 Likes 100 Awesomes
    ✭✭✭✭✭✭
    David, that was true until yesterday. Now iOS 14 randomised MAC Adresse even on known networks with a new one every couple of hours. 
    According to Apple, the private network function is per network for iOS 14. Not constant randomness.  Unless you have information to the contrary you can post?

    Linked from https://support.apple.com/en-us/HT211227

    Use private Wi-Fi addresses in iOS 14, iPadOS 14, and watchOS 7
    To further protect your privacy, your iPhone, iPad, iPod touch, or Apple Watch can use a different MAC address with each Wi-Fi network.
    To communicate with a Wi-Fi network, a device must identify itself to the network using a unique network address called a media access control (MAC) address. If the device always uses the same Wi-Fi MAC address across all networks, network operators and other network observers can more easily relate that address to the device's network activity and location over time. This allows a kind of user tracking or profiling, and it applies to all devices on all Wi-Fi networks.
    To reduce this privacy risk, iOS 14, iPadOS 14, and watchOS 7 use a different MAC address for each Wi-Fi network. This unique, static MAC address is your device's private Wi-Fi address for that network only.
    Thats Daphnee, she's a good dog...
  • Fing_a_me_BobFing_a_me_Bob Member Posts: 1
    First Comment

    Yep. Confirm this is happening to me to. Ios14 has stopped this feature working.

  • OnfusOnfus Member Posts: 1
    First Comment

    +1 - We have multiple devices upgraded today and this is happening - on the network and just got a notification that I had left.

  • wmillikwmillik Member Posts: 1
    First Comment
    Happening to me too. Continual leaving & arriving
  • DrosophDrosoph Member Posts: 1
    First Comment
    edited September 21

    Have you disabled the “Private Address” setting that is now on your WiFi settings yet? It randomizes your MAC address and might be causing this issue. ???

    MarcOnfusJeffWI
  • MarcMarc Moderator, Beta Tester Posts: 1,658
    100 Answers 1000 Comments 500 Likes 100 Awesomes
    ✭✭✭✭✭✭

    Turning off the private address feature should clear it up. It worked for me.

    Thats Daphnee, she's a good dog...
    OnfusJeffWI
  • RevTemerityRevTemerity Member, Beta Tester Posts: 1
    First Comment First Anniversary Photogenic
    Okay, that was annoying. Thanks, all, for the fix.
  • Adampk17Adampk17 Member, Beta Tester Posts: 6
    First Comment Photogenic
    Ideally we wouldn't need to turn this feature off in iOS 14, it's a good feature honestly.  But managing by MAC address is pretty entrenched and will take a while to evolve.
  • Mike_DuncanMike_Duncan Philadelphia suburbsMember Posts: 4
    First Anniversary Name Dropper First Comment Photogenic
    Apple Watch OS 7 also implements "private address" on its WiFi connection, which results in "new" Watches showing up, just like we were seeing for the iPhone.  To fix: open up the Settings App on your watch (the gear icon), go to the WiFi settings and for each SSID that you use, turn off the Private Address setting.
    Regards, Mike
    Mike Duncan, Retired IT Manager


    MarcRobin
  • RobinRobin Administrator Posts: 2,828
    2500 Comments 100 Answers 250 Likes 100 Awesomes
    admin
    Thanks @Mike_Duncan @Marc

    Our engineers are working on new ios14 updates as it was not publically released before so our developers could not test it.  
     
    We will investigate this issue and we will work on a fix. In meantime, in order for Fing app to work with ios14, you might need to disable "Use Private Address" and the issue will be resolved. To disable the Private Mac address, 


    1. Open the Settings app, then tap Wi-Fi. 

    1. Tap the information button next to a network. 

    1. Tap Private Address. 


    Thanks for bringing this to our attention. 


    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
Sign In or Register to comment.