Weird behavior of Fing Desktop

JH2574JH2574 Member, Beta Tester Posts: 5
First Comment Photogenic
edited August 31 in Fing Desktop discussions
Hi,

I noticed some weird behavior in Devices view recently. Basically I saw different results depending upon which sorting field I chose.

For example, when I chose “State” for sorting field, I got

However, when I switched the sorting field to “Name”, both the refresh timestamp and total number of devices changed:  

Also, when I chose “State” as the sorting field, I saw

But if I changed the sorting field to “Name”, both “Details” and “Changed” fields show different values:


I wonder if anyone experienced the similar problem? Any suggestions about how I can resolve this problem?

Thanks.

Answers

  • MarcMarc Moderator, Beta Tester Posts: 1,658
    100 Answers 1000 Comments 500 Likes 100 Awesomes
    ✭✭✭✭✭✭
    @JH2574. I moved this to the fing desktop area for visibility and relevance.
    Thats Daphnee, she's a good dog...
  • RobinRobin Administrator Posts: 2,828
    2500 Comments 100 Answers 250 Likes 100 Awesomes
    admin
    Hi @JH2574
    Thanks for the feedback. In case if it is a bug impacting many users, can you put: 
    OS name / OS version, desktop version, any VPN used? 
    Thanks again. 
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • JH2574JH2574 Member, Beta Tester Posts: 5
    First Comment Photogenic
    Hi, it's Fing Desktop 2.1.0 running in Windows 10 2004 (10.0.19041.487). No VPN is used. Thanks.
  • RobinRobin Administrator Posts: 2,828
    2500 Comments 100 Answers 250 Likes 100 Awesomes
    admin
    JH2574 said:
    Hi, it's Fing Desktop 2.1.0 running in Windows 10 2004 (10.0.19041.487). No VPN is used. Thanks.
    Thanks I am seeking developers' advice on this one and I will update you once I have a reply. In meantime, Can you try to delete the network identified by Fing desktop from Fing mobile app and then scan the network again to see if the error persists?
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • JH2574JH2574 Member, Beta Tester Posts: 5
    First Comment Photogenic
    I deleted the device associated to IP address 192.168.2.42 from Fing mobile. Although it showed up in Fing Desktop after I refreshed the list, I could not edit it (e.g., customize the device name or even confirm it's mine) from Fing Desktop afterwards. BTW, it seems this problem occurred to other new devices I added to my LAN recently, too.
  • RobinRobin Administrator Posts: 2,828
    2500 Comments 100 Answers 250 Likes 100 Awesomes
    admin
    JH2574 said:
    I deleted the device associated to IP address 192.168.2.42 from Fing mobile. Although it showed up in Fing Desktop after I refreshed the list, I could not edit it (e.g., customize the device name or even confirm it's mine) from Fing Desktop afterwards. BTW, it seems this problem occurred to other new devices I added to my LAN recently, too.
    Instead of deleting device, Can you delete the whole network identified by Fing desktop and then scan using Fing desktop and then check? thanks
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • JH2574JH2574 Member, Beta Tester Posts: 5
    First Comment Photogenic
    Hi Robin,

    Could you tell me how I can delete the network from Fing Desktop?

    Thanks,
  • RobinRobin Administrator Posts: 2,828
    2500 Comments 100 Answers 250 Likes 100 Awesomes
    admin
    JH2574 said:
    Hi Robin,

    Could you tell me how I can delete the network from Fing Desktop?

    Thanks,
    You need to either use the web app and delete the network from there or use the Fing mobile app and go to all networks and then select the same network name as identified by Fing desktop and then delete it and go to Fing desktop to perform another scan.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • JH2574JH2574 Member, Beta Tester Posts: 5
    First Comment Photogenic
    Hi Robin,

    I deleted the network from the web app and recreated it from scratch per your suggestion. Now everything seems working as expected.

    Thanks.
    Robin
Sign In or Register to comment.