FING service not found on Mac

SparksSparks Member, Beta Tester Posts: 81
10 Comments First Anniversary 5 Likes Photogenic
✭✭
This seems to be a continuing problem. I open FING and parts are missing or it says FING service missing, The only way to get FING to function is reboot. I also sometimes get this screenshot below.

Best Answer

  • RobinRobin Administrator, Fing Team Posts: 3,785
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Accepted Answer
    Sparks said:
    Thanks, ran the two commands, and will see what happens. Anti Virus is required here on multi levels. I guess I am not the only one with this problem, so can it be added to future installations? So that every time there is an OS upgrade this will not happen.
    I will definitely pass this feedback to our developers for review. Thanks again
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!

Answers

  • SparksSparks Member, Beta Tester Posts: 81
    10 Comments First Anniversary 5 Likes Photogenic
    ✭✭
    I came back to my iMac after dinner and found the app box with a message FING service not initialized, contact support. This is happening many times, But rebooting every time cuts into my work day.
  • RobinRobin Administrator, Fing Team Posts: 3,785
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Hi @Sparks
    It seems like you have any application running on your device like antivirus which is disabling the fing agent.
    You can run this commands as follows:

    1 - sudo launchctl disable system/com.fing.service.plist
    2 - sudo launchctl load -w  /Library/LaunchDaemons/com.fing.service.plist

    I'm not sure anti-malware won't block again, in this case, you will have to configure well anti malware.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • SparksSparks Member, Beta Tester Posts: 81
    10 Comments First Anniversary 5 Likes Photogenic
    ✭✭
    Thanks, ran the two commands, and will see what happens. Anti Virus is required here on multi levels. I guess I am not the only one with this problem, so can it be added to future installations? So that every time there is an OS upgrade this will not happen.
  • SparksSparks Member, Beta Tester Posts: 81
    10 Comments First Anniversary 5 Likes Photogenic
    ✭✭
    edited August 2020
    Well this morning my FING again not working. Tried the commands nothing. I guess I have to reboot. I rebooted same message FING service not available contact support. Can you provide the link to download the Beta for Mac again? I installed the non beta but still will not load FING service.

    UPDATE: I tried again using the commands this time it worked. I disabled the virus detector but the problem persisted.
  • RobinRobin Administrator, Fing Team Posts: 3,785
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Hi @Sparks
    Are you still facing the trouble? Also, when you disable the anti virus, you need to restart the device and then if the problem persists, try those commands to load the Fing agent service.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • SparksSparks Member, Beta Tester Posts: 81
    10 Comments First Anniversary 5 Likes Photogenic
    ✭✭
    OK thanks, I didn't know about the restarting of the device.
    Robin
Sign In or Register to comment.