DNS not working properly (code W802)

robbe58
robbe58 Member Posts: 2
First Comment Photogenic
edited July 25, 2020 in Fing Desktop discussions #1
Hello, my internet connection works but I constantly get a warning in Fing about DNS resolution.
When I do a ping towards my DNS servers no errors appear.
I also use a VPN connection to go online.
All other internet-related tools and progs are doing OK also.
(Dropbox, Google Drive, Mega, OneDrive, Plex Media Server, QNAP, Drobo, Goodsync, etc)

What should cause this problem? Can anyone help me out?
Is there something wrong in my configuration (network, registry, settings,...)

I already want to thank everybody who makes an effort to give me a solution or tip(s) about this.

Regards,
Rudi, Belgium

Answers

  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,885
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Hi @robbe58
    Are you using any VPN while you receive this error? Can you disable the VPN and then refresh the scan if the error appears? Also, you can try to use this link to flush the DNS and then manually refresh the scan to check again: https://www.technipages.com/flush-and-reset-the-dns-resolver-cache-using-ipconfig

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • robbe58
    robbe58 Member Posts: 2
    First Comment Photogenic
    Hi Robin,
    First of all. When I use a VPN I can go online without any problem.
    My updates, download, internet tools,... All those things are working fine with or without using a VPN.
    It is just this annoying notification error code (W802) that I like to know where this comes from.

    When I disconnect the VPN then after a refresh there is no 'error' notification.
    Everything on the Home page of Fing is green (after a refresh), as it should be.
    All underneath commands I already tried out and executed.
    ipconfig/ flushdns --> ipconfig/ registerdns
    As you suggested I also executed the Powershell command Clear-DnsClientCache
    I already changed the (DHCP) IP addresses of my provider to the DNS servers of Google.
    I'm not an expert but in my opinion, I think there is a setting problem somewhere in the registry.

    Thank you for giving me an answer.
    Hope someone can help me out.

    Regards,
    Rudi, Belgium
     


  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,885
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Thanks @robbe58

    The notification you are referring comes when your device was either in sleep mode or the Fing desktop was unable to connect to the internet. When you click on the notification, it takes you to home tab to either re-run the scan or check if there is any error. When you manually scan or refresh the network, then Fing desktop re-runs the network scan and is able to talk to its servers and run the checks identifying everything is working alright.  

    The Connectivity alert is only for that particular time when Fing desktop was unable to run checks due to the device was in sleep mode or the internet was disconnected. You can always refresh the scan to make sure if everything is working alright at the current time.  

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • benhwa
    benhwa Member, Beta Tester Posts: 1
    First Comment First Anniversary Photogenic
    I too keep getting this error message when my VPN is running. I can access the internet but this message always pops up: DNS resolution is not working. Primary DNS is working but secondary DNS 75.76.160.2 failed. Any assistance would be appreciated to get rid of this. 
  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,885
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    benhwa said:
    I too keep getting this error message when my VPN is running. I can access the internet but this message always pops up: DNS resolution is not working. Primary DNS is working but secondary DNS 75.76.160.2 failed. Any assistance would be appreciated to get rid of this. 
    As you mentioned only when VPN is running this keeps happening. Do you see such errors when VPN is not running. It maybe VPN is not supported or you can manually set DNS to any 8.8.8.8 etc and see if the connections gets stable.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • carl2nasa
    carl2nasa Member Posts: 1
    First Comment
    can someone work to fix this because it is very annoying and misleading about the error state
  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,885
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    carl2nasa said:
    can someone work to fix this because it is very annoying and misleading about the error state
    I got in touch with our developers and to update you when the Fing desktop is doing its normal health check while running in background, there are chances of unreliable DNS resolution by router and once it goes unstable then Fing desktop catches that and thus warns you. Once you refresh the scan then it is able to actively work and thus everything is normal on Fing desktop. 
    If you configure the router dns settings with 8.8.8.8 then you will find there will be no errors or alerts. DNS resolution going unreliable by router is common.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!