FING Beta 1.4.1 not working

SparksSparks Member, Beta Tester Posts: 79
10 Comments 5 Likes Photogenic
✭✭
As of this morning I get nothing on FING desktop, Mobil works. I have tried opening and closing app, but no joy. Sometimes I get nothing as screenshot shows. The three dots only shows.

Answers

  • RobinRobin Administrator Posts: 2,344
    100 Answers 1000 Comments 250 Likes 25 Agrees
    admin
    Hi @Sparks

    Can you try to reboot the windows device and then check? if restarting PC haven't help to resolve this behaviour, these commands may be useful to windows (to launch from Command Prompt as administrator): 

     

    Stop service command: sc stop Fing.Agent 

    Start service command: sc start Fing.Agent 

     

     

    Fing agent needs the Windows libraries which are installed with the WinPcap package during FingDesktop installation, it used to make packet capture and filtering useful our engine to protocol analyzers and network monitors. 
    Fing agent service cannot work properly without the correct installation of WinPcap.  
     
    Please open the command prompt and return the output: 

    • sc query npf 

     
    it's useful to understand if the WinPcap has been installed correctly and it is running properly. 

    If possible please uninstall the older version of WinPcap and install the latest version of Win10Pcap from here and check. 

    I look forward to your reply. 

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • SparksSparks Member, Beta Tester Posts: 79
    10 Comments 5 Likes Photogenic
    ✭✭
    I am on a Mac
  • RobinRobin Administrator Posts: 2,344
    100 Answers 1000 Comments 250 Likes 25 Agrees
    admin
    Sparks said:
    I am on a Mac

    In order to address your query, first I would like to confirm that you are:

    • Installing the Fing Desktop under the 'Applications' folder only. If not, Fing Desktop won't be able to connect to its services. If it is not, it will appear as 'Unidentified' or ‘Undefined.
    • In this case, the service might have been disabled and cannot launch until the service is re-enabled. This is likely the result of the service having been unloaded using 'launchctl' in conjunction with the -w switch. This will disable the service. This condition can remain, even if the software is uninstalled and reinstalled.


    To resolve:

    Re-enable the disabled service using the following commands:

    • sudo launchctl load -w /Library/LaunchDaemons/com.fing.service.plist


    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • SparksSparks Member, Beta Tester Posts: 79
    10 Comments 5 Likes Photogenic
    ✭✭
    OK it just started working.
    Robin
Sign In or Register to comment.