Fing hangs on connectivity check V 1.3.2

MichaelSMichaelS Hayward CAMember Posts: 13
10 Comments Name Dropper Photogenic
Hi,
After I installed the latest version, when I try to start a scan for devices, I get a brief flash of what looks like column headers, then a blank window pops up and Fing hangs.
Windows 7 64 bit Dell laptop.
Any thoughts?
Thanks
kltaylor

Answers

  • kltaylorkltaylor Moderator, Beta Tester Posts: 1,231
    1000 Comments 500 Likes 50 Answers 100 Awesomes
    ✭✭✭✭✭✭
    Hi @MichaelS thanks for asking your question.
    Going to ask the standard toubleshooting questions that we all make fun of.
    Did you restart the laptop?  Are all Windows 7 updates (that are available) installed?  Have you scanned for Malware, Spyware, etc.?
    Completely uninstall and reinstall the latest app (use an uninstalled app that will also remove any registry entries.  I use geek uninstaller, personally) and see if that fixes any issues.  Post in here and '@' me so I know to come review this and reply when I can.
    "There's a fine line between audacity and idiocy."
    -Warden Anastasia Luccio, Captain
  • MichaelSMichaelS Hayward CAMember Posts: 13
    10 Comments Name Dropper Photogenic
    Hi. Thanks for your response @kltaylor.
    Yes, I did the reboot, uninstall, re-install, but the problem only got worse. Fing wouldn't even display. There were three instances of Fing running. I don't know if that is normal. But after another reboot, my system started instantly shutting down. Anyway, long story short, I realized that I had installed FileZilla and FileZilla server recently. I uninstalled them and will reinstall Fing. It seems like I might have a conflict somewhere. Attached is a screen shot of the resource monitor. All four CPU's are running full blast. That's without even trying to start Fing.
    Thanks for your help.
    kltaylor
  • kltaylorkltaylor Moderator, Beta Tester Posts: 1,231
    1000 Comments 500 Likes 50 Answers 100 Awesomes
    ✭✭✭✭✭✭
    Well great job on finding the culprit, let's bring in @Robin and @Ciaran to inquire about a possible incompatibility with Filezilla products.  If there is an issue it's good to catch it now so that it can be worked on while it's still in beta.
    "There's a fine line between audacity and idiocy."
    -Warden Anastasia Luccio, Captain
  • RobinRobin Administrator, Fing Team Posts: 4,044
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Hi @MichaelS
    Solution for this is to upgrade or reinstall the WinPcap application and it will work.
    Fing agent needs the Windows libraries which are installed with the WinPcap package during FingDesktop installation, it used to make packet capture and filtering useful our engine to protocol analyzers and network monitors.

    Fing agent service cannot work properly without the correct installation of WinPcap. 

    Please open the command prompt and return the output:
    • sc query npf

    it's useful to understand if the WinPcap has been installed correctly and it is running properly.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
    kltaylor
  • MichaelSMichaelS Hayward CAMember Posts: 13
    10 Comments Name Dropper Photogenic
    Hello @Robin
    Here is the output of the sc command
    SERVICE_NAME: npf 
            TYPE               : 1  KERNEL_DRIVER  
            STATE              : 4  RUNNING 
                                    (STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
            WIN32_EXIT_CODE    : 0  (0x0)
            SERVICE_EXIT_CODE  : 0  (0x0)
            CHECKPOINT         : 0x0
            WAIT_HINT          : 0x0
    I am going to re-install Fing. I also disconnected Firewalla. Every once in a while my internal LAN stops working and I need to reboot the router. Any known conflict between Fing and Firewalla?
    Thank you.
    Michael
  • MichaelSMichaelS Hayward CAMember Posts: 13
    10 Comments Name Dropper Photogenic
    No joy. Still hangs when opening scan devices window.
  • RobinRobin Administrator, Fing Team Posts: 4,044
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Hi @MichaelS
    Yes, with using Firewalla and Fingbox, there are some conflicts. To resolve that, Please follow these steps:  

    1. You can turn monitoring off on Fingbox in Firewalla app, so that Firewalla won't arp spoof Fingbox, and Fingbox won't report gateway change alert. 

     

    2. If you don't use the blocking feature in FingBox, it won't trigger arp spoofing against devices. But if you want to use the blocking feature, the arp spoof messages from FingBox may interference how Firewalla works. Our recommendation will be to use Firewalla app to block devices. 

     Also, for Fing Dekstop, can you please remove the WinpCAP application entirely and then install the latest update of WinPcap from this link and see if the issue persists: http://www.win10pcap.org/

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
    kltaylor
  • MichaelSMichaelS Hayward CAMember Posts: 13
    10 Comments Name Dropper Photogenic
    Hello @Robin
    I re-installed 1.3.1 and it works fine.
    Michael
  • MichaelSMichaelS Hayward CAMember Posts: 13
    10 Comments Name Dropper Photogenic
    I did not re-install Wincap before installing 1.3.1. If you still want me to that I will. Somehow 1.3.2 was installed even though I didn't want it. I might have clicked a button twice.
    Also un-install leaves some entries in the registry related to Fing.
    Michael
  • MichaelSMichaelS Hayward CAMember Posts: 13
    10 Comments Name Dropper Photogenic
    These are the registry entries left behind on an uninstall.


    Invalid Default Icon C:\Program Files\Fing\Fing.exe HKCR\fing\DefaultIcon Michael
    Open with Application Issue "C:\Program Files\Fing\Fing.exe" "%1" HKCR\fing\shell\open Michael
    Application Paths Issue C:\Users\Michael\Downloads\Fing (1).exe HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Compatibility Assistant\Persisted All users
    Missing Startup Software C:\Program Files\Fing\Fing.exe --processStart "Fing.exe" --process-start-args "--hidden" HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Run Michael
    Missing MUI Reference C:\Users\Michael\Desktop\Fing.exe HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\MuiCache Michael
    Missing MUI Reference C:\Program Files\Fing\Fing.exe HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\MuiCache Michael
    Invalid file reference ImagePath - c:\program files\fing\resources\extraresources\fingagent.exe --servicemode fing.agent --agentroot "c:\users\michael\appdata\roaming" HKLM\SYSTEM\CurrentControlSet\services\Fing.Agent Michael

  • RobinRobin Administrator, Fing Team Posts: 4,044
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Thanks for the information @MichaelS. Are you able to delete the remaining entries and see if the new installation works with updated winPcap.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • MichaelSMichaelS Hayward CAMember Posts: 13
    10 Comments Name Dropper Photogenic
    Hi @Robin
    I installed WinCap from your link and then re-installed Fing 1.3.2. Still hangs when trying to do a device scan.
  • RobinRobin Administrator, Fing Team Posts: 4,044
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    MichaelS said:
    Hi @Robin
    I installed WinCap from your link and then re-installed Fing 1.3.2. Still hangs when trying to do a device scan.
    Thanks for the feedback. I will include the feedback for our developers to investigate. Thanks
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • MichaelSMichaelS Hayward CAMember Posts: 13
    10 Comments Name Dropper Photogenic
    Hi @Robin
    Well, I accidentally installed version 1.0.1 thinking it was 1.3.1. After I installed 1.0.1 the program again forced me to upgrade to 1.3.2. 1.3.2 works now. Must be the phase of the moon or flooby dust.
    Thanks.
    Michael
    Robin
Sign In or Register to comment.