Delayed Digital Presence Notifications

Ddanf308Ddanf308 Member Posts: 4
Name Dropper First Comment
My work configuration is static IP coming to a Sonicwall VPN, but DHCP is handed out by primary domain controller. DHCP has two scopes: 192.168.0.10 - 192.168.0.250 & 192.168.1.2 - 192.168.1.250 Subnet mask 255.255.0.0. In the Fing app, I have set the Maximum Network size to /23 in an attempt to limit overscanning the network for non-existent addresses. Fingbox has activated and has found all of my devices, however there is a lengthy delay in reporting the changed state of any device (or new devices); usually by more than a couple hours. It's almost as if the Fingbox is still scanning the entire subnet of 255.255.0.0 (65k addresses). The Fingbox I have at home is very responsive to devices coming and going. 

Best Answer

  • Ddanf308Ddanf308 Member Posts: 4
    Name Dropper First Comment
    Accepted Answer
    ***SOLVED*** As suspected, the very wide mask of 255.255.0.0. was forcing the Fingbox to scan over 65k IP addresses and it just simply couldn't make the rounds and report in a timely manner. I changed the subnet mask to 255.255.254.0 so that it is only scanning 512 addresses, and the alerts are happening in under a minute. As echoed by others, it would be nice to see a future update that allows assigning a static IP and manual control over the Fingbox network settings. 
    RobinMarc

Answers

  • MarcMarc Moderator, Beta Tester Posts: 1,823
    100 Answers 1000 Comments 500 Likes 250 Agrees
    ✭✭✭✭✭✭
    @Ddanf308 , two things to look at to start... Is the Fingbox slower network detection set to off?  And what is the time out value in the individual device's settings?  Either of these can cause a delay if set too high or set to on.
    Thats Daphnee, she's a good dog...
  • Ddanf308Ddanf308 Member Posts: 4
    Name Dropper First Comment
    @Marc , thanks for the reply. 'Slower network discovery' is turned off. The timeout values range from 1 minute to 5 minutes on different devices I am monitoring. 
  • MarcMarc Moderator, Beta Tester Posts: 1,823
    100 Answers 1000 Comments 500 Likes 250 Agrees
    ✭✭✭✭✭✭
    @Ddanf308, Could the ones with 5 possibly be contributing to the delay?  You could try playing with the value, lower the numbers and see if the response improves...
    Thats Daphnee, she's a good dog...
  • Ddanf308Ddanf308 Member Posts: 4
    Name Dropper First Comment
    @Marc , I wouldn't think that would contribute to the delay as I have been testing some devices with a 1 minute value and the alerts are still being triggered after 2 hours. My guess is that is has something to do with the subnet mask being used on our network. While I have set the mask to /23 in the app, I believe the Fingbox is still looking at /16 since it gets its DHCP information from the domain controller. I am looking to see if we can change our mask to 255.255.254.0 so that all the devices on our network are in the /23 mask to see if it speeds up response time. 
  • MarcMarc Moderator, Beta Tester Posts: 1,823
    100 Answers 1000 Comments 500 Likes 250 Agrees
    ✭✭✭✭✭✭
    @Ddanf308, perfect, that's what I was looking for, thanks.  @Robin or @Ciaran , would you have some suggestions for @Ddanf308 issue other than what he has suggested to do, re: new subnet mask?
    Thats Daphnee, she's a good dog...
Sign In or Register to comment.