Android device on local wifi can't connect to local devices unless connected to vpn on my NAS

JasonSFJasonSF Member, Beta Tester Posts: 10
5 Agrees First Anniversary 5 Likes First Comment

This seems like a strange issue but I don't know enough about networking to really understand what is going on. The symptom is that I can't ssh or hit http server on my raspberry pi from my Android phone while both are connected via the same wifi network. I have a NAS with an openvpn server running. If I connect to the vpn from my phone it can then find and connect to the pi. Unrelated, I think, I also have fingbox on the network.

Anyone know what's going on here or how to troubleshoot it? There is only one subnet. The vpn server is set up so port forwarding from the router allows me to connect to it from outside. But I'm talking about connecting directly to the vpn from within the network already. The vpn server is wired to the network. The pi and phone are connected to wireless APs. I also think this isn't a problem from windows devices on the network so maybe this is an android thing?




  • rootedrooted Gulf Coast, USModerator Posts: 803
    500 Comments 50 Answers 100 Likes 25 Agrees

    You are certain they are on the same subnet and you don't have a VLAN active?

  • JasonSFJasonSF Member, Beta Tester Posts: 10
    5 Agrees First Anniversary 5 Likes First Comment

    So, this is where my understanding of network technology starts to break down. I know every device on my network is in the range of 192.168.11.XXX. My routers (Netgear R6700v3) dhcp settings specify the range of 2-254. Enable VLAN is unchecked.

    The wifi is disabled on the router and I have a wired Tp-link EAP225 connected to it. I have a second EAP225 downstream connected wirelessly. All devices are connected to the same ssid.

    Any suggestions on settings I should confirm?

  • ScoobyScooby Member Posts: 163
    100 Comments 25 Awesomes 25 Likes 5 Answers
    Not sure if this is the case, but is it possible your APs, or one of your APs,  (TP-Link EAP 225) is/are set for SSID Isolation?
    This article explains what it is:
    And this one may be a way to check for TP-Link APs:
    It could explain why you are able to connect when you VPN, but not for the Windows devices, unless they are connected to the router via ethernet. Anyhow, it could be something to check for.
  • JasonSFJasonSF Member, Beta Tester Posts: 10
    5 Agrees First Anniversary 5 Likes First Comment

    Thanks for the suggestion. I double checked and confirmed that I don't have site isolation enabled. I do have a separate SSID using the built in guest mode which essentially the same as isolation for that ssid. I would assume that it wouldn't affect my main ssid, since you are supposed to be able to have one with full access and one for guests. I suppose there could be something buggy in the software though.

    I just tried again to hit the web server on the raspberry pi and, as before, it wouldn't respond. I connected to the vpn and was able to connect. I then disconnected the vpn and tried again. This time I could connect. Very weird. It now seems to resolvable.

    Another thought- could IPv6 have any role in this. It is enabled and my android device does appear to have an address in both IPv4 and IPv6.

Sign In or Register to comment.