App crash when refresh scanning

Xabi
Xabi Member Posts: 2
First Comment
edited October 11, 2019 in Fing App #1

Hey!

My Fing APP is crashing every time I refresh a scanning on a certain WiFi. Not sure if more than one, but i have reinstalled the app on my iPhone without any success.

iphone

iOS 13 (newest)

Tagged:

Answers

  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Hi @Xabi have you given the Fing App  the required location permissions?
    https://community.fing.com/discussion/830/ios-13-fing-app 

    Community Manager at Fing

  • William
    William Member Posts: 1
    First Comment
    Even validate Location Permission settings, Fing APP still crash every time.
    All my mobile settings:
    1. Location Permission = "While Using"
    2. iPhone = XR
    3. iOS = 12.4.1
    4. Capacity & Available = 256GB / 220.6GB
    5. iPhone Language = English
    6. Fing APP version = latest 8.5.1
  • Xabi
    Xabi Member Posts: 2
    First Comment

    Yeah! This is a bug - in the current version!

    i discovered an IP conflict (two Mac addresses try to use the same IP). This causes Fing to Force Quit when scanning. Is this meant to be, in case if a cyberattack, or could we just call it a bug?

  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Yes @Xabi we have this identified now as a KNOWN issue, and I'll update everyone here when there is more information about the solution. Stay tuned. 

    Community Manager at Fing

  • Squid
    Squid Member, Beta Tester Posts: 5
    Name Dropper First Comment Photogenic
    edited November 10, 2019 #6
    Just got a Fing box. Using iOS 13 on an iPhone and iPad - constant crashing while trying to scan or add my Fing.
    Yes - I am allowing location.
    Yes - I've sized my network.
    Yes - Disabled reverse DNS lookup.
    Any other way of attempting to get this to work?
  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    @Squid
    Thanks for the response.
    I wonder, since you are using the app for iOS 13 but do not have iOS 13 on your phone if that could be the issue?

    3. iOS = 12.4.1

    Could you please try clearing the data cache of your phone/apps and re-installing?
    How to clear iPhone cache. (something similar to) 
    1. Tap Settings > General > Storage & iCloud Usage.
    2. In the top section (Storage), tap Manage Storage.
    3. Select an app that's taking up a lot of space.
    4. Take a look at the entry for Documents & Data. ...
    5. Tap Delete App, then head to the App Store to re-download it.
    Also setting the iOS location permissions to iOS 13 to ALWAYS to test it out? We do recommend ALWAYS but it isn't required. I do wonder if it is causing some kind of issue.

    Most likely this is happening because the correct permissions are not being acknowledged fully. 

    I'm just trying to get to the bottom of why.
    Let me know on the above.
    Cheers,
    Violet

    Community Manager at Fing

  • Squid
    Squid Member, Beta Tester Posts: 5
    Name Dropper First Comment Photogenic
    @VioletChepil - That was the previous poster (@Xabi).
    I can confirm that I am running iOS 13 (13.2.2)
    I'll try purging the app from there and trying again.
    VioletChepil
  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Thanks @Squid let me know how you get on.

    Community Manager at Fing

  • Squid
    Squid Member, Beta Tester Posts: 5
    Name Dropper First Comment Photogenic
    No good. Freezing and crashing still.
  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    edited November 12, 2019 #11
    @Squid EDITED:
    I believe this is because you are using Fing App 8.5.1 and not the latest app version.
    Could you update your app and try the steps again?
    Let me know if that solves it. 

    Community Manager at Fing

  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    edited November 12, 2019 #12
    Hi @Squid please see above. Let me know if that solves it. A fresh install should fix - we've corrected something on our side. If it is not solved after this, I will open you a ZenDesk ticket for further investigation. Let me know. 

    Community Manager at Fing

  • Squid
    Squid Member, Beta Tester Posts: 5
    Name Dropper First Comment Photogenic
    I did file a report from the App which listed the version as 8.5.2
  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Have you tried to re-install now? It may be working. Support have looked into your account and I believe corrected something. Let me know if its working now. 

    Community Manager at Fing

  • Squid
    Squid Member, Beta Tester Posts: 5
    Name Dropper First Comment Photogenic
    Magic. It's all working now. Not sure what y'all managed to do but it's now all happy happy. Thank you!
    VioletChepil
  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Happy days @Squid !!

    Community Manager at Fing