WiFi performance no longer working

CB44CB44 Member, Beta Tester Posts: 10
Photogenic First Comment

Every time I try to run a WiFi performance test it says “You must connect this device to a WIFI that can connect to a fing box”

Last time I ran this was being of September and it worked ok. Either it’s my iPhone iOS upgrade or a new version of fing app . Any ideas?

Marc
«1

Answers

  • MarcMarc Moderator, Beta Tester Posts: 2,153
    100 Answers 1000 Comments 500 Likes 250 Agrees
    ✭✭✭✭✭✭
    Interesting, I’m seeing the same thing, possible bug.  @VioletChepil and @Robin , see screenshot below. iOS version 13.1.2 (iPadOS for the below screenshot)


    Thats Daphnee, she's a good dog...
  • CB44CB44 Member, Beta Tester Posts: 10
    Photogenic First Comment

    Thanks Marc

  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Hi @CB44 and @marc - I've got some further information on this.
    Are you both using iOS 13?

    For iOS 13 - you need to grant new permissions. 
    Have you granted location permissions as required for iOS 13 and above? https://community.fing.com/discussion/830/ios-13-fing-app

    The same restriction that prevents the display of BSSID and SSID will cause the current access point to be unidentified.

    Let me know!
    Cheers

    Community Manager at Fing

  • MarcMarc Moderator, Beta Tester Posts: 2,153
    100 Answers 1000 Comments 500 Likes 250 Agrees
    ✭✭✭✭✭✭

    @VioletChepil , I’ll check when I get home and let you know. The apps on my iPad, not with me at the moment.

    Thats Daphnee, she's a good dog...
    VioletChepil
  • CB44CB44 Member, Beta Tester Posts: 10
    Photogenic First Comment

    Hi, I’ve tried to change permissions . It’s set to ask and I’ve tried to change to always or other settings and it just reverts back to Ask. I’ve tried to close app but no luck.

  • MarcMarc Moderator, Beta Tester Posts: 2,153
    100 Answers 1000 Comments 500 Likes 250 Agrees
    ✭✭✭✭✭✭
    As @CB44 found, I am still experiencing this on the iPad @VioletChepil .  It's working on my iPhone however.  One thing I've noticed on the iPad is that on fing's app setting in Apple's settings, after changing the location access setting it keeps reverting to Ask, no matter what I set it to.  The next step I would normally take would be to uninstall and reinstall the app on the iPad but will hold back till I hear from you.
    Thats Daphnee, she's a good dog...
    VioletChepil
  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    @Marc - have you double checked the account Logging in? (I believe we've just merged/transitioned your account). I would just ensure those are the same. After that, I'd proceed with install/un-install.

    Community Manager at Fing

  • MarcMarc Moderator, Beta Tester Posts: 2,153
    100 Answers 1000 Comments 500 Likes 250 Agrees
    ✭✭✭✭✭✭
    @Marc - have you double checked the account Logging in? (I believe we've just merged/transitioned your account). I would just ensure those are the same. After that, I'd proceed with install/un-install.
    I confirmed the account was correct so uninstalled and then reinstalled the app.  Everything is working now as it should. @CB44, not sure if you tried this but uninstall and reinstall and see if it clears things up.  
    Thats Daphnee, she's a good dog...
    VioletChepil
  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Ok great @Marc
    @CB44 let us know if that solves things for you too! 

    Community Manager at Fing

    Marc
  • NazirNazir Member Posts: 15
    10 Comments 5 Likes Photogenic

    Hi there. I have the same issue where I’m unable to obtain WiFi performance. I have location settings as “always”. I’m running iOS 13.1.2

  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    @Nazir you have granted all permissions. Did you try un-install/re-install after granting new permissions in the app?

    Community Manager at Fing

  • NazirNazir Member Posts: 15
    10 Comments 5 Likes Photogenic

    I have granted all permissions. I’ve also deleted and reinstalled the app. Still the same issue.

  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Thank @Nazir are you running this test while on the local network? You must be connected on the same network as your Fingbox for WiFi performance tests. If you are remote, it will not work as your phone is on a different WiFi network. Hope that clears things up and let me know. 

    Community Manager at Fing

  • NazirNazir Member Posts: 15
    10 Comments 5 Likes Photogenic

    I’m running it locally. On the same WiFi network. It’s bizarre as I’m clearly connected and Fing even identifies the two Wireless Access Points on the network.

  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    @Nazir - can you post this as a new discussion? That way, if necessary, I can create you a support ticket once we get through some perliminary troubleshooting steps. Let me know! Just ask a new question and detail what is happening to start that up! 
    Thank you

    Community Manager at Fing

  • CB44CB44 Member, Beta Tester Posts: 10
    Photogenic First Comment
    Hi, just got round to trying to resolve this issue. I’ve tried reinstalling and now even in a worse place as when running the performance function it does not think Fing is on the same network and showing 0 access point when there where at least 4 before. I’m now really confused. If someone can point me in the right direction that would help. 
  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    @CB44 - have you deleted and re-installed the app with all the new location permissions granted?

    Sounds maybe all the APs are not added in now. 

    Here are specific instructions on adding new access points in.
    In oder to monitor all access points, you can add the access point under Wifi Intrusion Protection. For Mesh system, if they are not creating a separate gateway than the router and sharing the same gateway then Fingbox will be able to see devices connected to all access points. You can verify how many access points are being monitored by Fingbox by checking the MAC address of the Access points(BSSID). 

    Please follow these steps:  
    1. Open the Fing App  
    2. Click on the Network Tab  
    3. Click on the Network Details section(This is the directly under your network name)  
    4. Scroll down and locate the Access Point Section  
    5. You will be able to see the BSSID.  

    In order to add the access point for Fingbox, first, you need to be connected to the access point network which you want to add. Then open the Fing App and choose the Fingbox network from the dropdown list. Go to the ‘Network’ tab and select either Wi-Fi Intrusion Protection or Wi-Fi Performance and you will be able to add the Access point for the current network your device is connected to. You can only add the Access point either from the Wi-Fi Performance tab or Wi-Fi Intrusion Protection tab.  
     After Adding the access point, you will receive the New Access point alert and you need to accept it as a trusted gateway and the access point will be added successfully. 

    Let me know if that might be the fix. Am happy to help you further as needed. 

    Community Manager at Fing

  • CB44CB44 Member, Beta Tester Posts: 10
    Photogenic First Comment
    Hi Violet, I’m connecting to my network and going to WiFi performance which says I’ve got 0 access points, if I click on this it states Unknown access point and you are connected to an access point “Skyxxxxx” (3C:89:........) that is not yet monitored by Fingbox. Use the button below to assign it to the network “Home”. When I click on Add Access Point the message disappears but no access point is added. 

    Any ideas ?

    Regards,
    Chris
  • RobinRobin Administrator, Fing Team Posts: 3,734
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Hi @CB44
    Can you check if the location permisssions are enabled or not? I believe the reason for no access points being added is because of the location permissions. 

    If you are unable to see the location permissions for the Fing App under phone settings then, I would like you to follow these steps and location permissions pop up will appear to be enabled.

    1) Open Fing App and go to 'Network' tab

    2) Click on the ISP tab and it will open the Network page

    3) Clear out the Network information such as Address.

    4) Next, to the MAP section, there is a small icon to auto-detect location. Click on the icon and location permissions will be asked.

    After making sure the location permissions are enabled and you are able to see the Access points then run the Wifi performance test and see if it helps.

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • CB44CB44 Member, Beta Tester Posts: 10
    Photogenic First Comment
    Hi Robin,
    When is go into settings on iPhone or iPad and click on Fing app in can see Location is set to Always. 

    If I open Fing app I cannot see any way to clear the information you are referring to.

    under my networks I’ve got one connection Called Home. If I click network it just states on not in WiFi when I’m connected to the sky wifi.

    If I click the map location icon it comes up location detected but did not ask for permissions. 

    I’m still under to see access points.
    Regards,
    Chris

  • RobinRobin Administrator, Fing Team Posts: 3,734
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Hi @CB44
    I would like you to uninstall and re-install the Fing App and then check the scan is working or not. To do this: 
    1. Sign out of the application 
    2. Remove the application 
    3. Reboot the phone to clear the cache 
    4. Reinstall the application 
    5. Start App & log back in the Application. 
    Once the application is re-installed, run the device scan and then check for the access points being monitored and location permissions are enabled. 
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • CB44CB44 Member, Beta Tester Posts: 10
    Photogenic First Comment
    Hi no joy. If I go into WiFi intrusion protection it say unknown access point but does not add. If I click WiFi performance it just say not in WiFi. 
  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Hi @CB44
    I'm sorry about this that a resolution isn't being easily found! 
    Ok I've created a ZenDesk ticket on this one so our support team can help any further on this.
    Based on what I've tried here we'll need more investigation. Support team will take things from here and update you by email.
    If I get any more information, I will post it here as well.

    Community Manager at Fing

  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Hi @CB44 I had one other member reporting the same. First they reenabled all location permissions.
    Then they did a hard reset of the devices and everything worked again. Could you flush the cache of your devices after enabling the location permissions and try that?
    The issue was nearly identical and that fixed it! 

    Community Manager at Fing

  • CB44CB44 Member, Beta Tester Posts: 10
    Photogenic First Comment
    Hi,
    Not sure if I’m doing this correct. I went into iPhone settings and found FInG and changed location setting from while using the app to Always. I then switched off the iPhone only way I can think of clearing cache. I restart iPhone and went into the app and still not working. 

    If sending screen shots of some of the setting just to you and not the whole community will help , happy to do so.



  • NazirNazir Member Posts: 15
    10 Comments 5 Likes Photogenic

    I found the solution to remove the app, delete the network from the online system and restart from new. It then recognised all my wireless access points.

    VioletChepil
  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Thanks for sharing @Nazir.
    @CB44 what device do you have? I'll check up online on ways to clear cache.
    May be something like this for the process.
    Follow these steps:
    1. Tap Settings > General > Storage & iCloud Usage.
    2. In the top section (Storage), tap Manage Storage.
    3. Select an app that's taking up a lot of space.
    4. Take a look at the entry for Documents & Data. ...
    5. Tap Delete App, then head to the App Store to re-download it.

    Community Manager at Fing

  • CB44CB44 Member, Beta Tester Posts: 10
    Photogenic First Comment
    Hi it’s an iPhone X and iPad, both do not work. Also tried on my chrome box. Nothing works.
  • CB44CB44 Member, Beta Tester Posts: 10
    Photogenic First Comment
    Hi,

    I’ve now delete all data related to Fing, deactivated the Fing box, deleted the app on all devices. Disconnected fing device. Rebooted all devices and reinstalled ensuring location was enabled. 
    Although it want to add the access point every time I go into intrusion detection it just say unknown access point you are connected to an access point SKyxxxx (MAC address .... ) The button say add access point  but nothing happens.

    if I go into WiFi  performance it just say Not in WiFi you must connect this device to a WiFi that can connect to fingbox. The Fingbox says it connected and under devices its picking up all devices.

    Question is why will the app not allow the access point to be connected?

    regards,
    Chris

  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    OK @CB44 this is as far as I can take things on Fing Community and needing support to look into your situation.
    Have you had feedback on the ticket?

    Community Manager at Fing

Sign In or Register to comment.