FingDesktop App can't ID iPad Pro 11" as 5th Gen

KingofKats Member, Beta Tester Posts: 3
Third Anniversary Photogenic First Comment
edited December 23, 2022 in Fing Desktop discussions #1
My Fing desktop app incorrectly identified my 11" iPad Pro (Wifi+C) as 2nd Gen. I  fact it is 5th Gen, but when I tried to correct this, the app had no option for 5th gen. When I tried manually editing, the app refused to save my edit. What next?


  • Marc
    Marc Moderator, Beta Tester Posts: 3,192
    250 Answers 1,000 Likes 2500 Comments 250 Awesomes
    edited December 23, 2022 #2
    I have the same problem.  I have an M2 iPad Pro which is not presented in the selection type and if you believe what Fing says about an 11" iPad Pro, it's already end of life.  In the old days, if you entered your own device info, it gave you the choice to submit to Fing for consideration.  I'm not sure if thats still the case.  

    @Karl_From_Fing, can you clarify how we can submit new devices to Fing if the device is not present to select?

    Thread moved to the Fing Desktop section for relevance....
    Thats Daphnee, she's a good dog...
  • Michal_From_Fing
    Michal_From_Fing Member, Administrator, Moderator, Desktop Help, Fing Team Posts: 84
    10 Comments 5 Likes First Answer Name Dropper
    Hi, yes. It is still possible to submit suggestions to fingpedia. Just select the device, type the name - ie 'iPad pro' it will narrow the device list - scroll down to the very bottom and you should have the option to submit missing model to fingpedia.