How to resolve "Fingbox not found" when LED is green?

nyul Member Posts: 9
Name Dropper First Comment Photogenic

I've been through the 101 articles and the help pages but have not had any success.
  • The Fingbox (v2) is powered on and connected by ethernet to the router/WAP (a Google Nest WiFi) and I also tried connecting the Fingbox to the Gigabit switch that most devices are connected to beyond that router.
  • The Fingbox LED is pulsing green
  • The Android Fing app consistently sees the Fingbox on the network in the Devices scan. When I do a scan, it prompts me to activate the identified Fingbox
  • When I attempt the activate the Fingbox, it searches but then shows as not found.
  • If I open the Fingbox IP address in my browser I see "Your device is being recognized, thank you! Check your device in Fing in a couple minutes, the improved recognition can take some time."
  • Although I bought the Fingbox from eBay it is from a seller who confirms it is an unused brand new warranty replacement they were sent by Fing. They have sent me a screenshot of their Fing console showing no connected Fingboxes.
  • I have tried several reboots. I have also tried a reset (holding reset for 30s during power up) and saw a lot of white flashing and a rainbow of LED colours I do not usually which I assume means it had reset.
It makes little sense to me that although the Fingbox is clearly on the network, the Fing app fails to find it to activate it. I wish the error message was explicit about the exact problem.

How do I get the Fingbox activated please, or is the product unit just faulty? I would really appreciate some help.


  • nyul
    nyul Member Posts: 9
    Name Dropper First Comment Photogenic

    The solution for me at least, after many hours trying everything I could and if anyone has the same problem, was to reinstall the Android app. With a fresh app install and using Add Fingbox (not the automated prompt after a scan, which did not work still), activation was successful. 👍