Bug when checking open ports

Ian222222
Ian222222 Member Posts: 5
First Comment

After scanning for devices on my network, whenever I check a device for open ports I get an error message saying “You’re currently connected to (null) while this device was found on (null)…”.

You can then choose to run anyway and it works but this message is a bit bizarre. I’m using the latest version of the app on iOS and can confirm this bug has been there for a few months.


Comments

  • Ian222222
    Ian222222 Member Posts: 5
    First Comment

    Oh another bug while I’m here. Every time I open the app it says “Unknown access point, tap to identify…”

    When you tap, nothing happens. Also the right arrow (>) does nothing.

  • Karl_From_Fing
    Karl_From_Fing Administrator, Beta Tester Posts: 414
    100 Comments 25 Likes 5 Answers 5 Awesomes
    ✭✭✭
    Hey @Ian222222
    May I ask if you are connected to a VPN?

  • Ian222222
    Ian222222 Member Posts: 5
    First Comment

    Hi Karl, no I’m not using a VPN. Just on my home network, using the iPhone app.

    The windows app works ok btw.

  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    Ian222222 said:

    Hi Karl, no I’m not using a VPN. Just on my home network, using the iPhone app.

    The windows app works ok btw.

    As the network name is mentioned 'null' it seems like you have not enabled location permissions for your Fing app and thus it is not able to identify your devices. Can you please enable location permissions or if you are unable to see the location permissions for the Fing App under phone settings then, I would like you to follow these steps and location permissions pop up will appear to be enabled.

    1) Open Fing App and go to 'Network' tab
    2) Click on the ISP tab and it will open the Network page
    3) Clear out the Network information such as Address.
    4) Next, to the MAP section, there is a small icon to auto-detect location. Click on the icon and location permissions will be asked.



    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • Ian222222
    Ian222222 Member Posts: 5
    First Comment

    Hi Robin,

    Thanks but location permissions were already enabled (see attachment).

    Out of interest I also tried the steps you mentioned to give Fing my exact location. When I fully close the app and reopen it then it reverts to using a rough location (5 miles away). So it seems the “Save” button also isn’t working on that page.


  • Ian222222
    Ian222222 Member Posts: 5
    First Comment

    Oh I’ve just found a fix!

    On the Network tab, once you’ve given it your exact location but before you click Save then you MUST give your location a name. Once it has a name then your location information persists and the other bug (the null message thing) goes away!

    Seems Fing falls over when you’re in an unnamed location. Anyway it’s working now. Thanks for the help.

    Robin_Ex_Fing