High CPU usage

Eric_DK
Eric_DK Member Posts: 2
First Comment Photogenic
edited January 5, 2022 in Fing Desktop discussions #1
This morning, as I approached my laptop, I could hear a noisy CPU fan. When I moved my mouse, I saw a series of grey Windows notifications about loss of internet connectivity starting here at 1:10 A.M. last night. The fifth notification at 1:15 A.M. informed me that all was good again.
I use Core Temp to monitor the CPU temperature and Sysinternals' Process Explorer to keep track of which Windows processes are active. Process Explorer and Windows' Job list showed the 32 bit version of Fing Agent Service using 35.9% of CPU capacity. After stopping the Fing Agent Service the CPU fan slowed down and the CPU load dropped to an average around 16%.
What can explain this anomaly? Is there a method to limit the tremendous CPU load?
Tagged:

Answers

  • Marc
    Marc Moderator, Beta Tester Posts: 3,081
    250 Answers 1,000 Likes 2500 Comments 250 Awesomes
    ✭✭✭✭✭✭✭
    Hi @Eric_DK, I've moved this to the Fing Desktop area for relevance.  Can you confirm the version of the desktop your using?  Also, did you notice if it was going through any process at the time like a speed test etc?  Finally, tagging @Robin_from_Fing to see if he has any insights to share on this.
    Thats Daphnee, she's a good dog...
  • Eric_DK
    Eric_DK Member Posts: 2
    First Comment Photogenic
    The version appears to be 2.7.2 and the laptop didn't appear to be running a speed test. Last night, before I went to bed I had a few browser tabs running and they didn't overload the CPU. Once I stopped the Fing Agent Service this morning the CPU load diminished considerably.
    Dylan_From_Fing
  • ICTijn
    ICTijn Member Posts: 4
    First Comment
    After installing Fing 2.9.0 (after having used several previous versions since version 1.0.0) I still had high CPU usage at boot. If I quit Fing-service in taksmanager and start Fing Desktop again, no problems.
    I uninstalled Fing and re-installed it after reboot. Still the same.
    After a second uninstall > reboot > re-install sequence the problem now seems to have gone...

    By the way; there are still no release notes of 2.9.0 at https://help.fing.com/knowledge-base/fing-desktop-release-notes/