Home Assistant (Home Automation) Network Configuration

GaborM
GaborM Member Posts: 1
I followed the instructions and set up HA on an Rpi4 connected to my Tplink modem via wired ethernet. I am using Google Nest mesh networking for my wireless devices wired to the same modem, the modem’s router function is disabled. The server works well, everything looks good, but HA will not recognize my wireless devices when I am trying to add integrations. I have a tplink kasa light and a tplink kasa outlet and a roku streambar pro whose IP addresses I adjusted to static on the network. These all work well with their respective apps and with Google Assistant, but they are not recognized automatically nor manually by HA. I get “connection failed.” I installed the HA app on my Google Pixel 4a(5G) phone and Galaxy 4 watch and those devices were automatically recognized by HA while on the same wireless network as all my devices. What setting do I need to change on my modem and/or router (both have uPnP enabled) in order for HA to “see” the wireless connected devices I want to connect using the Home Assistant UI?

Comments

  • Pixel
    Pixel Devon, U.K.Member, Moderator, Beta Tester Posts: 346
    100 Likes 25 Answers 100 Comments 25 Agrees
    ✭✭✭✭
    The majority of Home Automation devices only work on 2.4Ghz Wifi so when setting them up you need to disable the 5Ghz band on your WiFi network. You may need to split or separate the Mesh ssid for each band (2.4Ghz & 5Ghz) to achieve this if your device will allow it. Fortunately many HA devices can also be setup using Bluetooth, if available this may prove to be the easier option.