Fing Desktop Won't Update

ChuckV
ChuckV Member Posts: 4
First Anniversary First Comment Photogenic
I keep getting prompted that v 2.7.1 is available and will load when I reboot. Well, it never loads, and I keep getting prompted. The log file says the update has already been downloaded. But, nothing gets updated. Rinse, repeat for a couple weeks. Suggestions?
ChuckSilva

Answers

  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    Hi,

    If your Fing desktop is not updated automatically to the latest version then please try the following steps and the issue will be resolved.

    For Windows:

    Please check your system tray on your windows machine if Fing Desktop is running in the background. If yes, then open "Task Manager" and close the Fing desktop application and then reboot your device.

    Upon rebooting, open Fing desktop again and it will automatically update to the latest version.

    For MAC:

    Please open "Activity Monitor" and quit all Fing agents running and Fing desktop as well. After that, reboot your device and open Fing desktop again.

    This will load up all features on Fing desktop and will automatically update to the latest version.

    Here's the beta version for Fing 2.7.2, with the fix for future installations/upgrades

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • azimuth
    azimuth Member Posts: 4
    First Anniversary Photogenic First Comment
    Robin,

    I am having the same issue with 2.7.1. I shut down Fing, rebooted and restarted. No joy. Now tells me 2.7.2 is ready.
    Repeated the process but still no joy.

    What's next.

    Steven
  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    @azimuth
    Can you remove Fing desktop via iobit uninstaller or revo uninstaller and then reboot device and then install the new version and then check?
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • azimuth
    azimuth Member Posts: 4
    First Anniversary Photogenic First Comment
    That worked, thank you. Hopefully I won't have to do that again!

    Now I just need to run down the FingBox issue on speed test. Started to significantly under report the other day.
    I see someone else was having a similar issue but I haven't followed any further.
  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    azimuth said:
    That worked, thank you. Hopefully I won't have to do that again!

    Now I just need to run down the FingBox issue on speed test. Started to significantly under report the other day.
    I see someone else was having a similar issue but I haven't followed any further.
    For speedtest, can you go to this website from same device and share the screenshot of the speed test results from Fing app and the website so I can investigate: https://speed.measurementlab.net/#/
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • azimuth
    azimuth Member Posts: 4
    First Anniversary Photogenic First Comment
    Robin,

    Screenshots attached. I have restarted my Fingbox and at least for now it appears to be giving reasonable results. However it did this the other day after I restarted it. Didn't last. I looked back at my October summary and there is a significant drop off starting on the 29th. I have looked at my October and November Performance Reports. I don't believe my network performance is bouncing like this. I can forward them if needed.

    Thanks

    Steven

    Fingbox before reboot                                             Fingbox after reboot



    Mlabs speed from LG7 via WiFi




    Desktop MLab at about the same time


  • pedrofsl
    pedrofsl Member Posts: 1
    First Comment
    ChuckV said:
    I keep getting prompted that v 2.7.1 is available and will load when I reboot. Well, it never loads, and I keep getting prompted. The log file says the update has already been downloaded. But, nothing gets updated. Rinse, repeat for a couple weeks. Suggestions?
    Samo-samo. And looking at Robin's suggestions I wonder if wouldn't be easy justo to make things work instead of put the burden in users. C'mon, guys...it's so hard to write an update pack for Windows? How the rest of the world do it?
  • peterv23
    peterv23 Member Posts: 2
    First Comment
    i was getting daily prompts that 2.7.2 was ready to automatically install, then never did.  i found instruction here to manually run it from \users\[USER]\appdata\local\fing-updater....  there i found an executable called Installer that was still 2.7.1, and a directory called \pending.  in the directory i found Fing-2.7.2.  Removed Installer, then ran Fing-2.7.2.  All seems OK now.