FingAgent 2.6.0 extremely high CPU

Just installed Fing 2.6.0 on Windows 10 20H2 (19042.928) and FingAgent is consuming 40% CPU. I've let it run for 30 minutes in hopes it was just some sort of initialization thing, but it hasn't stopped. Having to turn it off in services.msc...

Best Answer

  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,746
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    #2 Accepted Answer
    Hi @danno57

    I have got in touch with our developers and I would like to share that CPU/GPU is used seamlessly by our UI framework to render pages and graphics. 

    You can disable this utilization but maps won't be working on the Fing desktop. To disable Hardware Acceleration, click on the name on Fing desktop and then go to 'Preferences' and then 'Disable Hardware Acceleration' which will fix your issue. 

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!

Answers

  • danno57
    danno57 Member Posts: 3
    First Comment First Anniversary Photogenic
    Thank you Robin, That does seem to work. Did something change in 2.6.0? I didn't have to do this in 2.5.1...
  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,746
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    danno57 said:
    Thank you Robin, That does seem to work. Did something change in 2.6.0? I didn't have to do this in 2.5.1...
    We added this feature a while back in our older versions to reduce the usage of CPU/GPU. You can check the release notes here: https://community.fing.com/discussion/3955/fing-desktop-release-notes-log
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • danno57
    danno57 Member Posts: 3
    First Comment First Anniversary Photogenic
    My point is that I never had to turn off hardware acceleration in any version prior to 2.6.0, and I've been a fing desktop user since the beta. So something has changed in 2.6.0...
    datagod
  • Norcelis
    Norcelis Member Posts: 6
    5 Likes First Comment
    I have turned off hardware acceleration BUT ... still high cpu by the fingagent. Before 2.6.0. hardware acceleration was ON but never noticed high cpu 
    datagod
  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,746
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Norcelis said:
    I have turned off hardware acceleration BUT ... still high cpu by the fingagent. Before 2.6.0. hardware acceleration was ON but never noticed high cpu 
    Can you quit Fing desktop and then check if the CPU usage going to 0 or not?
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • Norcelis
    Norcelis Member Posts: 6
    5 Likes First Comment
    When the Fing desktop is quit, the CPU usage of FingAgent stays high
    datagod
  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,746
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Norcelis said:
    When the Fing desktop is quit, the CPU usage of FingAgent stays high
    You will need to uninstall Fing desktop completely without leaving any traces and then reboot your device and then install again. It will resolve the issue.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • Norcelis
    Norcelis Member Posts: 6
    5 Likes First Comment
    Yes, that did the trick. Running "normal" again. Thank you for this solution
    Robin_from_Fing
  • Norcelis
    Norcelis Member Posts: 6
    5 Likes First Comment
    Oops. I was a bit to quick. The same high CPU usage is back
    datagod
  • Norcelis
    Norcelis Member Posts: 6
    5 Likes First Comment
    Did some testing with NO running fing client. Restart of the service fingagent: after about 40-45 seconds the high CPU usage occurs 
  • Norcelis
    Norcelis Member Posts: 6
    5 Likes First Comment
    Found it. I had the deep scan option on. That causes the high cpu of fingagent. I switched deep scan off, stopped fing desktop, restarted fingagent, started fing desktop and ... hurray: "normal" cpu again.
    Robin_from_Fingdatagod