Why does Fingbox show devices as in range - including those devices with no WiFi radios at all.

SystemSystem Administrator Posts: 51
First Comment Photogenic
admin
This discussion was created from comments split from: Best tips for using the Fing App.

Comments

  • MaggieLMaggieL Member Posts: 16
    10 Comments 5 Likes Photogenic Founder
    ✭✭
    edited September 2019
     In Range refers to multiple features on Fingbox, It can be for your own device which is under different network or the device which are not under your network(different network) but nearby (Digital Fence). Online refers to the device is under the same network and is connected. In your case, In Range is referred to the device is in the complete signal range of the network. 

    Dropping in here from a search for "in range". Back when my Fingbox was new, I took "in range" to simply mean that my Fingbox saw a device on WiFI frequencies via radio. But while shooting a bug in a desktop machine in my home this morning, I got a notification that the desktop was not only "online", but "in range"...and I'm prety sure (because I built it) the desktop doesn't have WiFI, although it does have a BlueTooth dongle on USB. 

    So...I'm inferring that the meaning of "in range" has expanded somewhat. My Fingbox is in fact on a different managed switch from the desktop in question.
    Developer of management software for proprietary industrial mesh networking equipment
    VioletChepil
  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    @MaggieL I've also split this one off into a new thread. Hope you don't mind. I think this is a useful topic to address in its own right. Let me know if any issues! 

    Community Manager at Fing

  • MaggieLMaggieL Member Posts: 16
    10 Comments 5 Likes Photogenic Founder
    ✭✭
    Yes, since it's gaining a life of its own we should spawn a new thread. :-) 
    Developer of management software for proprietary industrial mesh networking equipment
  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    @MaggieL e Do you have multiple access points? In range will show for devices which are on different access points of same network. If device1 is connected to A network and Fingbox is activated on B network, the Fingbox will show device1 as In Range. Let me know if that could be causing this. 

    Community Manager at Fing

  • MaggieLMaggieL Member Posts: 16
    10 Comments 5 Likes Photogenic Founder
    ✭✭
    Yes, multiple access points. But the APs have the same SSID and are on the same wired network segment.
    Tinsori isn't "on" ANY access point; it is wired-Ethernet only. Which is what puzzles me. 



    Developer of management software for proprietary industrial mesh networking equipment
  • VioletChepilVioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Ok @MaggieL thanks for that - can we get one more thing to troubleshoot this? Can you send over the In-Range screenshot as well?

    Community Manager at Fing

  • MaggieLMaggieL Member Posts: 16
    10 Comments 5 Likes Photogenic Founder
    ✭✭
    This one? 


    Developer of management software for proprietary industrial mesh networking equipment
  • MaggieLMaggieL Member Posts: 16
    10 Comments 5 Likes Photogenic Founder
    ✭✭
    Here's one that's deeper. As you can see, this is a fairly recent development.

    Developer of management software for proprietary industrial mesh networking equipment
  • MaggieLMaggieL Member Posts: 16
    10 Comments 5 Likes Photogenic Founder
    ✭✭

    Developer of management software for proprietary industrial mesh networking equipment
  • RobinRobin Administrator Posts: 1,146
    1000 Comments 50 Answers 100 Likes 25 Agrees
    admin
    Hi @MaggieL
    The reason you are getting In range alerts is due to your network set up. As your Tinsori device is connected to the Netgear switch which is  connected to your router and that router has one more switch connected to it. So in this case, the IP address for the device may get changed or another device may use the same IP address from different access point thus showing your Tinsori device as In-Range. Furthermore, you have all access points named as same. This can create confusion for Fingbox to monitor the IP address range. To solve this, Can you assign a static IP address to your Tinsori device and see if anything changes.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • MaggieLMaggieL Member Posts: 16
    10 Comments 5 Likes Photogenic Founder
    ✭✭
    All the APs have the same SSID because they're all on the same network, (although on different channels) and are (or should be) using the same DHCP server.
    There should be no IP address collisions...I certainly haven't seen any. 
    There's also Megelaar, a laptop that *has* a WiFi radio, but that radio is turned off when it's connected to Ethernet. No in-range alerts in the history for Megelaar. 
    The router has two switches connected to it, and one of them has two more switches downstream.
    I had thought "in range" meant a device had been heard on a 2.4 radio in the FingBox.
    I'd expect you'd track WiFi devices by MAC. You're doing it by IP?

    Developer of management software for proprietary industrial mesh networking equipment
  • MaggieLMaggieL Member Posts: 16
    10 Comments 5 Likes Photogenic Founder
    ✭✭
    I don't think "Our network management device is emitting wierd, misleading messages because of your network configuration" is a good look. 
    Developer of management software for proprietary industrial mesh networking equipment
  • RobinRobin Administrator Posts: 1,146
    1000 Comments 50 Answers 100 Likes 25 Agrees
    admin
    Hi @MaggieL
    The only way to make sure the set up is working okay is by assigning a static IP address to your device. Can you try that? Once it is done and then check. In-range sometimes will also show for different frequencies if the device is switching between 2.4Ghz to 5Ghz
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • MaggieLMaggieL Member Posts: 16
    10 Comments 5 Likes Photogenic Founder
    ✭✭
    The "device" has no radio, other than a BlueTooth dongle in a USB port.
    It's a Threadripper 2920X desktop I built from parts.
    It's not on any WiFI frequency. Confirmed with a WiFI scanner app.
    Is Fingbox trying to track WiFi devices by IP addresss? It shouldn't. Some WiFI devices never join the network. If you're trying to track WiFi devices by IP addresss, that's a design flaw.   
    No, I'm not going to monkey with my netwrok design to diagnose your box. Manual static IP assignment is for the birds, except in special cases where It might be necessary. You haven't adequately explained why the IP addresss matters here, and I'm unclear that you actually understand the issue. 


    Developer of management software for proprietary industrial mesh networking equipment
  • RobinRobin Administrator Posts: 1,146
    1000 Comments 50 Answers 100 Likes 25 Agrees
    admin
    MaggieL said:
    The "device" has no radio, other than a BlueTooth dongle in a USB port.
    It's a Threadripper 2920X desktop I built from parts.
    It's not on any WiFI frequency. Confirmed with a WiFI scanner app.
    Is Fingbox trying to track WiFi devices by IP addresss? It shouldn't. Some WiFI devices never join the network. If you're trying to track WiFi devices by IP addresss, that's a design flaw.   
    No, I'm not going to monkey with my netwrok design to diagnose your box. Manual static IP assignment is for the birds, except in special cases where It might be necessary. You haven't adequately explained why the IP addresss matters here, and I'm unclear that you actually understand the issue. 



    To address your question, The Fing App discovery will identify devices on a best effort basis, based on the information made available by the device, e.g. the MAC address. There are numerous reasons why the device might not be recognised correctly e.g.

    - The DHCP server is not refreshing when speaking to your Fingbox.

    - Limited information being offered by specific devices.

    From your screenshot, I can understand either the device is going to sleep mode and then after a period of time it is showing Offline or you have changed the state change auto for that device. The reason you may be experiencing this issue in relation to alerts for specific users, is that you might have changed the state change alert from default value to a different value. The usual default value is 20 minutes. Sometimes, when the device is not in use, it may go to sleep mode and then if the state change is set to the lowest value of 1 or 2 minutes, it can be recorded as offline or out of range. So, when it returns back from the sleep mode, it will be marked as 'Online' and thus providing you with an alert. If the state change alert value is set to more than 20 minutes, then until that time period is finished, that device will still be marked 'Online' and only after that time period it will be recorded as 'Offline', thus providing you with an alert. 

    In order to change the alert settings, please click on the device from the device list and then scroll down to 'State Change Timeout(auto)' . You can then set the value to at least 20 minutes. This will resolve your issue.


    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
Sign In or Register to comment.