Every time Raspberry Pi reboots it is detected as a new device by Fing

PeterD
PeterD Member Posts: 3
First Comment
edited April 22, 2021 in Devices & Security #1
Even though the IP address is unchanged each time, every time I reboot my rPi 400 (running Raspberry Pi OS with Cinnamon) Fing reports a new device on the network.  I've been using Fing/Fingbox for years and never encountered this before.  Any ideas?

Best Answer

  • Pixel
    Pixel Devon, U.K.Member, Moderator, Beta Tester Posts: 403
    100 Likes 25 Answers 100 Comments Second Anniversary
    ✭✭✭✭
    #2 Answer ✓
    Hi @PeterD

    The wifi connection from your Pi is using private addressing which means each time you log in to a wifi network it is generating a new MAC address to stop you be tracked across networks. All operating systems are starting to use this feature but it can, usually, be disabled for known networks so check the wi-fi settings on your pi (for your network) and you should be able to disable private addressing (It might have a different name). I am not overly familiar with Linux/Pi so can’t explain how to disable it.
    rooted

Answers

  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    Hi @PeterD
    You can check from the alerts if it has exactly same MAC or different even by single digit. If MAC is different then Fing is working properly and your Pie is creating virtual MAC address everytime it reboots which is picked up as new device by Fing app.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • PeterD
    PeterD Member Posts: 3
    First Comment
    Thanks for replying.  Each message from Fing gives a different MAC so Fing is working as expected.  I don't know why the rPi is doing this as I've not had it happen before.  Maybe there's a setting on the rPi side that's been changed?
    Pixel
  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    PeterD said:
    Thanks for replying.  Each message from Fing gives a different MAC so Fing is working as expected.  I don't know why the rPi is doing this as I've not had it happen before.  Maybe there's a setting on the rPi side that's been changed?
    I don't have a Pie to test but I believe our moderators can advice something on this. Any advice @Marc @Pixel @rooted
    Thanks


    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • rooted
    rooted Gulf Coast, USModerator Posts: 898
    250 Likes 500 Comments 50 Answers Third Anniversary
    ✭✭✭✭✭

    It's becoming a common feature on Android phones as well, it's called randomize MAC and is enabled by default on both my Pixel phones.

    [Deleted User]
  • PeterD
    PeterD Member Posts: 3
    First Comment
    Thanks for all your very helpful responses.  Mystery solved.
    [Deleted User]