Why do I get a blank window, on starting Fing

I'm running Fing Version 2.4.1 (2.4.1) on a MacBook Air (M1), with MacOS v11.1. I get a blank window on starting Fing and nothing seems to happen. Any thoughts please? (Is it M1 compatibility?)

Best Answers

  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    #2 Answer ✓
    Hi @Andrew_Stirling

    To address the blank screen, Can you please follow these commands on the terminal and let me know of the result?  
     

    • Command 1: /usr/bin/pgrep fingagent 

    • Command 2: sudo lsof -nP -iTCP:48080 -sTCP:LISTEN 

     
    On running the 2nd command, it will ask for a password and you need to enter the login password of your MacBook 

    Also, after running the 1st command it will return a number, suppose 123. You need to enter that number in the command below and then reboot your device and then check if the issue persists. 

    Commandsudo kill -9 123 


    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    #3 Answer ✓
    I have sent a message to support at the above email address, to see what they recommend.
    In this case, the service might have been disabled and cannot launch until the service is re-enabled. This is likely the result of the service having been unloaded using 'launchctl' in conjunction with the -w switch. This will disable the service. This condition can remain, even if the software is uninstalled and reinstalled.

    To resolve:

    Re-enable the disabled service using the following commands:

    • sudo launchctl load -w /Library/LaunchDaemons/com.fing.service.plist


    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
    Andrew_Stirling

Answers

  • Andrew_Stirling
    Andrew_Stirling LondonMember Posts: 4
    Name Dropper First Comment Photogenic
    Hi @Robin, thanks very much for your advice. I followed the steps listed and rebooted. When restarting Fing I get further than before, but there's a message 'Fing Service Not Found'. I don't see Fing listed in the Firewall exceptions, but am not sure if that would make the key difference here.
  • Andrew_Stirling
    Andrew_Stirling LondonMember Posts: 4
    Name Dropper First Comment Photogenic
    I have sent a message to support at the above email address, to see what they recommend.
  • Andrew_Stirling
    Andrew_Stirling LondonMember Posts: 4
    Name Dropper First Comment Photogenic
    Thanks again Robin - enabling the service, as you described, worked!
    Robin_Ex_Fing