Fingbox is intermittently blocking all wifi devices ("auto block new devices" is off)

stephan
stephan Member Posts: 17
10 Comments Name Dropper First Anniversary Photogenic
Intermittently my MacBook Pro connected to 5GHZ WiFi on my router seems to get blocked. As well as my spouse's MacBook Pro connected to the same 5 GHz Wifi at the same time. Probably other devices gets blocked as well, but I don't know. 

To solve the issue I switch to the 2,4GHz network, and then it can connect to internet again, and then I immediately switch back to 5 GHz again, and it works fine.

It happens like every other day or so, and most often in the morning. And typically maximum once a day.

This only happens when my Fingbox is connected. I pulled the plug on my fingbox for 2 months and it never happened during that time. The "auto block new devices" setting is off.

Answers

  • Marc
    Marc Moderator, Beta Tester Posts: 2,671
    1,000 Likes 2500 Comments 100 Answers 250 Awesomes
    ✭✭✭✭✭✭
    @stephan, even with auto block off you can still set a device to be blocked individually.  Have you checked the devices settings on yours and your wives Mac to be sure?  I would also check all of your devices to make sure non have an individual setting enabled.

    @Robin, do you have anything else Stephan should be looking at?
    Thats Daphnee, she's a good dog...
  • stephan
    stephan Member Posts: 17
    10 Comments Name Dropper First Anniversary Photogenic
    @Marc
    I have now verified that the devices is not blocked individually. And they work almost all the time, it's just once every other day or so I have trouble. And I actually think it's the whole network which stops working. It's jus that the MacBooks Are the ones that we notice it on. The network has been working flawlessly for about two months until I reconnected the Fing box
  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,761
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Hi Stephan
    Can you check the network size set on your Fing app. Under App Settings, please make the following 2 changes: 


    1. Disable Reverse DNS Lookup 

    2. Change the Maximum network size to match your network size. 

    To do this: 

     

    • Open the Fing app, ensure that you are on the Network associated with your Fingbox 

    • Tap on the Avatar icon in the top-right corner 

    • Choose 'App Settings' 

    • Scroll down and go to the "Maximum Network Size" setting and select the size based on the number of devices connected to network in your house. 

     
    After this check if the issue persists?

      
     

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • stephan
    stephan Member Posts: 17
    10 Comments Name Dropper First Anniversary Photogenic
    edited December 18, 2020 #5

    Ok, done. But how would changing Fing App settings solve this issue? I'm not using the app. I'm using the fing box. @Robin

  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,761
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    stephan said:

    Ok, done. But how would changing Fing App settings solve this issue? I'm not using the app. I'm using the fing box. @Robin

    If the network size is not correctly set on Fing app then Fingbox will allow only some devices to get IP address and then other devices may not be able to get the IP address thus acting as blocked. Fing app is the only thing which manages Fingbox so in order to make changes on Fignbox you have to use and set things correctly on Fing app. The way the Fingbox blocks is through ARP poisoning and DNS Spoofing.  So what is happening is that when you block a single device, the computer DHCP address and DNS entries gets changed and pointed to the Fingbox.  So this device is blocked from getting to the internet or internal resources. 
     
    For more information on ARP poisoning and DNS Spoofing see the following links: 
    Blocking is done by DNS/Blocking Spoofing. 
    https://en.wikipedia.org/wiki/DNS_blocking 
     
    The Fingbox/App work to pause things by a process called ARP poisoning/Blocking. 
    https://en.wikipedia.org/wiki/IP_address_spoofing
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,761
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Can you confirm if the steps resolved the issue @stephan? Thanks


    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • stephan
    stephan Member Posts: 17
    10 Comments Name Dropper First Anniversary Photogenic

    The steps did not resolve the issue. Got the issue this morning again. Are there any logs I can provide from the fing box that could be of help?

  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,761
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    stephan said:

    The steps did not resolve the issue. Got the issue this morning again. Are there any logs I can provide from the fing box that could be of help?

    Is it blocking the same set of devices or any random device? Did you check under router settings if those blocked devices were able to get the IP address?
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • stephan
    stephan Member Posts: 17
    10 Comments Name Dropper First Anniversary Photogenic

    I can't check because I can't access the network when I get blocked. Seems like all devices on the network gets blocked. Perhaps the fing box is blocking my router in some way. I use the service "uptime doctor", and sometimes when this happens I also get reports from them that my server on the network is not available from internet.

  • Marc
    Marc Moderator, Beta Tester Posts: 2,671
    1,000 Likes 2500 Comments 100 Answers 250 Awesomes
    ✭✭✭✭✭✭
    if you have the mobile app installed on your phone, disconnect from Wifi and use the mobile network to connect back to your Fingbox.  I don't believe a Fingbox can block itself from the internet.
    Thats Daphnee, she's a good dog...
    Robin_from_Fing
  • stephan
    stephan Member Posts: 17
    10 Comments Name Dropper First Anniversary Photogenic
    Ok, now it happened while I had the time to investigate. This time it seems like it was only my MacBook that was blocked. My phone was able to reach internet while connected to WiFi. I manually disabled wifi on my MacBook and enabled it again and then it started working. Previously I have successfully switched between 5GHz and 2.4GHz network to make it work again, without totally disabling the wifi on my MacBook. Lately is has not happened as often as before. It was about two weeks ago since last time.

    Earlier this fall I had this issue more than once a week, and I then pulled the power plug on the Fing box for two months and didn't have the issue once during that time. Then I connected the Fing box again and then the issues started to appear again.

    When the MacBook can't connect it can't ping even local devices using IP. I opened the Fing App on my phone and connected it to my fing box and tried to ping the MacBook. All attempts fail.

    I have dual boot on my MacBook and have had this issue on both installations of Mac OS.




  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,761
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Thanks @stephan
    Can you check network mask size set on router as well as Fing app? Make sure that 'Maximum network size' match your network size based on the number of devices in the house. Normally it should be a /24  
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • stephan
    stephan Member Posts: 17
    10 Comments Name Dropper First Anniversary Photogenic
    edited January 7, 2021 #14
    19 of 61 devices are online according to the Fing app/box.

    MacBook network:


    Fing Box network:


    Airport Router LAN:

  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,761
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Thanks @stephan
    Can you perform a power cycle of your router and Fingbox and then check over the period of 24 hours if the issue persists? I will be looking forward to your reply.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • stephan
    stephan Member Posts: 17
    10 Comments Name Dropper First Anniversary Photogenic
    I experienced the issue a week ago and power cycled the Fing box and router. Today I got strange behaviours again. Power cycled both devices. I have now put the Fing box on a power outlet which will power cycle automatically every night. If that doesn't work Ill try to disconnect the Fing box again for a longer time again and see if it helps this time as well.
    Robin_from_Fing
  • stephan
    stephan Member Posts: 17
    10 Comments Name Dropper First Anniversary Photogenic
    No luck, had the same issues the day after. Just a clarification is that this is not just wifi devices (which I wrote in the subject). I also have a server connected via ethernet cable which seems to go down as well. not always at the same time as my laptop. I have an external ping service which monitor uptime on my server, so I can see that it goes down as well.

    I have disconnected the Fing box now. Well know soon if it's something else in the network that causes this or if it is the Fing box.
    Robin_from_Fing
  • stephan
    stephan Member Posts: 17
    10 Comments Name Dropper First Anniversary Photogenic
    Seems like the Fing Box is not the culprit after all. I know I had issues this fall when I connected the Fing Box and they went away when I disconnected the Fing Box for almost two months. But it might have been just a coincidence.

    I will continue looking for the culprit by disconnecting other devices one by one for a couple of days at a time.
    Marc
  • hopkins35
    hopkins35 Member Posts: 16
    10 Comments First Answer 5 Agrees 5 Likes
    This is interesting, I've been having DHCP assignment issues for a number of years with WiFi clients, I've always blamed my Unifi APs as they've got a reputation of having issues with 3rd party DHCP servers but truth be told I also had problems with my Draytek APs as well. I have quite a complicated setup with a number of VLANs and several different DHCP servers working across those VLANs. When the problem occurs I can see the clients broadcasting their DHCP discover messages but the servers don't send an offer. To cut a long story short I disconnected my Fingbox two weeks ago due to the ongoing issues with false offline reporting and low and behold my DHCP issues have disappeared. The Fingbox has been in place since 2018 alongside my Draytek APs and now the Unifi ones and I never suspected that it might be the cause of my issues