Xfi won't properly reserve IP address for device; printers show as unconnected

Hi. Posting this here because Comcast hasn't a clue.

I just switched from a third party router to the Comcast xfi gateway. I hate that there's no network map, that only MAC addresses rather than common language names show on the connected device list, and that I can't change host names in the edit dialogues, but I was allowed to change the LAN address to its previous state (to 192.168.0.x from 10.0.0.x), and the gateway is working okay with two exceptions:

 

(1) I tried re-reserving at the same IP addresses the MAC addresses of devices that I previously reserved on the old router. Everything seems to be okay on that score except for one device, a Sonore microRendu audio streamer, which keeps reverting to the same DHCP-assigned address. With my old router, it was at 192.168.0.6, but now it's always reachable only at 192.168.0.246, even after the assignment page tells me it has saved the new address and the connected devices list shows it at the new address. 

I have disconnected the device from the network and, after ten minutes or so, can tell the gateway via the phone app to "forget this device," but it always comes back on at the same 192.168.0.246 address. My old router would allow me to disconnect and forget a device instantaneously, but this one doesn't seem to do that, and "forget this device" definitely doesn't work. (I note that others posting in the Comcast forums have had the same issue and there's been no solution posted other than to try "forget this device." There must be something one can do to make "forget" a useful option.)

 

(2). My two printers definitely are connected to the network as I have been able to print off to them from my computer and can ping them, but the router interface, the Xfinity webpage, and the Xfinity app all show them as disconnected. It isn't a big deal because they are working okay, but how can I get them to be recognized as connected?


Thanks for your help!

Tagged:

Answers

  • RWild
    RWild Member Posts: 60
    25 Likes 10 Comments First Anniversary 5 Awesomes
    ✭✭✭
    These don’t really sound like Fing problems but anyway . . .

    The problem with the printers may be that you have basically reserved addresses for the printer in your new router but still have the printer itself set to request an IP address. In a case like this, I believe the printer wins.


  • RWild
    RWild Member Posts: 60
    25 Likes 10 Comments First Anniversary 5 Awesomes
    ✭✭✭
    Forgot to mention - some routers will act like they don’t know about devices that set their own IP addresses, even if they address is on the same subnet.
  • MikeRubin
    MikeRubin Member Posts: 7
    First Anniversary Name Dropper Photogenic First Comment

    Thank you for addressing this. No, it's not a Fing issue but I haven't been able to get it addressed elsewhere, even on network-oriented forums. There definitely are network experts here, so it doesn't hurt to ask.

    I wasn't clear in my post about how I set up the printers and for that I apologize. I set each with static IP addresses in its own firmware. The router obviously sees the printers because I can print over the network and they are pingable at the static addresses. The router's device list shows them offline, though, albeit with the proper static addresses reserved.

    When they are an option, my preference is for static IP addresses in device firmware rather than reserving IP addresses in the router. The xfi has no trouble dealing with those properly. In contrast, except for the printers showing erroneously as being offline, the problems are with devices that can't be set at their own static IP addresses but that rely on web interfaces that prefer their having fixed addresses. These are the devices that cannot be reserved successfully.

    The network map, such as it is, shows these devices at the addresses reserved for them, but they remain at different, unalterable addresses in reality. See the example above, where my audio streamer always shows on the network map at the address I asked be reserved, but, in reality, it is not at that address. Instead, it remains on the first DHCP-assigned address and I just can't get it to move from there even when disconnecting and reconnecting from the network, rebooting the device and router, and telling the router to "forget" the device. I can live with the outcome as long as the DHCP-assigned address remains unchanging, but I like to keep my reserved devices within a specific reserved IP range at the top of the address list and the unmoving ones are outside of it.

    Thanks again for your comments.