Fing Desktop says I have no internet connection, but I do have internet connection

I_am_not_here
I_am_not_here Member Posts: 6
Photogenic Name Dropper First Comment
edited November 2, 2020 in Fing Desktop #1
Hello,

I have a problem with the Fing Desktop app on my Windows10 PC. It says that I have no internet connection, but I actually have connection. I don't even need to have internet for what I'm using Fing for (I scan my LAN with it).

Could it be that Fing tries to reach a certain site to determine if it has internet connection? I recently installed Pi-Hole (an adblocker that works on DNS base). Maybe the link that Fing uses is somewhere in the lists, but I would want to know what I have to whitelist.

As you can see, the start speed test is clickable, but the see all devices is a lighter shade of blue and not clickable. If I click the speed test, the test actually runs.

Thanks in advance


Answers

  • Marc
    Marc Moderator, Beta Tester Posts: 2,802
    250 Answers 1,000 Likes 2500 Comments 250 Awesomes
    ✭✭✭✭✭✭✭
    Hi @I_am_not_here, as a test try disabling pi_hole and see if it goers away.  Could be some site blocking causing this...
    Thats Daphnee, she's a good dog...
    Robin_from_Fing
  • I_am_not_here
    I_am_not_here Member Posts: 6
    Photogenic Name Dropper First Comment
    Hello @Marc
    Thank you for the suggestion, but it still doesn't work. I closed Fing (made sure it was not in the task bar minimized). Then I disabled the Pi-Hole and started Fing again, without a change.

    However, I have found something that does actually make it work again: change my IP address from Static to DHCP (I did set it static so I can reference only my PC and my smartphone to the Pi-Hole without affecting my entire network. I did the static IPs outside of the DHCP scope (the DHCP scope is x.x.1.2 --> x.x.1.63. I started the static IPs at x.x.1.100)

    Do you have any idea why this behavior comes up? I even tried setting my DNS server back to my router (the way DHCP sets it), but that didn't work, only the actual change from static to DHCP did work.
  • Marc
    Marc Moderator, Beta Tester Posts: 2,802
    250 Answers 1,000 Likes 2500 Comments 250 Awesomes
    ✭✭✭✭✭✭✭
    I’m not familiar enough with how pi-hole works to be able to tell you.  Perhaps someone else from the forums can?
    Thats Daphnee, she's a good dog...