IOS 14, Fing thinks I keep leaving

2»

Answers

  • Adampk17Adampk17 Member, Beta Tester Posts: 6
    First Comment Photogenic

    Actually, hasn’t it been widely available in beta for a couple months?

  • RobinRobin Administrator Posts: 2,828
    2500 Comments 100 Answers 250 Likes 100 Awesomes
    admin
    Adampk17 said:

    Actually, hasn’t it been widely available in beta for a couple months?

    For developers testing we need the production version to be released. We are working on updates and I will update everyone on community as the progress follows. Thanks
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • Lee_BoLee_Bo Member Posts: 272
    100 Comments 100 Likes 5 Answers 25 Agrees
    ✭✭✭
    Well, I turned Use Private Address off on my iPhone, iPad and Apple Watch.  I removed the entries from Fing and rebooted the Box.  Rebooted all three Apple devices.  And BOOM, duplicate entries appeared for all three devices in Fing, even after disabling UPA.  Rebooted all devices again, same issue.  Ubiquiti client list shows only one device each.
  • Lee_BoLee_Bo Member Posts: 272
    100 Comments 100 Likes 5 Answers 25 Agrees
    ✭✭✭
    Oh, and ny the way:
    https://www.fing.com/news/private-mac-address-on-ios-14
    We shouldn't have to disable this feature, even for our home networks, for Fing to work properly.  My Ubiquiti is only showing one iPhone, iPad and Apple Watch, but Fing is now showing 3 of each.
    Marc
  • MarcMarc Moderator, Beta Tester Posts: 1,627
    100 Answers 1000 Comments 500 Likes 100 Awesomes
    ✭✭✭✭✭✭
    @Lee_Bo, thanks for the link.  The issue with multiple access points, as I have a mesh network, was killing me till I turned private addressing off.  Now at least I understand the “why”.
    Thats Daphnee, she's a good dog...
  • Lee_BoLee_Bo Member Posts: 272
    100 Comments 100 Likes 5 Answers 25 Agrees
    ✭✭✭
    Well I've turned private addressing off on my iPad, but Fingbox is still seeing it multiple times.
  • MarcMarc Moderator, Beta Tester Posts: 1,627
    100 Answers 1000 Comments 500 Likes 100 Awesomes
    ✭✭✭✭✭✭
    Multiple active or active / inactive?  I ended up having to delete the inactive entries or rather the virtual Mac ones manually after I switched it off.
    Thats Daphnee, she's a good dog...
  • KayJayKayJay Member, Beta Tester Posts: 38
    25 Likes 10 Comments 5 Awesomes First Anniversary
    ✭✭✭
    Hi Everyone, has anyone else noticed that this constant leaving/joining issue is only on their iPhones?  I have an iPhone 8 Plus and that is the only device that I have had to turn off the Private Address setting on.  On my Apple Watch Series 3 and my iPad Mini 5, they are working fine with Private Address turned on.  They showed up once as a new device, so I treated them as new devices and removed the old ones and have not had any issues with them at all.  I also have a mesh network with multiple "pods" throughout the house.  Again, this issue only affects my iPhone and the Private Address assigned MAC address is the same as when I first upgraded to iOS 14 and joined my home network.
  • MarcMarc Moderator, Beta Tester Posts: 1,627
    100 Answers 1000 Comments 500 Likes 100 Awesomes
    ✭✭✭✭✭✭
    edited September 25
    @KayJay, take a look at this article..  https://www.fing.com/news/private-mac-address-on-ios-14

    Specifically, 

    Because Private MAC Addresses are bound to the access point identifier rather than the WiFi network name, if you have multiple access points serving your network in WiFi roaming, you may be required to perform this operation multiple times for each device. Indeed, a new randomised MAC address will be generated every time the iOS device jumps from being connected to a WiFi access point A to another WiFi access point B of your network.
    Thats Daphnee, she's a good dog...
  • KayJayKayJay Member, Beta Tester Posts: 38
    25 Likes 10 Comments 5 Awesomes First Anniversary
    ✭✭✭
    @Marc, I did read the article, however, as I mentioned, I don't have that issue on my Apple Watch or my iPad.  They are still using the Private Address setting turned ON and Fing never reports them as randomly leaving or joining the home network, even when they switch between access points in the network.  They showed up one time as new devices.  I treated them as new devices and haven't had any issues with either of them since.  Only the iPhone experiences this issue which is why I have turned off the Private Address on my iPhone as suggested.
  • MarcMarc Moderator, Beta Tester Posts: 1,627
    100 Answers 1000 Comments 500 Likes 100 Awesomes
    ✭✭✭✭✭✭

    My personal experience was I had to turn it off for all of the apple mobile devices in my house. That’s included a watch series 5, ipad pro 11, iPhone XR and iPhone 11. They all gave me grief with the latest versions of iOS till I did that.

    Thats Daphnee, she's a good dog...
  • KayJayKayJay Member, Beta Tester Posts: 38
    25 Likes 10 Comments 5 Awesomes First Anniversary
    ✭✭✭
    @Marc, yes that is what some other people are saying as well, but I haven't experienced that same issue.  As I said, it works perfectly fine on my Apple Watch and iPad Mini...just not my iPhone 8 Plus.  Do you think that this issue could be related to the actual hardware?  Is it possible that different wireless cards are affected differently by this Private Address setting?  It might be something for the Fing Team to consider in their troubleshooting/future version planning.  Really, I'm not sure why it works on my Watch and iPad and not on my iPhone.
  • MarcMarc Moderator, Beta Tester Posts: 1,627
    100 Answers 1000 Comments 500 Likes 100 Awesomes
    ✭✭✭✭✭✭
    Thats quite possible.  The only good thing about this all is its settable by ssid, so turning it off on your home network only affects your home network.  
    Thats Daphnee, she's a good dog...
  • KayJayKayJay Member, Beta Tester Posts: 38
    25 Likes 10 Comments 5 Awesomes First Anniversary
    ✭✭✭
    Yes, that's true although it would be nice not to have to turn it off since it's an extra layer of security and we can't be too secure these days.  :)
    Adampk17
  • KayJayKayJay Member, Beta Tester Posts: 38
    25 Likes 10 Comments 5 Awesomes First Anniversary
    ✭✭✭
    One other thing I noticed, my wife's iPad Mini 4 was doing the same thing and I had to disable the private wifi address on it as well.  This definitely seems to be hardware related.
  • JohnnyJackammerJohnnyJackammer Member Posts: 11
    10 Comments Photogenic
    I have "private address" off for all of my devices now. Yet still running into odd events.
    In our router I assign all of the devices in our home an IP addresses based on their MAC addresses. So I can recognize which device is connected by their IP address.
    Today I received a FING email notice for a "watched device" it was my iPhone. Fing didn't associate it with my iPhone - it was listed as a separate device yet with the same IP address as the Known Device in the devices list. This ghost device was also blocked.
  • Lee_BoLee_Bo Member Posts: 272
    100 Comments 100 Likes 5 Answers 25 Agrees
    ✭✭✭
    Marc said:
    Thats quite possible.  The only good thing about this all is its settable by ssid, so turning it off on your home network only affects your home network.  
    Well, that's SUPPOSED to work, but it's not.  And we shouldn't have to make privacy changes on our devices to make manufacturer's products work.

    So for testing, I have turned off private addressing on my iPhone, iPad and Apple Watch.  Several times a day I get notifications that "Lee Bo's iPhone has connected to....., Lee Bo's iPad has connected to.......,Lee Bo's Apple Watch has connected to......", rinse and repeat, over and over.  Then I look in the Fing app and see one active iPhone and several inactive iPhones, all with private IP addressing turned OFF.  And what really sucks is I have "auto block new devices" enabled.  Unfortuantely I've now had to disable that feature until the Fing dev's can figure it out.
  • MarcMarc Moderator, Beta Tester Posts: 1,627
    100 Answers 1000 Comments 500 Likes 100 Awesomes
    ✭✭✭✭✭✭
    Since I turned it off I have not seen that behavior but, I do not have auto-block on.  I could enable it if you want me to if we want to see if that's an issue that could affect anyone.
    Thats Daphnee, she's a good dog...
  • JohnnyJackammerJohnnyJackammer Member Posts: 11
    10 Comments Photogenic
    I do have auto-block on. That's the one security feature that makes fing worth using for me.
    Lee_Bo
  • Lee_BoLee_Bo Member Posts: 272
    100 Comments 100 Likes 5 Answers 25 Agrees
    ✭✭✭
    I do have auto-block on. That's the one security feature that makes fing worth using for me.
    <mic drop>
  • MarcMarc Moderator, Beta Tester Posts: 1,627
    100 Answers 1000 Comments 500 Likes 100 Awesomes
    ✭✭✭✭✭✭
    Lee_Bo said:
    I do have auto-block on. That's the one security feature that makes fing worth using for me.
    <mic drop>
    I just lost it, great reply...  
    Thats Daphnee, she's a good dog...
  • JohnnyJackammerJohnnyJackammer Member Posts: 11
    10 Comments Photogenic
    Lee_Bo said:
    I do have auto-block on. That's the one security feature that makes fing worth using for me.
    <mic drop>
    Because you agree.... or disagree?
  • MarcMarc Moderator, Beta Tester Posts: 1,627
    100 Answers 1000 Comments 500 Likes 100 Awesomes
    ✭✭✭✭✭✭
    edited October 9
    I loved your mike drop comment.  

    I  get frustrated with the impediments Fing faces when implementing this stuff.  IPV6, virtual Mac addresses per SSID.  To be honest, with some of these new security measures, I’m not sure if the mobile version can be built to circumvent, unless the OS vendors build in an API or something that Fing can use to get around  it.  I wonder at times if the desktop version was introduced as a way to address these limitations.
    Thats Daphnee, she's a good dog...
  • ssj152ALssj152AL Member, Beta Tester Posts: 3
    First Anniversary Photogenic First Comment
    I think that Apple having this setting default to ON without explanation was another boneheaded decision and was as detrimental to the use of Fing boxes as was Spectrum patching their modems boot load provided  to customers; enabling IP V6 without any warning. This last move locked my router up tight. I spent two weeks figuring what  the problem was and patching my router.
  • BnelmsBnelms Member Posts: 5
    Photogenic First Comment
    SteveP said:
    I have iOS 14 beta loaded on a test iPhone and started seeing my Fingbox detecting it as a new device more than once. It turns out there is a new anti tracking feature in iOS 14 called "Use Private Address". It is found under Settings/Wi-Fi/SSID and should probably be turned off for your Fingbox managed network. It will periodically change the MAC address of your device for that particular SSID.
    Ya my Iphone 7 and Ipad kept getting blocked...  Thanks,,,
  • ShooterShooter Member Posts: 15
    10 Comments First Anniversary Name Dropper Photogenic
    Is the way my FingBox sometimes & temporarily gets listed on the app's device list page (Android) with multiple IP addresses, also an effect of upgrade to IOS 14? (see Screenshot)  Thanks! 


Sign In or Register to comment.