Fing Desktop Insists I am not connected to the network

Hello, 
I am running Windows 10 (latest patch level) and Fing Desktop 2.2.0. 
Fing desktop insists I am not connected to the network at all. However, everything else works fine. I am able to surf, check e-mail, etc, etc. Pings done from the command prompt work fine: 

Also, my Fingbox is just fine and working normally, it is just Fing Desktop. 
I have confirmed it is not the Windows firewall, and I have reinstalled Fing Desktop. 
Any ideas?
David
Tagged:

Answers

  • kltaylor
    kltaylor Member, Beta Tester Posts: 1,231
    1000 Comments 500 Likes 50 Answers 100 Awesomes
    ✭✭✭✭✭✭
    Hi @DavidF thanks for asking your question.
    Thanks for the screenshots, this helps a lot.  Or ... not as much as I'd like for it to be.
    I'm wondering if you have something like a VPN running on your machine, what your DNS settings are, things like that.  Can you provide to me as much info as you can about the machine that refuses to acknowledge your online presence?
    "There's a fine line between audacity and idiocy."
    -Warden Anastasia Luccio, Captain
  • DavidF
    DavidF Member Posts: 34
    10 Comments 5 Answers First Anniversary 5 Agrees
    ✭✭
    No VPN and I am using Google DNS - both of which are pingable from the FIng Desktop. In fact Fing Desktop passes all of those checks in its network check. See below: 

    The machine always worked with Fing desktop up until recently (I am not sure if it was the last update on one of the previous ones). The machine is a Lenovo desktop, nothing special about it at all. Could it have to do with fact that the PC has a static IP address? I keep it on the same address rather than having it assigned DHCP. 
  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    Hi @DavidF

    It seems that WinPcap might not be working properly. I would like you to follow these steps and it should resolve this issue: 
     

    • Uninstall WinPcap using any 3rd party software(iobit uninstaller/Revo uninstaller) so that it doesn't leave any traces. 

    • Uninstall Fing Desktop 

    • Reboot pc 

    • Install NpCap or Win10pCap 

    • Download and Install latest Fing Desktop release.  

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • DavidF
    DavidF Member Posts: 34
    10 Comments 5 Answers First Anniversary 5 Agrees
    ✭✭
    edited September 15, 2020 #5
    Thanks @Robin, I will try that. Doesn't Fing install its own version of WinPCAP which it installs? 
    I use NpCap for other programs so perhaps that is the issue. Can Fing use NpCap if I install it first, or will it still install its own WinpCap? 
  • kltaylor
    kltaylor Member, Beta Tester Posts: 1,231
    1000 Comments 500 Likes 50 Answers 100 Awesomes
    ✭✭✭✭✭✭
    Ahh, WinPCap ... Let's find out if that's our culprit or not.  Also wanted to add that using a static IP address on your Lenovo machine should have no effect on this issue.  I have a few machines on my LAN that has a static IP and the desktop app works fine.
    "There's a fine line between audacity and idiocy."
    -Warden Anastasia Luccio, Captain
  • DavidF
    DavidF Member Posts: 34
    10 Comments 5 Answers First Anniversary 5 Agrees
    ✭✭
    @ktaylor When I uninstalled WinpCap it was listed as "WinpCap for Fing" so I am suspicious. I suspect WinpCap and NpCap do not play well together and that is my issue. I have uninstalled both and will reinstall Fing in the morning. 
  • @DavidF How did it work out once you reinstalled?    I have the same issue and hoping you can provide an update.
  • DavidF
    DavidF Member Posts: 34
    10 Comments 5 Answers First Anniversary 5 Agrees
    ✭✭
    @Howard_Frazier123 Following what Robin suggested above did the trick - using NpCap. All up and running again. 
    Robin_Ex_Fing
  • I_am_not_here
    I_am_not_here Member Posts: 6
    Photogenic Name Dropper First Comment
    @Robin I tried following your steps (I used Total Uninstall to remove WinPCap and Fing. After no result, I used Revo Uninstaller like you suggested, but to no avail). I did it in the order you said (remove WinPCap, remove Fing, reboot, install nPCap, install Fing), but the "WinPCap for Fing" kept appearing again in the program list. Is there somewhere an option to select that you don't want Fing to install WinPCap? I noticed that Fing also automatically logs me in on new install.

    Before rebooting, I removed the nPCap that was already there (it was installed by Wireshark).

    When using static IP, it doesn't work, for me, only DHCP address works.

    Here you have a bit more info (I made the question before finding this thread)
  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    Hi @I_am_not_here
    Can you disable the Static Ip address and then check if the Fing desktop works or not. It seems like Fing desktop is not able to read the static IP correctly and when using DHCP assigned IP, It works.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • I_am_not_here
    I_am_not_here Member Posts: 6
    Photogenic Name Dropper First Comment
    edited November 5, 2020 #12
    @Robin as stated in my previous comment, it works when using DHCP.
    I just discovered that Fing on my smartphone still works when giving a static IP to it, so that makes me think that WinPCap is the problem with me too, but I can't seem to install Fing without it. I searched, but I can't find an "advanced" type of installer or option during the installation (a lot of programs do have that, where you can select what parts you do or do not want to install)
  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    @I_am_not_here
    With Fing desktop, WinPcap will be installed automatically. In this case, I am sorry but Static IP address seems will not work. I will seek further advice from developers and get back to you with an update. Thanks
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • I_am_not_here
    I_am_not_here Member Posts: 6
    Photogenic Name Dropper First Comment
    @Robin
    Thank you for the effort, I appreciate it :smile:
    Robin_Ex_Fing
  • I_am_not_here
    I_am_not_here Member Posts: 6
    Photogenic Name Dropper First Comment
    @Robin
    I have the latest version of Fing (2.4.1) and that one doesn't use the WinPcap (so yay about that!), but when my IP is static, it still can't tell that it's online. When I put my laptop in DHCP mode, it works again (so still the same problem as above). I don't want to change my laptop to DHCP every single time to find what I need.

    But before posting, I fiddled a bit more and just discovered something that makes it semi-work with static IP:
    set it static on Network interface level, instead of for 1 specific network.

    This is on the adapter level (then I have to set the wifi network to DHCP). If I do it this way, Fing works, but then I can't forget to change it back once I'm on another wifi network, because it's the adapter that has these settings, so for every network it connects to it will be the same 192.168.1.101 address that it will have.


    And this is when it's static on the wifi network (that is when it doesn't work, even with adapter level static in combination with network level). At least I found a bit of a workaround for myself, and hopefully others can use it too, if they ever have the same kind of problem I have.

  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    Hi @I_am_not_here
    It seems like Fing desktop is not able to work correctly with Static IP address. I will seek further advice on this from developers. As soon as there is an update, I will let you know. thanks
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
    I_am_not_here
  • DavidF
    DavidF Member Posts: 34
    10 Comments 5 Answers First Anniversary 5 Agrees
    ✭✭
    I think you are right - and it seems to extend to DHCP static reservations, not just hardcoded addresses. Fing stays at pending indefinitely and never finishes its testing. 


    Oddly other tests do not complete as well. 


    Note that if I go to a dynamic address (rather than static lease via DHCP) everything completes fine. 

    David
  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    thanks @DavidF
    I will check and investigate this further. I will seek developers advice and get back to you. Thanks
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!