Not accepting DHCP reservation

MartynK
MartynK Hong KongMember Posts: 52
10 Comments 5 Likes 5 Agrees First Anniversary
✭✭
I have just added a reservation for my Fingbox in to DHCP as I need to give it a specific IP.
I unplug the box, delete the old IP from DHCP and added the reservation.
When it came back on to the network, its registered against the same IP, but with a MAC address that is probably 30 chrs long on my server that is only IP4, not IP6.
Should it not be using its normal IP4 MAC address when registering with IP4 DHCP scope, if not there is no way I can override the IP address ?

Answers

  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,882
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Hi @MartynK
    If you are not using IPv6 then it should not happen. I am not sure in this case, what went wrong. Can you check with your ISP if there is IPv6 active?
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • MartynK
    MartynK Hong KongMember Posts: 52
    10 Comments 5 Likes 5 Agrees First Anniversary
    ✭✭
    I dont have any IPv6 active anywhere on my network, I turn it off at every point manuall.
  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,882
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    MartynK said:
    I dont have any IPv6 active anywhere on my network, I turn it off at every point manuall.
    I am not sure of the reason here. Can you share the screenshots of the MAC address that is probably 30 chars long and what kind of router are you using?
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • Fraxis55
    Fraxis55 Member Posts: 3
    First Comment
    Was there a solution found to this?  I'm seeing the exact same behaviour. I have an IPv4 DHCP reservation set to the MAC address, yet it won't pick up that reservation as it registers in my DHCP server with a long Unique ID...

    I do not have any IPv6 scope defined.
  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,882
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Fraxis55 said:
    Was there a solution found to this?  I'm seeing the exact same behaviour. I have an IPv4 DHCP reservation set to the MAC address, yet it won't pick up that reservation as it registers in my DHCP server with a long Unique ID...

    I do not have any IPv6 scope defined.
    Have you assigned static IP to fingbox before or trying to assign static Ip now? Have you contacted your ISP if your set up is correct or not?
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • Fraxis55
    Fraxis55 Member Posts: 3
    First Comment
    It's not possible to assign a static IP to Fingbox. That is why I'm having to do it via a DHCP reservation.  
    My ISP is not related to the issue in question as DHCP doesn't extend beyond the LAN. There is no IPv6 enabled on my LAN network. It's an issue with the Fingbox not registering the correct MAC address with the DHCP server.
  • Robin_from_Fing
    Robin_from_Fing Administrator, Fing Team Posts: 4,882
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    @Fraxis55
    Can you please send a screenshot from the Fing app of the complete Network section? You can DM it to me so I can understand the network better and guide you? Thanks
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!