Fing Desktop v2 issues

Mine Fing upgraded itself, but after that all I got was "Fing Service not found".  The service was running, but nothing was listening to the Fing port. This is the latest Windows 10

I removed & reinstalled the 2.0 desktop.

Everything seemed to work - for about 30 seconds. The Scan devices showed a few named items & a lot of generics, I assume it lost the details when I reinstalled, so I clicked over to a list & back - the Scan feature has disappeared. The device, local network & internet icons on the top right of the home screen just have a plain asterisk. The report is now blank. Notifications didn't show anything. On the tools Ping did eventually work (but used two credits), while Wifi scan does nothing.

I rebooted the PC again - and I am back to "fing service not found". My main use was the scan for devices and to check the internet connection, but as the scan doesn't work & I am upgrading my internet to fibre, with a new router & monitoring software, I think I will just stop here. The version of Fing on my phone works fine, but I have had continual problems with Fing desktop, I fell I'm putting in far too much effort for the use I make of it.

If you can't suggest a simple solution, I will just have to drop it

kquinn99

Answers

  • MarcMarc Moderator, Beta Tester Posts: 2,373
    100 Answers 1000 Comments 500 Likes 250 Awesomes
    ✭✭✭✭✭✭
    edited July 2020
    @Robin or @Ciaran, could one of you help @crishog with his desktop issue?  Crishog I moved this to installation issues for greater visibility. 
    Thats Daphnee, she's a good dog...
  • RobinRobin Administrator, Fing Team Posts: 4,220
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Hi @crishog

    The last time you were installed NpCap and things were working correctly. Did you make any changes after that? If the issue persists, Can you follow the steps again:

    • Uninstall Fing Desktop using any 3rd party software(iobit uninstaller/Revo uninstaller) so that it doesn't leave any traces.

    • Reboot pc 

    • Check NpCap or Win10pCap if they are working. Check if the Firewall or Antivirus is blocking anything.

    • Download and Install latest Fing Desktop release.  

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • crishogcrishog Member Posts: 18
    10 Comments Photogenic
    Yes it was working & it "broke" when it upgraded to v2
    I removed Fing desktop & reinstalled. Currently it is saying I'm not connected to my LAN or to the Internet  - interestingly I can't scan for devices, but I can run a speed test. I have 2 instances of the agent running & one is listening to port 48080. I'm going to do one more attempt to remove everything, including the agent & reinstall while I'm waiting for something else to happen. I will let you know the result
    Robin
  • crishogcrishog Member Posts: 18
    10 Comments Photogenic
    I removed fing, but one instance of the agent was still running (despite services.msc indicating that the service was disabled), but it wasn't listening to the port. I rebooted & deleted manually all remnants of the agent & reinstalled fing
    Now Fing is working again. Somehow the upgrade to v2 added a second agent? But that one wasn't listening to the port. I don't quite understand, but I will keep an eye on what is happening

    Robin
  • crishogcrishog Member Posts: 18
    10 Comments Photogenic
    And the following morning I have one copy of the agent listening to the correct port, but the desktop has no report, the "The Device", "Local Network" and "Internet" areas to the right as all just showing * there is no scan for local devices & the Ping traceroute buttons open a dialog to type a URL, but thatd oesn't do anything
  • RobinRobin Administrator, Fing Team Posts: 4,220
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    crishog said:
    And the following morning I have one copy of the agent listening to the correct port, but the desktop has no report, the "The Device", "Local Network" and "Internet" areas to the right as all just showing * there is no scan for local devices & the Ping traceroute buttons open a dialog to type a URL, but thatd oesn't do anything
    Can you share the screenshot of this and also if other features are working or not?
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • crishogcrishog Member Posts: 18
    10 Comments Photogenic

  • crishogcrishog Member Posts: 18
    10 Comments Photogenic
    for every operation I've tried I just be the "busy" icons
  • crishogcrishog Member Posts: 18
    10 Comments Photogenic
    Upon restarting my PC the agent was running, but not listening to a port. I tried to stop & restart the service. Now I have two instances running, neither of which is listening
  • RobinRobin Administrator, Fing Team Posts: 4,220
    250 Answers 2500 Comments 500 Likes 100 Awesomes
    admin
    Hi @crishog
    I have sent you a private message as I would require further information from you to investigate this. Please reply to my message directly. Thanks
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
Sign In or Register to comment.