Fing App on Apple Mac Getting a Blank Dialogue Box on Scan for Devices on Network

lov2krzlov2krz Member Posts: 17
10 Comments Photogenic
I have reported this on another thread but it turned out to be for Window's 10.
THE PROBLEM:
When I last ran the Mac Fing App on my iMac running OS X 10.5.5 and scan my network for connected devices it returns a blank (white) screen.  As reported in the Window's thread there is a brief flash of screen then it goes white.  Based on suggestions in the Window's 10 thread I've done many restarts with the same results.  

I have done so many attempts Igot to the point where when I tried to download the app and reinstall it I was getting "file is damage" and asked if I wanted to cancel or move to trash.  I moved it to the trash every time, deleted the program and its application support folder and preference pane plus anywhere else fing was located in the library and utilities folders.  I also posted this in that thread about the damaged file message, sorry I don't have the link to that.

When I did a restart in safe mode I was able to install the program but I am still getting the white box after I click scan.  
My iPhone fing app works just fine as it did when I was getting Not Connected errors on the desktop app during a couple of installations that the fing box was not connected on my desktop.  I got that fixed after a half dozen attempts of new downloads and installations.

In total I have rebooted my system more than a dozen times, I have deleted the program more than 10 times, I have reinstalled my OS 3 times and nothing seems to help.  Booted in safe mode with only Safari running.  This problem doesn't care what browser I use, Safari or Firefox.
Please, someone needs to get this resolved. Running Fing Version 1.4.1 (1.4.1) which was downloaded from the Mac OS link on the Fing website.

Since this seems to be occurring on both Window's and OS X ,and the find app version is the same on both, I believe it's in the app and not on the respective PC platform.



Best Answer

  • RobinRobin Administrator Posts: 2,386
    100 Answers 1000 Comments 250 Likes 25 Agrees
    admin
    Accepted Answer
    lov2krz said:
    Robin,
    Fing 2.0 Desktop for Mac running Catalina 10.15.5 seems to be working without issue.
    What did your commands do?
    Thanks,
    Steven
    I simply gave the command to kill the Fing running process as it was struck in memory and once all processes were killed. Fing desktop got refreshed and started working again. I am glad it is working for you now.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!

Answers

  • lov2krzlov2krz Member Posts: 17
    10 Comments Photogenic
    edited June 30
    This issue has been reported for Window's 10 but it's also happening on Apple OS X 10.15.5.
    I've done many restarts with the same results.  I even got to the point where when I tried to download the app and reinstall it I was getting "file is damage" and asked if I wanted to cancel or move to trash.  I moved it to the trash many times, deleted the program and its application support folder and preference pane.  I was able to just now restart in safe mode and installed the program, but I am still getting the blank white box after I click scan for devices on my network.  
    My iPhone fing app works just fine as it did when I got an error on a couple of installations that the fing box was not connected on my desktop.  I got that fixed after a half dozen reinstall attempts.
    I also posted this in the thread about the damaged file message, sorry I don't have the link to that.
    In total, I have rebooted my system more than a dozen times, I have deleted the program more than 10 times, I have reinstalled my OS 3 times and nothing seems to help.  Booted in safe mode with only Safari running.  This problem doesn't care what browser I use, Safari or Firefox.
    Please someone needs to get this fixed. Running Fing Version 1.4.1 (1.4.1) which was downloaded from the macOS link on the Fing website.
    This has also been reported in a couple of other threads, but they deal with Window's 10.  
    This is an Apple Mac (iMac/MacBook) issue.  I've seen other Mac users on other Mac's report the same thing.
    Since this is happening with the same version of Fing App 1.4.1 on both platforms it looks to me to be an app issue.

  • ChrisLiChrisLi Member Posts: 1
    First Comment
    I have the same problem (WIN10). All other screens work. But only the "Scan for device" shows a blank screen.  I tried everything (reinstall, reboot) nothing happend.   :(
  • kltaylorkltaylor Moderator, Beta Tester Posts: 1,191
    1000 Comments 500 Likes 50 Answers 100 Awesomes
    ✭✭✭✭✭✭
    Hi @lov2krz welcome to the community and thanks for asking your question.
    I know that this was an issue for Mac recently, not sure if they've patched that for Mac or not.  Will need to have @Robin comment on that part to be sure.
    "There's a fine line between audacity and idiocy."
    -Warden Anastasia Luccio, Captain
  • lov2krzlov2krz Member Posts: 17
    10 Comments Photogenic

    Thanks for confirming the issue.

    Frankly I would have thought it would have been acknowledged sooner by staff.

    kltaylor
  • kltaylorkltaylor Moderator, Beta Tester Posts: 1,191
    1000 Comments 500 Likes 50 Answers 100 Awesomes
    ✭✭✭✭✭✭
    It was addressed, but I've been away for two weeks so I need to catch up on the Changelog for the application to be sure that it was patched already or not.
    "There's a fine line between audacity and idiocy."
    -Warden Anastasia Luccio, Captain
  • RobinRobin Administrator Posts: 2,386
    100 Answers 1000 Comments 250 Likes 25 Agrees
    admin
    Thanks @kltaylor
    We have just released a new version yesterday Fing Desktop 2.0. @lov2krz Can you uninstall the previous version and delete the network detected by Fing desktop from the web app and then download a new copy and install it under Applications Folder only and then check if the issue persists?

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • lov2krzlov2krz Member Posts: 17
    10 Comments Photogenic
    Robin, I saw a post on the Window 10 thread and found the new macOS version.  I deleted, restarted and reinstalled version 2 and I just reported that the screen is flashing data on and off.  I reported this under the New discussions about the release of the update. 
    I've launched the app a couple of times to see if acted differently and now its showing connectivity problems, yet I can post on this forum.

  • lov2krzlov2krz Member Posts: 17
    10 Comments Photogenic
    I resubmitted this issue under a similar topic title.  Please disregard this post.
    Thanks,
    Steven
  • kltaylorkltaylor Moderator, Beta Tester Posts: 1,191
    1000 Comments 500 Likes 50 Answers 100 Awesomes
    ✭✭✭✭✭✭
    I'm scratching my head on this one, Robin ... wish I could help further.
    "There's a fine line between audacity and idiocy."
    -Warden Anastasia Luccio, Captain
  • RobinRobin Administrator Posts: 2,386
    100 Answers 1000 Comments 250 Likes 25 Agrees
    admin
    Hi @lov2krz
    Can you try these commands under terminal and let me know of the result?
    • /usr/bin/pgrep fingagent

    • sudo lsof -nP -iTCP:48080 -sTCP:LISTEN 

    After the second command it will ask for a password. You need to enter your login password for your mac device
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
    kltaylor
  • lov2krzlov2krz Member Posts: 17
    10 Comments Photogenic
    Robin, sorry I didn't see this until now.  I ran your script twice, once a line at a time and once both lines together.  These are results:
    Last login: Sat Jul  4 10:49:42 on console

    The default interactive shell is now zsh.
    To update your account to use zsh, please run `chsh -s /bin/zsh`.
    For more details, please visit https://support.apple.com/kb/HT208050.
    Steven-Greens-iMac-3:~ SAGreen$ /usr/bin/pgrep fingagent
    116
    Steven-Greens-iMac-3:~ SAGreen$ sudo lsof -nP -iTCP:48080 -sTCP:LISTEN
    Password:
    COMMAND   PID USER   FD   TYPE             DEVICE SIZE/OFF NODE NAME
    fingagent 116 root   21u  IPv4 0x325cb1e5b7fce107      0t0  TCP 127.0.0.1:48080 (LISTEN)
    Steven-Greens-iMac-3:~ SAGreen$ /usr/bin/pgrep fingagent
    116
    Steven-Greens-iMac-3:~ SAGreen$
    Steven-Greens-iMac-3:~ SAGreen$ sudo lsof -nP -iTCP:48080 -sTCP:LISTEN
    Password:
    COMMAND   PID USER   FD   TYPE             DEVICE SIZE/OFF NODE NAME
    fingagent 116 root   21u  IPv4 0x325cb1e5b7fce107      0t0  TCP 127.0.0.1:48080 (LISTEN)
    Steven-Greens-iMac-3:~ SAGreen$


  • RobinRobin Administrator Posts: 2,386
    100 Answers 1000 Comments 250 Likes 25 Agrees
    admin
    Thanks @lov2krz
    Can you run this command: sudo kill -9 116 
    And after that Can you reboot the device and then run the Fing Desktop and let me know if it works?
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • lov2krzlov2krz Member Posts: 17
    10 Comments Photogenic
    Robin,
    Fing 2.0 Desktop for Mac running Catalina 10.15.5 seems to be working without issue.
    What did your commands do?
    Thanks,
    Steven
    Robin
Sign In or Register to comment.