DHCP is not healthy

13»

Answers

  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    Thanks @efiner92
    I have passed on your files to developers for investigation. Can you please provide me the error codes you are getting as well? Thanks
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • AlainCo
    AlainCo Member Posts: 3
    First Anniversary Photogenic First Comment
    Hi, I had the same strange problems since few weeks, and it seems I solved it, so I share my finding.
    Every few hours I had the notification "DHCP not healthy" and about an hour after it was OK, then not healthy...
    Finally, I found that my TP-Link WA850RE repeater (Wifi Range Extender) was configured with a DHCP server  (Networks > DHCP Settings ) as "AUTO". I disabled the DHCP Server, which should work because my Freebox Revolution set top box proposes a DHCP, and the TPlink help says it should work:
    • DHCP Server - Auto or On or Off the server. If you disable the Server, you must have another DHCP server within your network or else you must configure the IP address of the computer manually.
    I have another Asus RT N12 Router which collaborate better with the freebox, maybe because it does not propose any DHCP server, just a client for the access point ethernet LAN port : "Get LAN IP Automatically?" (YES of course)

    If you find a router or repeater with DHCP Server active or auto-configured, try to disable it...

    Hope this helps.
    Robin_Ex_FingKevinE
  • Steve_b
    Steve_b Member Posts: 10
    Photogenic First Comment
    I see many users who do not have multiple DHCP still have this problem.  However no answers or proposed solutions?  Has anyone got a better understanding of this?
  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    Steve_b said:
    I see many users who do not have multiple DHCP still have this problem.  However no answers or proposed solutions?  Has anyone got a better understanding of this?

    The check verifies that a single DHCP server is active: a warning is raised if there is no DHCP or when there is more than one DHCP server offering IP addresses.

    In case there is no DHCP active, it might have happened that your router/DHCP ran out of addresses to assign to new devices; as a last resort step, you could check your router status and power cycle the router: upon reboot it'll restart assigning addresses to devices; please be aware that rebooting your router will cause a temporary interruption of any networking for all devices.
    In case instead the checks reports more than one DHCP running in the network, you should make sure to disable or turn off DHCP's until there is a single one. You should look for other running DHCP's in routers, switches and security devices.

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • Steve_b
    Steve_b Member Posts: 10
    Photogenic First Comment
    Yeah, I've seen this comment before.  And sorry to say I don't really believe it.
    I have over 200 IP addresses available on my network, and a maximum of 75 devices, far less than that at any one time.  FING reports that there is only one DHCP on the network.   So 3 or 4 times a day Fing reports a DHCP issue, and every time I run a re-check (no reboot of router is needed) then it comes back clean.  The occurrence of this error is unrelated to the uptime of the router.
    So yes I am aware that I can suppress the message but that is a self-defeating course of action.  I have paid for the premium version of Fing to be able to resolve potential issues, and not have to switch off facilities because Fing reports issues incorrectly.
    Please can we have some more effective support for this issue?  Let's hope the 'devs' get somewhere soon because this is not good press for Fing.

  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    @Steve_b
    I am seeking further advice on your query from developers. As soon as there is an update, I will let you know. Also, we may require further network information and Fing desktop log files to investigate this. I will get back to you if I need more info. Thanks
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    @Steve_b
    Can you run DHCP discovery tool on Fing desktop and DM me screenshot of the results? Thanks
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • Help4Mac
    Help4Mac Member Posts: 4
    Name Dropper First Comment
    Robin - I've tried to " run DHCP discovery tool on Fing desktop" and it's never returned any results. Also a Pro subscriber.

    GCB
  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    Help4Mac said:
    Robin - I've tried to " run DHCP discovery tool on Fing desktop" and it's never returned any results. Also a Pro subscriber.

    Can you share the screenshot of the result if it gives any error? Thanks
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • Help4Mac
    Help4Mac Member Posts: 4
    Name Dropper First Comment
    Sure, it's the same one we all see. I've got the FingBox connected directly to my router - there are no other DHCP sources, and devices don't have a problem joining the network. Using "DHCP Discovery" just hangs and never produces a result. 
  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    @Help4Mac
    Are you using any Firewall on your device? Which router are you using? Are you using any VPN or VMware?
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • Help4Mac
    Help4Mac Member Posts: 4
    Name Dropper First Comment
    @Robin
    1. Are you using any Firewall on your device? Yes, I have the macOS Firewall turned on for my MacBook Pro
    2. Which router are you using? the Ubiquiti Dream Machine
    3. Are you using any VPN or VMware? I do have a VPN for my company traffic, but not for all data
  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    @Help4Mac
    Can you disable VPN and Firewall and then run the scan for DHCP discovery and check if the issue persists?
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • Help4Mac
    Help4Mac Member Posts: 4
    Name Dropper First Comment
    @Robin  - I gave DHCP Discovery 5 minutes with no results after turning off the Firewall and VPN - so those don't appear to be factors

  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    Help4Mac said:
    @Robin  - I gave DHCP Discovery 5 minutes with no results after turning off the Firewall and VPN - so those don't appear to be factors

    Can you boot your device to safe mode and then try to run DHCP scan and see if the same error persists? Thanks
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • sarahlizzy
    sarahlizzy Member Posts: 4
    Photogenic First Comment
    Getting this error a lot too. DHCP is fine. Fing Desktop on a Mac
  • claudiolr
    claudiolr Member Posts: 10
    10 Comments Name Dropper Photogenic
    Getting this error too every single day but DHCP is working fine and I have no problem with my devices. DHCP discovery is ok.
  • sarahlizzy
    sarahlizzy Member Posts: 4
    Photogenic First Comment

    Since the most recent upgrade it’s started constantly complaining about DHCP IP address clashes on IPs that aren’t even allocated. I wish I could just tell it to ignore DHCP checks, since they seem to be broken.

  • AlainCo
    AlainCo Member Posts: 3
    First Anniversary Photogenic First Comment
    Hi, I had this problem few months ago, but I reorganized many things (new computer, OpenWrt routers in AP no DHCP mode...)... and I encountered a problem with IPV6, which finally was because my network driver did not catch some multicast properly.
    I updated my driver from the manufacture website (ASIX AX88179 USB 3.0 to Gigabit ) with a version not available via Windows update, and all was solved.
    Independently, I have no more any DHCP problems (dunno if it is the cause, I've reinstalled Fing recently).

    I advise you to check this hypothesis... one way I discovered the problem was using Wireshark, and the symptom was that while I was using Wireshark, all was working properly, as my driver was in "compromised mode".

    DHCP is based on multicast address, and it may be a similar problem (or not).

    Good struggle.

  • sarahlizzy
    sarahlizzy Member Posts: 4
    Photogenic First Comment

    Thanks. I’m using Pi-hole for my DHCP and it does support ipv6, but all the warnings about clashes are for (unassigned) ipv4 addresses.

  • AlainCo
    AlainCo Member Posts: 3
    First Anniversary Photogenic First Comment
    My problem was not ipV6, but lower layer, some Ethernet multicast packets were not received... driver was faulty...
  • sarahlizzy
    sarahlizzy Member Posts: 4
    Photogenic First Comment
    edited September 16, 2022 #84
    Update: It's the ethernet doing it. I'm using Belkin USB C multihub for my ethernet. If I pull the cable out and let Fing bind to WiFi, the warning goes away.
  • claudiolr
    claudiolr Member Posts: 10
    10 Comments Name Dropper Photogenic
    Unfortunately not for me. Fing desktop is connected to my WiFi network...