Ethernet Link Speed is not optimal

MGoeppl Member Posts: 2
Name Dropper First Comment
The warning says "Speed is less than Gigabit: 0.0 Mbps" on my Mac mini late 2018.
It is connected to a Gigabit switch (Cisco SG200-08) with a CAT7 cable.
The Mac mini is running macOS 10.15.4, and I have an identical model with the same specs connected to the same switch, which is displaying fine (1Gbps), can anyone help?
I tried a SMC and PRAM reset as well as a full networking reset on my machine.

Best Answer

  • MGoeppl
    MGoeppl Member Posts: 2
    Name Dropper First Comment
    #2 Answer ✓
    Thanks @kltaylor,
    I guess I found the problem: My Mac mini is connected to another Mac mini using Thunderbolt 3.
    Removing the "Router" IP address (the machine with the error) from the Thunderbolt network on System Preferences works, and the message disappears on refresh. 


  • kltaylor
    kltaylor Member, Beta Tester Posts: 1,231
    1000 Comments 500 Likes 50 Answers 100 Awesomes
    Hi @MGoeppl welcome to the community and thanks for asking your question.
    I received a message like that once, it told me that the Ethernet cable that I was using wasn't capable of obtaining a Gigabit connection.  Try changing the Ethernet cable to a Cat7 or Cat8 and ensure that the Fingbox is connecting directly to the Gateway/Router which should fix that issue.
    "There's a fine line between audacity and idiocy."
    -Warden Anastasia Luccio, Captain
    Robin_Ex_Fing[Deleted User]