New Fing Desktop Version 1.2.0

RobinRobin Administrator Posts: 1,719
100 Answers 1000 Comments 250 Likes 25 Agrees
admin


Hi All,

Today we have released a new version of Fing Desktop, Version 1.2.0. The new release includes:

  •  NEW! Added Insight view mode to visualize and explore discovered network from a new angle.
  •  NEW! Device details show information and shortcuts for smart home features and integrations: IFTTT, Google Assistant, Amazon Alexa, Apple HomeKit, HomeAssistant
  •  NEW! Green dots to mark online devices
  •  FIX: Shows additional IP addresses for devices in the table and in device details
  •  FIX: Shows also hostname when present, in device details

Thanks,
Ciaran, Robin & all the Fing team

Robin (Admin at Fing)
Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
Carlo_from_FingMarcPurplexmariaDiverkingbaergrizzSteph_R22nakedpwrleandroxizJdizzlesethbdw232ç
«1

Comments

  • Carlo_from_FingCarlo_from_Fing Rome, ItalyFing Team Posts: 245
    100 Likes 100 Comments 5 Answers 25 Awesomes
    ✭✭✭
    Please let us know how you like the new features. The new Insights view is available from below button.


    And will show you statistics and overviews about your network. Very useful the SmartHome section which lets you know about capabilities of your smart home devices, listing devices able to work with Smart Home capabilities like voice assistants and smart home automations such as IFTTT and HomeAssistant.


    Carlo from Fing

    RobinMarcRodgerJdizzle
  • MarcMarc Moderator, Beta Tester Posts: 1,132
    100 Answers 1000 Comments 500 Likes 100 Awesomes
    ✭✭✭✭✭✭
    @Carlo_from_Fing, the more ways I can slice and dice my data, the better...  Appreciate the iteration on the desktop product.  Also discovered that I own way too any Apple devices!
    Thats Daphnee, she's a good dog...
    Carlo_from_Fing
  • RodgerRodger Member Posts: 5
    Photogenic Name Dropper First Comment
    A couple of things that I thought I should mention though I acknowledge my situation in not typical.   Not specific to 1.2.0 of course, but will the many improvements of late the root cause issue is becoming glaring.

    I live in Saddlebrooke, AZ and in my area  "last-mile" broadband provider is Orbitel.  Orbitel in turn connects to CenturyLink Tucson, AZ (or perhaps Phoenix where Orbitel is based) for access to the internet backbone.  In my area , CenturyLink provides a lot of DSL service but not much (if any) direct broadband last-mile service that I'm aware of.  As a consequence, the Fing info reported for my network is wrong in two fundamental ways.  Perhaps nothing can be done and granted, this situation may be a relatively atypical.  Regardless, I thought I should share:

    1.  The "Home Network" and "Connected To" are reported as "CenturyLink Tucson" and "CenturyLink" on the Fing home page.  I would instead like to see these factoids reported:  "Last Mile Internet Service Provider: Orbitel" and "Internet Backbone Access Provider: CenturyLink Tucson". 

    2. The Connectivity info now shown in Fing is apparently based on CenturyLink DSL service in this area.  So for me, all the data points reported are way wrong.  For example, the average download and upload speeds reported are 20 and 9 respectively.  For me, correct figures would be closer to 200 and 20.  I believe the root cause of this issue is that many ISPs provide both DSL and broadband last mile services.  Meanwhile, Fing currently does not discriminate as to which service the Fing user has.
    Lmac
  • StuartukStuartuk Member, Beta Tester Posts: 1
    First Comment Photogenic
    edited April 1
    Hi, liking the new Desktop app. Only slight problem is then when aut-starting at Windows startup I get this error. It doesn't seem to affect operation and I just dismiss it. Could it be a problem with not having a correct certificate installed? 
    Update - I've un-installed and then re-installed the app, and so far the problem seems to have gone away!

  • ThatGuyThatGuy Member Posts: 1
    First Comment
    edited April 8
    I haven't been able to completely nail it down yet, but it appears to me that the Fing Desktop application is causing the Windows DNS Client to do so many lookups that it's taking 4% of my CPU all the time.  Shutting down Fing seems to have stopped it.  But restarting Fing didn't cause the behavior to immediately resume.  This is a laptop that connects to networks over WiFI, a docking station wired connection, and using a VPN connection, so it's possible that maybe Fing got into a confused state.  Shutting it down and bringing it back may have cleared the issue.  I'll keep monitoring it.

    UPDATE: Yep, not only does Fing desktop itself take too many resources, but it is directly responsible for the DNS client going bonkers too.  I've had to completely disable it, unfortunately.
    Robin
  • ThorathomeThorathome Member, Beta Tester Posts: 9
    5 Likes Photogenic First Comment
    I've been happy with Fing Desktop, have 1.2.0 now. It Starts up automatically on Windows boot, and no problems at all. Thanks.  
    Tweak: when editing a device name, Fing Desktop remembers the last device name the user entered and allows the user to edit the name. However, when starting from the default device name, Fing Desktop starts with a blank name field. I suggest FD start with the default device name, instead of a blank, for fewer keystrokes. Defaults are often, at least, half accurate. 
    I like
    the QR scan approach for device information. Quick and easy. Thanks.   
    I am curious about Win Fing Desktop's access to Fingbox info on other networks. I am not at home, happy to use the Win Fin App, but cannot(?) see my Fingbox (on another network, true) info from the Win FIng Desktop. Instead, I use the Fing App on iOS or Android - I have both.  
    Thanks for all you do. Love your work.  
  • GianmarcoGianmarco Member Posts: 10
    Photogenic First Comment
    Good day! When I install it on My Mac witch Catalina it says iy cannot find the server and hangs at startup...:(
  • DiverkingDiverking Member Posts: 28
    10 Comments Photogenic Name Dropper
    edited April 4
    Nice work can we also get some insight information what's coming up in next releases?
    Or better, vote on your backlog if you work Agile :wink:
  • baergrizzbaergrizz Member, Beta Tester Posts: 5
    First Comment Photogenic
    I love these new views... sadly, Gaming is the top use case in my house due to the quarantining. 
    Keep up the great updates!
  • KEMKEM KansasMember, Beta Tester Posts: 8
    First Comment Photogenic
    Ths is a continuation of the thread regarding my inability to login that was originally posted in the v110 announcement thread,  I’ve updated to v120 and no matter what method I use to try to login to the Windows desktop app I get the attached error message that you requested a screenshot of before I could get support

    As I stated before, I’ve tried almost every release of the Windows Fing app and no matter which method I try using to login this is the error message I receive.  Thank you for your help.
  • BlowfishBlowfish Member Posts: 1
    First Comment Photogenic
    edited April 16
    I keep getting "Notifications" with a number icon, but when I click on it, notification is empty...
    (Note: v1.3.0 resolve this issue...)
  • RobinRobin Administrator Posts: 1,719
    100 Answers 1000 Comments 250 Likes 25 Agrees
    admin
    edited April 8
    Hi @KEM

    Initially, please try to set a different browser as default browser and then reboot the device and then check if the sign-in error comes or not?

    Can you try to reboot the windows device and then check? if restarting PC haven't help to resolve this behaviour, these commands may be useful to windows (to launch from Command Prompt as administrator): 

    Stop service command: sc stop Fing.Agent

    Start service command: sc start Fing.Agent

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • KEMKEM KansasMember, Beta Tester Posts: 8
    First Comment Photogenic

    I should have said that I have tried with multiple browsers and the computer has been rebooted many times as I've tried each update from the first available version. Every time I have this same problem. I don't even know anymore how many times I've uninstalled, rebooted, installed, rebooted, tried both login methods using multiple browsers each time with this exact same result. I've also completely disabled my anti-virus and firewall as well as tried many other things that I thought if from tinge to time. Just put the login on the front page of the ASP and get rid of this silly browser/clipboards login, PLEASE. :)

    I'm considering running a trace in the installer to see where it touches the Registry then compare that to what the uninstaller leaves lasting around. Before I start a technical analysis of this in going you can suggest something that will work.


    Thank you - KEM

  • DocJacksonDocJackson Member Posts: 5
    Name Dropper First Comment Photogenic
    There's a problem with the new release that may have been a problem in older releases and I didn't notice. My IP address is on a 172.16.x.x/22 subnet, but on the Home page my network is described as a 192.168.0.0/22. I have a secondary IP that I use for configuring a switch, but it's on 192.168.0.0/24 subnet, not /22. I'd post screen shots but that's not possible from the clipboard. 
  • filbertfilbert Member Posts: 11
    First Answer First Comment Photogenic
    edited April 9
    One of my Macs just did an update to 1.3.0 but it's not mentioned here. The other is not showing any sign of an update. Is it genuine?
  • RobinRobin Administrator Posts: 1,719
    100 Answers 1000 Comments 250 Likes 25 Agrees
    admin
    Hi All, 
    Yes, We have a new version with major bug fixes and some new enhancements. Please refer these release logs: https://community.fing.com/discussion/3955/fing-desktop-release-notes-log/p1?new=1
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • KEMKEM KansasMember, Beta Tester Posts: 8
    First Comment Photogenic
    Hello,
    I just downloaded v1.3.0 and I’m getting the exact same authorization error as I have in every release.  I’ve tried everything you have suggested.  I really want this to work, I use it extensively on my iOS devices and love it.  Can someone PLEASE help me getting Fing Desktop for Windows to work.  Any ideas would be greatly appreciated, I’m desperate to get this working.  Is there any official support I should be communicating with with beyond what is available here?  I have been trying to participate in the beta and use the desktop app since the first version released.  There must be something about my Windows environment or my network topology that is preventing the app from authenticating properly.

    Please Help! - KEM
  • SECSEC Member Posts: 12
    10 Comments Photogenic
    Version 1.3 is unstable on my system (Win 10 Pro) keeps coming up to scan again or hangs. Didn't have problems with V1.2
  • KEMKEM KansasMember, Beta Tester Posts: 8
    First Comment Photogenic
    edited April 12

    Thank for the info, that is good to know. In my case though I've never been able to get any version of Fing Desktop to work. I've tried most if not every release and I just get the authorization error. I've posted about it a few tines but the ewe replies are very basic canned responses then when I follow up with any details requested the silence becomes deafening. It seems there us no real support if your problem isn't the most basic and easily resolved. It is very disappointing because I love my Fingbox and I use it often on my iOS devices. Sadly I'm giving up reporting the issue, I'll just try each new release hoping the issue has been resolved.


    Regards - KEM

  • RodgerRodger Member Posts: 5
    Photogenic Name Dropper First Comment
    Just tried to load version 1.3 of the app, in Windows 10 Pro (all updates applied), my fist attempt.  There's a sub-second indication that the app is loading (the Windows hourglass shows) and then nothing.  Versions 1.1.0 and 1.2.0 worked.
  • KEMKEM KansasMember, Beta Tester Posts: 8
    First Comment Photogenic

    Thanks. In my case though no version of Fing Desktop has ever worked and I can't get anything but the most basic help and unfortunately I have never been able to use the app, sigh.


    • KEM
  • Long_John_SliverLong_John_Sliver Member, Beta Tester Posts: 9
    5 Likes Photogenic First Comment
    Fing Desktop (1.3.0) works fine for me, but I keep getting notifications that my wired network isn't working at Gigabit speeds, just at 100MBS speed. I can understand how this would be a concern if I were running a Gigabit LAN, but I don't have Cat-6 cabling in my LAN and am not about to pull new cable throughout my house; yet there is no way I can tell Fing to stop alerting me on this "problem." That is, let me accept the notification, killing it for the future. Maybe version 1.3.1 can fix this bug (which you probably think of as a feature).
  • MayaMaya Member, Beta Tester Posts: 37
    5 Answers 10 Comments 5 Awesomes 5 Likes
    ✭✭✭
    @Long_John_Sliver the option was introduced recently as matter of fact it's there yet: you enter the report, you click on the (?) of the warning you want to mute, and in the informational popup about the warning you get the option in the buttons at the bottom.
    Definitely agree that was needed! I have an old windows PC with 100Mbit network adapter and was annoying.

    RobinLong_John_Sliver
  • RobinRobin Administrator Posts: 1,719
    100 Answers 1000 Comments 250 Likes 25 Agrees
    admin
    Hi @KEM @SEC @Roger

    Can you try to reboot the windows device and then check? if restarting PC haven't help to resolve this behaviour,  it may the case that the Fing Agent service has not been installed correctly. This can be verified by making the following commands from the command line (cmd) :


    1. sc query Fing.Agent - (it should return to service status)
    2. %ProgramFiles\resources\fingagent.exe --version - (it should return the installed version of the Fing Agent)


    If the commands are successful I recommend a new installation of the Fing Desktop. Also, please perform these commands may be useful to windows (to launch from Command Prompt as administrator): 

    Stop service command: sc stop Fing.Agent

    Start service command: sc start Fing.Agent

    If the issue persists, to help isolate the issue, please perform the following steps:

    Share the agent log: To access the agent log files:

      1. Click on the Fing Desktop version in the bottom-left hand side of the screen

      2. This will display two folders to open. We will need specific files from each of these folders.

      3. Firstly, click on 'Open App Log Folder'

      4. When the folder opens, we will now need to compress and share the log.log file (titled 'log' - all lowercase). To compress and share: right click on the file; choose 'Send to' & then choose 'Compressed zip folder'.

      5. Please attach both compressed files and DM me @Robin


    Also, please copy and paste the following URL into your browser "http://127.0.0.1:48080/getFingagentinfo". This will then display device information. Please copy and paste the text into your reply e-mail to us.







    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
    KEM
  • SECSEC Member Posts: 12
    10 Comments Photogenic
    Robin -
    Http://127.0.0.1 etc. follows. Also attached log file and a PDF showing the error I get, often.  The command didn't work for me...   :/


    agentinfo
    agentVersion"1.3.0"
    clientId"DW-00:25:22:A7:89:3C"
    clientName"BlackCat"
    clientPlatform"Windows"
    clientPlatformVer"10 Pro"
    clientPlatformBuild"18363"
    recogPort"51529"
    fingEndpoint"api.fing.com"

  • RobinRobin Administrator Posts: 1,719
    100 Answers 1000 Comments 250 Likes 25 Agrees
    admin
    Hi @SEC
    Are the logs updated because if I open the log file, the Fing agent is still of version 1.1.0? Can you try to completely uninstall the Fing desktop application and make sure all traces are removed for it. You can use Iobit Uninstaller for this or any other third party software and download a fresh version of Fing desktop and install it. Thanks
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
  • SECSEC Member Posts: 12
    10 Comments Photogenic
    OK. Uninstalled and installed fresh download. I'll let you know if the problems continue.
  • SECSEC Member Posts: 12
    10 Comments Photogenic
    Well that didn't take long, <5 minutes. Got the same error as I sent you previously. I've attached the "log" file. Http://127.0.0.1 follows-


    agentinfo
    agentVersion"1.3.0"
    clientId"DW-00:25:22:A7:89:3C"
    clientName"BlackCat"
    clientPlatform"Windows"
    clientPlatformVer"10 Pro"
    clientPlatformBuild"18363"
    recogPort"55215"
    fingEndpoint"api.fing.com"

  • SECSEC Member Posts: 12
    10 Comments Photogenic
    Robin,
    Didn't see if the "log" file made it with the comment. Here it is again.
  • KEMKEM KansasMember, Beta Tester Posts: 8
    First Comment Photogenic
    Robin,

    I’m sorry for the delay in seeing your message.  I will follow your instructions and get back to youas soon as I can.  I’m away all day again tomorrow so hopefully I can get it to you Friday.

    Again, my apologies for the delay and thank you very much for the help.

    Regards,
    KEM
Sign In or Register to comment.