Speed Test is no longer working properly

KingKing Member Posts: 15
10 Comments 5 Likes Photogenic

Lately after the recent app updates the Mlab speed test is no longer detecting the location and for some reason. It keeps using Washington DC (US). Download and upload test don't even show any numbers at all. Can you please look into this issue? I am located in Toronto Ontario Canada and not Washington DC.


Thanks,

King

Best Answers

  • kltaylorkltaylor Moderator, Beta Tester Posts: 1,191
    1000 Comments 500 Likes 50 Answers 100 Awesomes
    ✭✭✭✭✭✭
    Accepted Answer
    As you can see ... albeit barely it looks like, my internet connected detected the location and tested properly.  Try uninstalling and reinstalling the app and let me know if you receive the same result from that.

    "There's a fine line between audacity and idiocy."
    -Warden Anastasia Luccio, Captain
  • KingKing Member Posts: 15
    10 Comments 5 Likes Photogenic
    Accepted Answer

    I used the link you provided and it is the same... Washington DC. I have already confirmed the time zone and the address in my phone Fing app and Fing Desktop app. This issue all started shortly after one of the most recent updates. Please see attached screen shot from Mlabs....

    Thank you


    kltaylor
  • RobinRobin Administrator Posts: 2,312
    100 Answers 1000 Comments 250 Likes 25 Agrees
    admin
    Accepted Answer
    I believe M-lab changes something on their end. I go in touch with M-lab and got this reply:

    Sorry that you've been experiencing this issue. The reason you've experienced this is due to our automated load management on our servers. We limit the number of concurrent tests per location in order to assure a high standard of measurement quality, which has the effect of limiting some test clients to not run. In Toronto, we have also been working to upgrade our servers and add additional infrastructure to support the increasing volume of tests and higher speed customer connections. 

     
     

    We have implemented a change based in part on your report, which we think will reduce the number of times this happens for you. With respect to the Fingbox integration, there is a change that they might be able to make to further mitigate this issue for their clients. We will let them know about it. 

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
    kltaylorKing

Answers

  • kltaylorkltaylor Moderator, Beta Tester Posts: 1,191
    1000 Comments 500 Likes 50 Answers 100 Awesomes
    ✭✭✭✭✭✭
    Hi @King, have you tried reinstalling the desktop app and rescanned?
    I'm attempting to recreate the issue and will post my findings here shortly.
    "There's a fine line between audacity and idiocy."
    -Warden Anastasia Luccio, Captain
    King
  • KingKing Member Posts: 15
    10 Comments 5 Likes Photogenic

    I uninstalled it and reinstalled and it works now.

    Thanks for the quick fix

    kltaylor
  • kltaylorkltaylor Moderator, Beta Tester Posts: 1,191
    1000 Comments 500 Likes 50 Answers 100 Awesomes
    ✭✭✭✭✭✭
    You're welcome, @King.  Glad that it all worked out for you.
    "There's a fine line between audacity and idiocy."
    -Warden Anastasia Luccio, Captain
  • KingKing Member Posts: 15
    10 Comments 5 Likes Photogenic

    It's back again showing Washington DC US and I am in Stoney Creek, Ontario Canada. Not sure what is causing this issue with Mlab speed tests for my Fingbox.

  • RobinRobin Administrator Posts: 2,312
    100 Answers 1000 Comments 250 Likes 25 Agrees
    admin
    King said:

    It's back again showing Washington DC US and I am in Stoney Creek, Ontario Canada. Not sure what is causing this issue with Mlab speed tests for my Fingbox.

    Can you check if the Time zone is set correctly on the Fing App? Also, Can you please check if M-Lab speed test is the same from link below?
    https://speed.measurementlab.net/#/

    That is the partner we use for speed measurement, so if Fing results are not in line with the ones reported by M-Lab, we definitely have to fix something.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides("Helping Hand"). HAPPY POSTING!!!
    kltaylor
  • KingKing Member Posts: 15
    10 Comments 5 Likes Photogenic
    edited April 2

    Thank you for looking into that for me. I guess there is not much Fing can do at this moment? I will wait for the change to complete. Can you provide an update and follow up with Mlab from time to time on this? Fing speed test feature is useless at the moment due to the latency of such a far away server and is not accurate reading. Speedtest.net is providing a more accurate test for me at the moment and is consistent for this region.

    Thank you again for looking into the matter

    Robinkltaylor
Sign In or Register to comment.