Should I enable static IP addresses for this speaker?

Hi. In this screenshot from the Fing Beta Desktop App for Windows you can see the same LAN IP showing up for two different MAC addresses. What I think is going on is that the powerline Ethernet connection has a problem so the speaker tries to switch to WiFi but somehow ends up with the same IP. At that point the connection drops and I have to reboot the speaker, which then reconnects to Ethernet. I don't want to change my AT&T gateway settings if I don't have to but am wondering if setting static IP's for those 2 network adapters inside this speaker would help. Any comments appreciated.

Best Answer

  • ScoobyScooby Posts: 74
    25 Likes 5 Answers 10 Comments 5 Awesomes
    ✭✭✭
    edited February 9 Accepted Answer
    Not sure if you tried this already, but found this, in the manual:
    p.69 - "Wi-Fi/Ethernet - Port deactivation method - Press WPS button on the product for 30 seconds to turn Wi-Fi/Ethernet On / Off".
    And found this, too:
    p.70 - "The product will restart automatically if you turn on/off Wi-Fi/Ethernet". It, also, mentions "(If using LAN cable, you'd better to use STP type. - WAM550, WAM551, WAM350, WAM351 Only)". If you have the WAM750, as Fing shows, then you should be ok (not need STP cable).
    Strange that it only mentions the ethernet connection and how to turn it off or on, at the very end of the manual (not mentioned in the "setup" section). It would, also, appear to use either Wi-Fi or Ethernet only, but not both at the same time. However, as you explain, it seems to still try to connect via Wi-Fi first. Then, again, I may not have the correct manual for your device. Anyhow, hope this helps.

    TemosheeCiaran

Answers

  • MarcMarc Posts: 724Moderator, Beta Tester
    500 Likes 50 Answers 500 Comments 100 Agrees
    ✭✭✭✭✭

    Do you need both connections active? Could you disable WiFi and just maintain the power line Ethernet one? Or vise versa, just keep the WiFi active?

    Thats Daphnee, she's a good dog...
    Temoshee
  • TemosheeTemoshee Posts: 18Member
    10 Comments First Answer Name Dropper Photogenic
    edited February 9
    There is not an obvious way to disable WiFi. I tried a factory reset and for the initial setup connected only to Ethernet without entering WiFi credentials but when there is a powerline Ethernet hiccup (probably from the clothes dryer) it tries to connect to Wifi and then disconnects. You gave me an idea though. Maybe it I added the WiFi connection it would switch back and forth. I put in on Ethernet in the first place to reduce the load on WiFi and the location is not that good for WiFi anyway. I could set it to WiFi only, which is pretty much its purpose, I think they just bolted that Ethernet connection on as a marketing gimmick, but I was hoping to keep the Ethernet connection. 

    Subsequent update via edit:  Nope. I just added the Wifi and the gateway still assigns the same IP to both. Oddly the Fing Beta desktop app does not show this as a "Last change."
  • TemosheeTemoshee Posts: 18Member
    10 Comments First Answer Name Dropper Photogenic
    Hi @Scooby  Wow, thanks for all that research. I've been digging around for a while and had not see that note about pressing the WPS button to turn off the Wifi. I will give it a try. Best regards.
    Ciaran
Sign In or Register to comment.