Wake On Lan - Not working

jnc
jnc Member, Beta Tester Posts: 23
Second Anniversary 10 Comments Name Dropper Photogenic
Hi,

I'm having problems getting WOL to work with a desktop through my FingBox.  Here are the scenarios:
  • When I am off my network, requesting a WOL through the FindApp/Box does not wake my PC;
  • VPN'ing onto my network, requesting a WOL through the FindApp/Box does not wake my PC;
  • VPN'ing onto my network, requesting a WOL through my routers UI works and does wake my PC;
  • When I am on my my network WOL work and does wake my PC.  I am assuming this may be because it is the app and not the box that is requesting the wake.
For all of the above I have tried with the device setting against 'Automatic Wake on LAN' on and off.  To be honest I'm not sure what this setting does.
Anyone any ideas?  Happy to help diagnose further if it helps.

Cheers,
Jon C
Tagged:

Best Answers

  • jnc
    jnc Member, Beta Tester Posts: 23
    Second Anniversary 10 Comments Name Dropper Photogenic
    #2 Answer ✓
    Thanks again Robin.  This now makes sense.  Just to cover off one of the other scenarios for completeness, should I not be able to issue a WOL request from the FingApp when I have VPN'd onto my network?
  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    #3 Answer ✓
    jnc said:
    Thanks again Robin.  This now makes sense.  Just to cover off one of the other scenarios for completeness, should I not be able to issue a WOL request from the FingApp when I have VPN'd onto my network?
    The objective of the VPN is to mask the real network. In your case, the Fing App will not be able to tell if you are connected to the local network or remote network if the VPN is on and thus the WOL wont work.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!

Answers

  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    Hi @jnc
    To address this "When I am off my network, requesting a WOL through the FindApp/Box does not wake my PC", you need to make many changes on your set up and originally we don't advise that as it is a major security risk and then anybody can wake up your device and get connected to it. We always prefer and advice the users to use WOL from a local location or use Automatic WOL from Fing App. Automatic WOL will be sent a wake-up packet as soon as it will detect the device as Offline when you are connected to your Fingbox network.
    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
    OKC
  • jnc
    jnc Member, Beta Tester Posts: 23
    Second Anniversary 10 Comments Name Dropper Photogenic
    Hi Robin,

    Thanks for the prompt response.  By having a FingBox I though that I would have a secure way into my network, through the Fing App, in order to then 'ask' the FingBox to send the wake packet.  Is this not the case?  Are you also able to explain further how the Automatic WOL works please?  The PC in question, whilst it in sleep mode, is not showing as offline.

    Thanks,
    Jon C
  • Robin_Ex_Fing
    Robin_Ex_Fing Member Posts: 5,293
    5000 Comments 250 Answers 500 Likes 100 Awesomes
    ✭✭✭✭✭✭✭
    jnc said:
    Hi Robin,

    Thanks for the prompt response.  By having a FingBox I though that I would have a secure way into my network, through the Fing App, in order to then 'ask' the FingBox to send the wake packet.  Is this not the case?  Are you also able to explain further how the Automatic WOL works please?  The PC in question, whilst it in sleep mode, is not showing as offline.
    Unfortunately, that is not the case, Fingbox does not provide a way to get securely in your network. It is a monitoring device. Also, WOL packets are sent from the Fing App and not the Fingbox. Automatic WOL checks for the state change based on the state change time interval set for the device and as soon as it detects the device as offline then sents the magic packet to keep the device online.
    In your case, I believe you are using a windows PC.  If thats the case, then you need to disable the ARP Offload option in the Advanced Options of the NIC driver in Device Manager (see attached screenshot).
    On Windows, a wired Ethernet adapter will continue to respond to ARP requests while in sleep if offloading is enabled (which it is by default on almost all adapters that support it). By disabling ARP Offload, the machine no longer responds to ARP requests while in sleep and Fingbox correctly sees it as offline.

    Robin (Admin at Fing)
    Getting Started? Please refer to Community guidelines & Community User Guides. HAPPY POSTING!!!
  • jnc
    jnc Member, Beta Tester Posts: 23
    Second Anniversary 10 Comments Name Dropper Photogenic
     :) Thanks Robin.
  • AlTyndall
    AlTyndall Member Posts: 10
    Second Anniversary Photogenic Founder First Comment
    ✭✭
    Hi. I'm having the same issue as the original post. Perhaps my needs are slightly different, but I'll detail them here in case anyone can help...

    I have a headless Win 10 PC at home, which I can access when on the network using RDP. I can also access it from outside my network by using a VPN to get "into" my network (I tried using port forwarding with disastrous consequences - RDP ports are commonly attacked by naughty people on the internet. Thankfully it was only during a test stage so I just wiped the ransomware hacked Win7 PC!). When connected by VPN I'm assigned an IP by the router which is on the same subnet as all of the other devices including the FingBox and the PC I want to wake, so it wouldn't take much for the Fing App/Box to recognise that I am on the same network, albeit at a different layer (L2TP).
    I see the bit about automatically waking devices for when I'm not on the network. However, I don't want the PC running all of the time - eco conscious! I do want it to go to sleep until I need to use it, either internally or externally. I can wake it no problem using the Fing App on my iPhone/iPad while at home, but I can't make it wake by using the Fing App while outside the home, regardless of whether I'm using the VPN. I would love it if I could use the Fing App to WoL the PC on demand from outside the network. Then when I'm finished working on it I'll put it to sleep, knowing I'm saving a bit of leccy and can wake it again when I need to.
    If I can do functions remotely using the Fing App talking to my FingBox (such as Bandwidth Analysis and Internet Performance), why can't the Fing App ask the FingBox to send the magic packet?

    It'd be a lovely function to be able to include - I read today's email informing of the new Desktop App and WoL feature with anticipation, but was disappointed that remote WoLing still wasn't possible.
    jnc
  • RG314
    RG314 Member Posts: 3
    First Anniversary First Comment Photogenic
    Robin said:
    jnc said:
    Hi Robin,

    Thanks for the prompt response.  By having a FingBox I though that I would have a secure way into my network, through the Fing App, in order to then 'ask' the FingBox to send the wake packet.  Is this not the case?  Are you also able to explain further how the Automatic WOL works please?  The PC in question, whilst it in sleep mode, is not showing as offline.
    Unfortunately, that is not the case, Fingbox does not provide a way to get securely in your network. It is a monitoring device. Also, WOL packets are sent from the Fing App and not the Fingbox. Automatic WOL checks for the state change based on the state change time interval set for the device and as soon as it detects the device as offline then sents the magic packet to keep the device online.
    In your case, I believe you are using a windows PC.  If thats the case, then you need to disable the ARP Offload option in the Advanced Options of the NIC driver in Device Manager (see attached screenshot).
    On Windows, a wired Ethernet adapter will continue to respond to ARP requests while in sleep if offloading is enabled (which it is by default on almost all adapters that support it). By disabling ARP Offload, the machine no longer responds to ARP requests while in sleep and Fingbox correctly sees it as offline.

    Robin, I must say that your response is quite surprising: first, I never thought that my FingBox is a potential security threat to my home network(!) Moreover, once you allow enabling the "Auto WOL" feature from remote (i.e. when the phone running the Fing app is accessing the FingBox from the Internet), you effectively allow the very same "remote WOL" operation that you apparently consider a "security hazard" (when enabling Auto WOL, FingBox should immediately wake up the PC/device as it is switched off). So, I'd suggest that you: 1) make sure the Fing app/FingBox combination is secure; 2) enable the "manual" remote WOL feature since, as explained, it is not riskier than the Auto-WOL feature, but is much more straight-forward and useful in many situations.