Fing Desktop Beta: DNS Failures

MAscoobyMAscooby Member, Beta Tester Posts: 7
Name Dropper First Comment Photogenic
edited December 2019 in Fing Desktop discussions
Fing desktop (v0.5.27) consistently reports failed DNS lookups. I'm using Pihole as my local DNS server, and I see the requests successfully forwarded by Pihole, but Fing Desktop still reports the lookup as failing.
EDIT: The app just updataed to v0.6.0 and the behavior is the same -- DNS tests still fail.

Answers

  • Carlo_from_FingCarlo_from_Fing Rome, ItalyAdministrator, Fing Team Posts: 247
    100 Likes 100 Comments 5 Answers 25 Awesomes
    ✭✭✭
    Several other beta testers use pi-hole and it works good.
    To be 100% sure we installed in lab and tested both from Mac and from Windows, and the health check works good.
    You should check your pi-hole configuration maybe.


    Carlo from Fing

  • MAscoobyMAscooby Member, Beta Tester Posts: 7
    Name Dropper First Comment Photogenic
    Thanks. I suspect the issue's with my Windows 10 systems, or maybe how Pihole is responding to queries from those systems. I'm not seeing any DNS issues when browsing web sites or using other applications, but nslookup from a Command prompt is also timing out.
    Carlo_from_Fing
  • Carlo_from_FingCarlo_from_Fing Rome, ItalyAdministrator, Fing Team Posts: 247
    100 Likes 100 Comments 5 Answers 25 Awesomes
    ✭✭✭
    Did you configure only the Pi hole or also a secondary?
    In the latter, maybe it's going to the secondary. Moreover we saw that pi-hole shows active devices sending data, in one of the left menu sections, maybe you can check there if this windows laptop is correctly using or having issue.
    We did test with Windows 10 Pro as well.

    Carlo from Fing

  • JohnJohn Member Posts: 108
    25 Likes 10 Comments 5 Awesomes 5 Agrees
    ✭✭✭
    I can second i use pihole and dont get failed dns lookups.  Have you tried disabling pihole and testing?
    I agree with @Carlo_from_Fing it could be your network has some conflicts with the DNS its dishing out I would suggest removing any secondary ones.
  • MAscoobyMAscooby Member, Beta Tester Posts: 7
    Name Dropper First Comment Photogenic

    It’s apparently something to do with Windows. Resolution from the Command prompt behaves similarly, and it seems to happen on two Windows 10 systems on my network (haven’t checked a third yet).

    I have only one Pihole, but it’s configured as both primary and secondary in the router. The Windows laptop is configured to get DNS from the router, and the Fing Desktop only has issues when using Pihole. If I set it to use Cloudflare it works fine.

    I haven’t really played around with it much yet, but I’ll report back if/when I figure it out.

  • MAscoobyMAscooby Member, Beta Tester Posts: 7
    Name Dropper First Comment Photogenic
    edited January 3
    This morning I updated my configuration & dropped the secondary DNS entries (IPv4 and IPv6) on my eero router. I also enabled eero Secure+ malware protection (which uses Zscaler DNS). As of right now, all checks are passing, but I’ll keep an eye on it to see if it’s stable. Probably should’ve changed one thing at a time, but I can narrow it down later and disable eero Secure+ to see if Pihole forwarding to Cloudflare is the issue.

    EDIT: I’m guessing I still have an issue... nslookup from my Windows Command prompt is still timing out:

    C:\>nslookup www.stanford.edu
    DNS request timed out.
        timeout was 2 seconds.
    Server:  UnKnown
    Address:  *.*.*.* <— Redacted IP of my Pihole server

    DNS request timed out.
        timeout was 2 seconds.
    DNS request timed out.
        timeout was 2 seconds.
    DNS request timed out.
        timeout was 2 seconds.
    DNS request timed out.
        timeout was 2 seconds.
    *** Request to UnKnown timed-out

  • mozarellamozarella Member, Beta Tester Posts: 108
    25 Likes 10 Comments First Anniversary 5 Awesomes
    ✭✭✭
    maybe you could do "pihole restartdns" to do a restart of pihole dns engine. I also had some trouble these days and this solved my problem.
  • JohnJohn Member Posts: 108
    25 Likes 10 Comments 5 Awesomes 5 Agrees
    ✭✭✭
    @MAscooby the Server should show as 'pi-hole', I suspect you cant ping your dns so try the following and see where you fall over:
    1) try pinging your redacted dns from cmd (i.e. ping 192.168.x.x) - if it fails dump a ipconfig /all
    2) if you get a response, try disabling pihole from the pihole gui and try the nslookup again 
    3) if its still failing then can you screenshot your dns settings from pihole as I think the problem will lie there.

  • MAscoobyMAscooby Member, Beta Tester Posts: 7
    Name Dropper First Comment Photogenic
    @mozarella I’ve restarted (and rebooted) Pihole several times; no dice.
    @John I can ping the IP address. If i disable Pihole, all DNS lookups fail for everything on the network. There’s no secondary configured anywhere, and my gateway router (which is providing DHCP services) is handing out the Pihole & nothing else. 
    I haven’t had time to play with it much, but I’m pretty confident the issue is with my Windows systems, not Pihole. If I connect one of my Windows 10 systems to a VPN, nslookup from the command line still fails:
    C:\>nslookup www.cnn.com
    DNS request timed out.
        timeout was 2 seconds.
    Server:  UnKnown
    Address:  *.*.*.* <— Redacted IP address of my VPN provider‘s DNS server
    DNS request timed out.
        timeout was 2 seconds.
    DNS request timed out.
        timeout was 2 seconds.
    DNS request timed out.
        timeout was 2 seconds.
    DNS request timed out.
        timeout was 2 seconds.
    *** Request to UnKnown timed-out

  • JohnJohn Member Posts: 108
    25 Likes 10 Comments 5 Awesomes 5 Agrees
    ✭✭✭
    if you disable pihole and all the dns lookups fail, I suspect pihole is not configured correctly.  What upstream servers do you have selected?

    See mine below:

      


  • MAscoobyMAscooby Member, Beta Tester Posts: 7
    Name Dropper First Comment Photogenic
    edited January 14
    I meant that if I actually disable Pihole as a DNS server, then there’s no DNS server to respond to queries or to forward queries, so everything fails. If I just stop Pihole from blocking and let it forward everything, then nothing changes from what I’ve been describing. 

    My configuration’s essentially the same as yours (I’m using Cloudflare for my upstreams), but the local domain functionality’s hamstrung by limitations of my eero network & how it handles local domains within the DHCP scope. I get around that by statically mapping a limited subset of hosts in the hosts file on the Pi.
  • MAscoobyMAscooby Member, Beta Tester Posts: 7
    Name Dropper First Comment Photogenic
    One other note: At the moment, I’ve got eero Secure+ enabled on my mesh network, so any DNS queries destined for Cloudflare (or any other upstream DNS that I might choose) will be intercepted by eero and proxied to Zscaler. If I disable that and allow forwarding to Cloudflare or another upstream then, still, there’s no change in the behavior I’m observing.
  • JohnJohn Member Posts: 108
    25 Likes 10 Comments 5 Awesomes 5 Agrees
    ✭✭✭

    Do you have any manual setup is windows for your adapter? Also are you only connecting on one adapter (I.e wired or wireless not both)?


    and ipconfig /all dump would be helpful

Sign In or Register to comment.