Delayed Exit Notifications

JohnnieGadget
JohnnieGadget Member Posts: 6
First Answer First Comment Photogenic

I’m (trying to) use my Fingbox with an IFTTT integration to Hubitat to send mode changes to my home hub, allowing it to modify behavior accordingly. The integration is working flawlessly, EXCEPT Fingbox delays exit notifications by 20mins. Entry (WiFi connect) notifications are sent immediately. Obviously, I don’t want Hubitat to wait 20mins before turning off lights or turning down the heat. I looked at Fingbox settings to see if there’s a way to modify the away delay, but can’t find it. I’ve confirmed that the delay is definitely on Fingbox side, because it sends an “away” email as well when a family member comes or goes. The exit notifications actually identify the correct time of departure, but are sent 20mins later. Entry notifications are received within seconds!!

I appreciate anyone’s thoughts or experiences!

Best Answer

  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 250 Awesomes
    ✭✭✭✭✭✭
    #2 Answer ✓
    It's on the device level!
    Should be available when you click into the device.
    Notifications -> stage change timeout. (Automatic - would be the default 20 minutes)
    You can lessen this down to 1 minutes. 

    Community Manager at Fing

Answers

  • kltaylor
    kltaylor Member, Beta Tester Posts: 1,231
    1000 Comments 500 Likes 50 Answers 100 Awesomes
    ✭✭✭✭✭✭
    That is odd, indeed.
    What steps have you taken towards resolving this on your own?  I'd like some more information to consider before jumping in, not that what you have provided isn't detailed.  I just wonder after you discovered the issue, what steps you may have taken to find the resolve on your own.
    "There's a fine line between audacity and idiocy."
    -Warden Anastasia Luccio, Captain
  • JohnnieGadget
    JohnnieGadget Member Posts: 6
    First Answer First Comment Photogenic

    Well, I’ve confirmed that my IFTTT integration with both Fingbox and Hubitat are working, and that it’s Fingbox delay in reporting my absence that’s causing the issue. Not sure how to change notification options in Fingbox app (if I can). Thanks for your feedback though!

    VioletChepil
  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 250 Awesomes
    ✭✭✭✭✭✭
    Hi @JohnnieGadget
    What is the delay set on the device?
    This thread should be of use: https://community.fing.com/discussion/1170/device-presence-delayed-emails
    You know, we have a bit of a delay on default notifications to avoid false positives for example. 
    What is the state change timeout set for the device?

    Community Manager at Fing

  • JohnnieGadget
    JohnnieGadget Member Posts: 6
    First Answer First Comment Photogenic

    My app settings don’t have a “timeout” option. Am I missing something??


    VioletChepil
  • JohnnieGadget
    JohnnieGadget Member Posts: 6
    First Answer First Comment Photogenic

    Violet, THANK YOU so much for the response, and providing the solution to my perplexing question. I never even thought to administer the timeout at the device level. Now that I understand, it’s totally logical to be able to have different notification delays for different devices. For example, my wife tends to our gardens in the summer, so it’s very possible that if she brought her phone outside, it would temporarily lose connection to our LAN. For that reason, I may wish to set her at 5-10 mins in the summer, and back to 1 at this time of the year. Brilliant design, like all things that I’ve experienced so far on Fingbox. Thanks again!!

    VioletChepil
  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 250 Awesomes
    ✭✭✭✭✭✭
    Thanks a lot @JohnnieGadget and so great to hear this feedback!
    Cheers

    Community Manager at Fing