Persistent Device

Dez
Dez Member Posts: 12
First Comment Photogenic
Morning All, please are there any ghostbusters out there?  I had a Linux Ubuntu laptop that seemed to access the internet even after I turned it off.  I have now disposed of the laptop and installed Fingbox.  Now, whenever I connect any laptop by Ethernet, it shows up on Fing as the now defunct Linux machine (MAC 00:50:B6:18:72:8D Good Way, Taiwan).  Naturally, every time I blocked it, I was just blocking myself!  I can use Wi-Fi okay, but fear that the apparent persistence of the Linux device may mean I have some kind of ghost in the system? Hope someone can help, Cheers Dez. 
VioletChepil

Best Answer

  • Hronos
    Hronos Member, Beta Tester Posts: 289
    100 Likes 100 Comments Second Anniversary 25 Awesomes
    ✭✭✭✭
    #2 Accepted Answer
    @Dez, "USB/Ethernet adapter" has it's own MAC Address, is this the same adapter used by your old linux machine? (just curious) 
    Keep looking up!
    VioletChepil

Answers

  • Shadow54
    Shadow54 Member Posts: 1
    First Comment

    I could make ssure it has the same ip address as your lapqtop and try to change the name

    VioletChepil
  • narwhal
    narwhal Member Posts: 1
    First Comment

    Wake on network?

    VioletChepil
  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Thanks @Dez
    I wonder if @Marc @kltaylor @Hronos @Pixelpopper @Crowgrandfather @Pooh can help us further as to why.
    This could be something like a remote server the device is accessing for firmware upgrades?
    Would that be a possibility? 
    I know that Ubuntu core (which is what Fingbox is run on) can perform remote/auto upgrade for new firmwares. 

    Community Manager at Fing

  • Hronos
    Hronos Member, Beta Tester Posts: 289
    100 Likes 100 Comments Second Anniversary 25 Awesomes
    ✭✭✭✭
    I have no clue! xD hehehe.
    That's an interesting behavior you are getting out there...
    Could you try to get a response from that MAC Address (by it's reported IP on FingApp) to see if there is a connection indeed?
    The other idea I have is that the MAC Address is not of a host (Laptop) but a switch or other device on your network than became "alive" when using an Ethernet device. Are you connecting the laptop to the router directly?, through a switch?, is the only device attached to LAN ports?, Could you try more than one laptop/desktop at the same time?
    Keep looking up!
    VioletChepil
  • Hronos
    Hronos Member, Beta Tester Posts: 289
    100 Likes 100 Comments Second Anniversary 25 Awesomes
    ✭✭✭✭
    Sorry one more, I am not an expert on Linux, but have you "migrated" your old Linux configuration to the new laptop?.
    Maybe, this is just a thought, Linux is setting the MAC Address by itself (there is a way to "report" a custom address) and it copied from the old machine.
    Keep looking up!
    VioletChepil
  • Dez
    Dez Member Posts: 12
    First Comment Photogenic
    Hi Hronos, Thank you for your help and sorry, I should have said that Fing is seeing the MAC address that the old Linux laptop had previously reported itself as having.  Also, it only appears to Fing (and gets blocked) when I connect any laptop using Ethernet wired via Powerline to router LAN socket.  (The only other thing plugged into router LAN is Fingbox).  I completely destroyed and disposed of the Linux (except hard-drive), so I don't think it will still be accessing the network?  Nevertheless, and please forgive my ignorance, but how and when should I try to get a response from this MAC address using its IP address?
    I have blocked 5 laptops (one at a time) that all appear to Fing with the old Linux MAC address when connected by Ethernet cable as above.  I can connect them by wi-fi via a Powerline Access Point, but I'm worried that the old Linux may have somehow infected my router or laptops with malware.  My Chromebooks have been Powerwashed and I have not consciously migrated any configuration from the now deceased Linux.
    Any advice gratefully appreciated.
    Cheers, Dez.  
    VioletChepil
  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Hi @Dez
    Can you assign a static IP address to Fingbox and then remove the linux devices and run the scan again?
    This should resolve things for you. 
    How to assign a Static IP address to Fingbox? You'll need to assign the static IP address from your router settings page. Assigning Static IP addresses to most devices is easy. Just go to the network settings on your router, look for DHCP option and turn it OFF. Once you do that, you'll see a text area to enter Static IP address. Enter a new IP address for Fingbox there and save changes.

    If you need any more help, let me know and I'll be happy to assist further. 
    Let me know!
    Cheers,
    Violet

    Community Manager at Fing

  • Hronos
    Hronos Member, Beta Tester Posts: 289
    100 Likes 100 Comments Second Anniversary 25 Awesomes
    ✭✭✭✭
    @Des could you try to connect the Laptop directly to a LAN port on the router? (if what @VioletChepil recommend doesn't help)
    Keep looking up!
    VioletChepil
  • [Deleted User]
    [Deleted User] Posts: 0
    100 Comments 25 Likes First Anniversary Member of the Month
    ✭✭✭
    Hi Dez, I think @VioletChepil is on the right track. Did you previously set a static IP address (for your old laptop) on your router as, if you did, it’s certainly possible that an old IP address is causing problems. I have had experience where a device had no outgoing network access due to an IP address & MAC address being linked & corrupted. I resolved the issue by removing any static addresses from the router DHCP table, rebooted & router. If all else fails a factory reset of the router may sort it.
    BEFORE you try the above scan those old drives for viruses & malware (malwarebytes is a good malware detection & removal tool) & any reputable A/V software should be sufficient.
    VioletChepil
  • Dez
    Dez Member Posts: 12
    First Comment Photogenic
    Hi Violet, Hronos & Pixelpopper.  Thank you all for your help.  For some reason, it seems I had already put all the IP addresses into Static DHCP.  Taking them all out didn't help, nor did putting just Fingbox back in.  Nor did rebooting or factory resetting the router, nor connecting the laptop directly to the router using only a USB/Ethernet adaptor.
    One laptop reported itself as having the correct wi-fi MAC address, but when on Ethernet it reported itself as having the old Linux MAC address, (which doesn't appear anywhere when ifconfig is expanded).  Next stop malwarebytes.
    Cheers, Dez.   
  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Hm Ok @Dez
    I wonder if this is related location permissions. 
     Can you also try these steps? 

    Can you check the app settings and make sure location is set to ALWAYS (for best performance)?
    This allows Fing app to read network name etc. on iOS 13 and Android 10. 

    To make sure all permissions are enabled correctly: 
    • Set location permissions to ALWAYS in app settings
    • Open Fing App and go to ‘Network’ tab
    • Click on the ISP name and it will open the Network page
    •  Clear out the Network information such as Address
    • Next, to the MAP section, there is a small icon to auto-detect location. Click on the icon 
    • Try scanning again 
    Let me know if that changes anything. 

    Community Manager at Fing

  • Dez
    Dez Member Posts: 12
    First Comment Photogenic
    Hi Violet, Hronos & Pixelpopper.  Oops!  Hronos was absolutely right, the USB/Ethernet adaptor even has the "suspect" MAC address printed on it!  I guess the old Linux must have been connected to the adaptor when it reported itself as having this MAC address.  (I don't regret destroying the old Linux, as I was concerned that it did not have a radio kill switch).
    Thank you all so much for your help and advice, it has been a real education for me.
    Cheers, Dez. 
    VioletChepilHronos
  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Thanks @Dez and please post any future problems with your network and devices on Fing Community!
    As we want to make this your dedicated troubleshooting smart home resource. 
    Cheers!
    Violet

    Community Manager at Fing