Internet pause not working for YouTube app

My can still watch youtube videos on a Samsung S8 phone when he is on block device schedule - his browser does not connect to anything. In the network settings he only has an IPv4 address, however my router has IPv6 which cannot be disabled. How Can I block access to YouTube streams?

Answers

  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Hi @Kai
    A bit more details on streaming. It should eventually block this, depending on how much is loaded in advance. Could it be the person is still downloading this in advance? If so, there isn't much we can do for that scenario...

    Applications, such as Youtube, will often download packets of data in advance so as to make the use of them smoother. You will see this on Youtube in the bar along the bottom of the video. The line in red indicates how far through the video you are, but you will also see a grey line further ahead of the red – this grey line shows you where the application is in downloading the data. As this data has already reached your device and does not require the Internet to watch,  when the Internet is paused Youtube will continue to play the video until the red line catches up with the grey line. When it catches this up the video will stop working as Youtube is unable to access the Internet to download more data.

    This catch-up process can sometimes take a minute or so, so if you want to know immediately if an Internet Pause has worked try refreshing or opening a new screen.

    Let me know! 

    Community Manager at Fing

    kltaylor
  • Kai
    Kai Member Posts: 7
    Photogenic First Comment
    Hi Violet,
    I checked and the reason is not buffering - in the test below a laptop which is paused on fing has an IPv4 address recognized by fingbox and when pinging google.com or youtube an IPv6 address responds, pinging a host that does not respond on IPv6 will result in a timeout. I understand that fingbox does not block IPv6 traffic - but my modem does not have an option to disable this protocol. Is getting my own router the only way around this?
    Pinging google.com [2607:f8b0:400b:801::200e] with 32 bytes of data:
    Reply from 2607:f8b0:400b:801::200e: time=56ms
    Reply from 2607:f8b0:400b:801::200e: time=21ms
    Reply from 2607:f8b0:400b:801::200e: time=38ms
    Reply from 2607:f8b0:400b:801::200e: time=24ms
    Ping statistics for 2607:f8b0:400b:801::200e:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 21ms, Maximum = 56ms, Average = 34ms

    C:\Users\erikw>ping ksta.de

    Pinging ksta.de [35.190.93.140] with 32 bytes of data:
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.

  • VioletChepil
    VioletChepil London, UKMember Posts: 2,471
    100 Answers 500 Likes 1000 Comments 100 Agrees
    ✭✭✭✭✭✭
    Ok thanks @Kai for this detailed response and explanation.
    There isn't any way around IPv6 as disabling IPv6 is required for this feature because it leverages ARP.
    I am not sure any other workaround. I know a few users have gone through the ISP/router support and succeeded in getting them to remotely disable. Other than that I'm afraid I don't have any more suggestions...

    Community Manager at Fing

  • Hronos
    Hronos Member, Beta Tester Posts: 289
    100 Likes 100 Comments Second Anniversary 25 Awesomes
    ✭✭✭✭
    The only suggestion is to disable the protocol on each device instead, you can try this in the devices you are mostly to have to block, not sure if that could be done in a Phone...
    Keep looking up!
    VioletChepil